Skip to content
Snippets Groups Projects
Commit 6040b079 authored by Holger Jaekel's avatar Holger Jaekel :map: Committed by Kevin Daudt
Browse files

community/cfitsio: upgrade to 4.5.0

parent 1b5cae09
No related branches found
No related tags found
1 merge request!74829community/cfitsio: upgrade to 4.5.0
......@@ -6,10 +6,10 @@ Summary: under musl, off_t is always 64-bit
+++ b/fitsio.h
@@ -88,16 +88,7 @@
/* Debian systems require: "(defined(linux) && defined(__off_t_defined))" */
/* Debian systems require: "(defined(__GLIBC__) && defined(__off_t_defined))" */
/* the mingw-w64 compiler requires: "(defined(__MINGW32__) && defined(_OFF_T_DEFINED))" */
-#if defined(_OFF_T) \
- || (defined(linux) && defined(__off_t_defined)) \
- || (defined(__GLIBC__) && defined(__off_t_defined)) \
- || (defined(__MINGW32__) && defined(_OFF_T_DEFINED)) \
- || defined(_MIPS_SZLONG) || defined(__APPLE__) || defined(_AIX)
-# define OFF_T off_t
......@@ -19,6 +19,6 @@ Summary: under musl, off_t is always 64-bit
-# define OFF_T long
-#endif
+#define OFF_T off_t
/* this block determines if the the string function name is
/* this block determines if the the string function name is
strtol or strtoll, and whether to use %ld or %lld in printf statements */
Author: Holger Jaekel <holger.jaekel@gmx.de>
Summary: set destination of *.cmake and *.pc files
----
--- a/CMakeLists.txt.orig
+++ b/CMakeLists.txt
@@ -359,7 +359,7 @@
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cfitsio.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/cfitsio.pc @ONLY)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cfitsio-config.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/cfitsio-config.cmake @ONLY)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cfitsio-config-version.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/cfitsio-config-version.cmake @ONLY)
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cfitsio.pc DESTINATION ${LIB_DESTINATION}/lib/pkgconfig/)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cfitsio.pc DESTINATION ${LIB_DESTINATION}/pkgconfig/)
install(FILES ${CFITSIO_BINARY_DIR}/cfitsio-config.cmake
${CFITSIO_BINARY_DIR}/cfitsio-config-version.cmake
- DESTINATION ${LIB_DESTINATION}/lib/cfitsio-${CFITSIO_VERSION})
+ DESTINATION ${LIB_DESTINATION}/cmake/cfitsio-${CFITSIO_VERSION})
# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
maintainer="Holger Jaekel <holger.jaekel@gmx.de>"
pkgname=cfitsio
pkgver=4.4.1
pkgver=4.5.0
pkgrel=0
pkgdesc="Library reading and writing data files in Flexible Image Transport System data format"
url="https://heasarc.gsfc.nasa.gov/fitsio/"
......@@ -9,49 +9,49 @@ arch="all"
license="CFITSIO"
makedepends="
bzip2-dev
cmake
curl-dev
gfortran
samurai
"
subpackages="
$pkgname-static
$pkgname-dev
"
source="https://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/cfitsio-$pkgver.tar.gz
10-OFF_T.patch
add-loongarch64.patch
20-add-loongarch64.patch
30-lib_destination.patch
"
build() {
export CFLAGS="$CFLAGS -D_DEFAULT_SOURCE"
./configure \
--prefix=/usr \
--with-bzip2 \
--enable-reentrant \
--enable-sse2 \
--enable-hera
make shared
make utils
if [ "$CBUILD" != "$CHOST" ]; then
local crossopts="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=ON \
-DCMAKE_BUILD_TYPE=None \
-DUSE_PTHREADS=ON \
-DUSE_BZIP2=ON \
-DTESTS=ON \
-DUTILS=ON
$crossopts
cmake --build build
}
package() {
make DESTDIR="$pkgdir" install
# delete test/demo programs
rm "$pkgdir"/usr/bin/testprog
rm "$pkgdir"/usr/bin/cookbook
# avoid conflicts with smem
rm "$pkgdir"/usr/bin/smem
DESTDIR="$pkgdir" cmake --install build
}
check() {
LD_LIBRARY_PATH=. ./testprog > testprog.lis
[ -z "$(diff testprog.lis testprog.out)" ]
[ -z "$(cmp testprog.fit testprog.std)" ]
cd build
ctest
}
sha512sums="
a49e4e09a2e5f6e0ae823a68f02b3f6285cf3e0af66c9a1f8dadcd2867fa83c17fd27e446e8e5af9374ff2dc7b7a18334663ce977a1691c4ed4ced14d33232b7 cfitsio-4.4.1.tar.gz
4a1cf7cf6f7dbd44c91d8f0b7de5792b83786ffcb3e18188e1ed82c00fda420613e7442b7497d3867bcd6695438ce660ebf7563a60dfc4f48a3807712a69f7ec 10-OFF_T.patch
a74c929ab3fdb57af9f6efaf987ffe6fb1e70eeca9fdc3706a71ef26e9bb58e8d7cedee3eac4aa24c713e10b85de0feb6de79e6a0777d61045627c6f7ce2d7ce add-loongarch64.patch
03746bf49cfcd97991be54f3e4dd51fb45c7b3a75f581dc6ab9ee5726a342dc11b651667807fd67e5318576d9b15e3580dd62ceab02fd684feff7ee6bb2edc7c cfitsio-4.5.0.tar.gz
87b61f3cd01b5c34633d5c16681fa42594c2e56a2e850337a78e418c100f0081675a335a05b00e89d24258accfa5a4d4584d533ce6121346dbbfe961f5fffbe6 10-OFF_T.patch
a74c929ab3fdb57af9f6efaf987ffe6fb1e70eeca9fdc3706a71ef26e9bb58e8d7cedee3eac4aa24c713e10b85de0feb6de79e6a0777d61045627c6f7ce2d7ce 20-add-loongarch64.patch
444b0ccb82711ecdd94a779382aa0ed93fa3fffcb5c73b8705c5a2f760e11d70d9a43760f1878e81a33faa51ed936efbe7596e692480be9ff70a3eeaebb2a81f 30-lib_destination.patch
"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment