Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
6024a0fe
Commit
6024a0fe
authored
2 weeks ago
by
Michał Polański
Browse files
Options
Downloads
Patches
Plain Diff
community/py3-poetry-core: upgrade to 2.0.1
parent
ee204a2d
No related branches found
No related tags found
2 merge requests
!79570
community/firefox-esr: upgrade to 128.7.0
,
!78988
community/poetry: upgrade to 2.0.1
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/py3-poetry-core/APKBUILD
+8
-7
8 additions, 7 deletions
community/py3-poetry-core/APKBUILD
community/py3-poetry-core/fix-tests.patch
+34
-0
34 additions, 0 deletions
community/py3-poetry-core/fix-tests.patch
with
42 additions
and
7 deletions
community/py3-poetry-core/APKBUILD
+
8
−
7
View file @
6024a0fe
...
...
@@ -2,7 +2,7 @@
# Maintainer: Michał Polański <michal@polanski.me>
pkgname
=
py3-poetry-core
_pkgname
=
poetry-core
pkgver
=
1.9
.1
pkgver
=
2.0
.1
pkgrel
=
0
pkgdesc
=
"PEP 517 build backend implementation for Poetry"
url
=
"https://github.com/python-poetry/poetry-core"
...
...
@@ -21,11 +21,14 @@ checkdepends="
py3-pytest-mock
py3-setuptools
py3-tomli-w
py3-trove-classifiers
py3-virtualenv
python3-dev
"
subpackages
=
"
$pkgname
-pyc"
source
=
"
$_pkgname
-
$pkgver
.tar.gz::https://github.com/python-poetry/poetry-core/archive/
$pkgver
.tar.gz"
source
=
"https://github.com/python-poetry/poetry-core/archive/
$pkgver
/py3-poetry-core-
$pkgver
.tar.gz
fix-tests.patch
"
builddir
=
"
$srcdir
/
$_pkgname
-
$pkgver
"
build
()
{
...
...
@@ -39,10 +42,7 @@ check() {
export
CFLAGS
=
"
$CFLAGS
-Wno-error=int-conversion"
python3
-m
venv
--clear
--without-pip
--system-site-packages
.testenv
.testenv/bin/python3
-m
installer .dist/
*
.whl
.testenv/bin/python3
-m
pytest
\
--deselect
tests/masonry/builders/test_sdist.py::test_includes_with_inline_table
\
--deselect
tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
\
--deselect
tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
.testenv/bin/python3
-m
pytest
.testenv/bin/python3
-m
pytest
--integration
tests/integration
\
--deselect
tests/integration/test_pep517_backend.py::test_pip_install
}
...
...
@@ -57,5 +57,6 @@ package() {
}
sha512sums
=
"
9ca0aa68e4e7637e78b0a02cb3946b6efd29b91e99663f26fbb09736ff2fbfa13cd683337001b2200e3037e5d4adcd745bc6ff4c91a708880238f0b78719c281 poetry-core-1.9.1.tar.gz
5e578ae615da55b6e138b968e65b5090547807e06a1ba95bff40f8e42f4b86977bb939072df02e9ee76d3e58df250f6065c321d0e0934d1f061414856f2ab894 py3-poetry-core-2.0.1.tar.gz
f369a5a6ce6f9a52a6e2103ba7584d2362f1b338ccbca9e5aafd07475e43140c9c14dde6f6d580514196cce6ef90240960bf2627a8b86689e361831bb542ae6f fix-tests.patch
"
This diff is collapsed.
Click to expand it.
community/py3-poetry-core/fix-tests.patch
0 → 100644
+
34
−
0
View file @
6024a0fe
Patch-Source: https://github.com/python-poetry/poetry-core/commit/2f33eb0fd75a1876c721a6128ee1b6ee9846d62c
From 2f33eb0fd75a1876c721a6128ee1b6ee9846d62c Mon Sep 17 00:00:00 2001
From: Arun Babu Neelicattu <arun.neelicattu@gmail.com>
Date: Fri, 17 Jan 2025 13:35:53 +0100
Subject: [PATCH] fix(tests): clear SOURCE_DATE_EPOCH env var
Resolves: python-poetry/poetry#10011
---
tests/conftest.py | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/tests/conftest.py b/tests/conftest.py
index 7d10143f3..5ab1331cd 100644
--- a/tests/conftest.py
+++ b/tests/conftest.py
@@ -1,5 +1,6 @@
from __future__ import annotations
+import os
import sys
import tempfile
@@ -120,3 +121,10 @@
def with_mocked_get_vcs(mocker: MockerFixture) -> None:
"poetry.core.vcs.git.Git.run", return_value="This is a mocked Git.run() output."
)
mocker.patch("poetry.core.vcs.get_vcs", return_value=Git())
+
+
+@pytest.fixture(autouse=True)
+def clear_env_source_date_epoch() -> None:
+ """Clear SOURCE_DATE_EPOCH from environment to avoid non-deterministic failures"""
+ if "SOURCE_DATE_EPOCH" in os.environ:
+ del os.environ["SOURCE_DATE_EPOCH"]
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment