Skip to content
Snippets Groups Projects
Commit 5ea2bd7d authored by alice's avatar alice
Browse files

community/hydrogen: fix implicit decl, dev warning

parent 1a9d65fb
No related branches found
No related tags found
No related merge requests found
From f1aef07dbac734640dae28e99512e5e3f4b9a957 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Sun, 5 Feb 2023 13:01:50 +0000
Subject: [PATCH] rtclock: fix implicit sleep declaration
otherwise clang16 fails to compile this code, and detects this as false
---
cmake/rtclock/rtclock.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/cmake/rtclock/rtclock.c b/cmake/rtclock/rtclock.c
index 851e78dc..439be41f 100644
--- a/cmake/rtclock/rtclock.c
+++ b/cmake/rtclock/rtclock.c
@@ -1,6 +1,7 @@
#include <stdio.h>
#include <time.h>
#include <stdint.h>
+#include <unistd.h>
int main( int argc, char** argv, char** env ) {
uint64_t dt;
struct timespec t0,t1;
--
2.39.1
......@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hydrogen
pkgver=1.1.1
pkgrel=0
pkgrel=1
pkgdesc="Advanced drum machine for GNU/Linux"
url="http://www.hydrogen-music.org/"
arch="aarch64 armv7 ppc64le x86 x86_64" # armhf limited by qt5-qtxmlpatterns
......@@ -10,7 +10,6 @@ license="GPL-2.0-or-later"
makedepends="
alsa-lib-dev
cmake
cppunit-dev
flac-dev
jack-dev
ladspa-dev
......@@ -23,8 +22,14 @@ makedepends="
qt5-qtxmlpatterns-dev
samurai
"
checkdepends="cppunit-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="hydrogen-$pkgver.tar.gz::https://github.com/hydrogen-music/hydrogen/archive/$pkgver.tar.gz"
source="hydrogen-$pkgver.tar.gz::https://github.com/hydrogen-music/hydrogen/archive/$pkgver.tar.gz
0001-rtclock-fix-implicit-sleep-declaration.patch
nodevel.patch
"
# tiny float differences
options="!check"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
......@@ -34,14 +39,16 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=MinSizeRel \
$CMAKE_CROSSOPTS .
-DCMAKE_BUILD_TYPE=None \
-DWANT_CPPUNIT="$(want_check && echo ON || echo OFF)"
-DWANT_DEBUG=OFF \
-DVERSION_SUFFIX=alpine \
$CMAKE_CROSSOPTS
cmake --build build
}
check() {
cd build
CTEST_OUTPUT_ON_FAILURE=1 ctest
./build/src/tests/tests
}
package() {
......@@ -50,4 +57,6 @@ package() {
sha512sums="
c5e6bd713a0f9ef3b30bf0ae00bc41fea7494c20342c14c9f41ec05d1fdd3be721ffc3ff92bacd011e3b39a68022ea04daf55e60d334f64a00abef17d892cd37 hydrogen-1.1.1.tar.gz
6cce04b14b862c0ffc057f9e15a32ef0acece984eca91ce06ebb6bee42b66eb60dfe83ea1673e749fdf70b0983931299fcdc9d98fe5ab68cd9e4f45ff904d4fa 0001-rtclock-fix-implicit-sleep-declaration.patch
9135b7c4ec4818df3e28f9dfcc3d8a88f407ffd0a74ebc8ad0a29f91d514d667db93f03cc4f7cfaa65e4034c6f2270ec574ad32d79679e8b012a6f0c1bf13f7c nodevel.patch
"
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aebce40..f9d155b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,7 +34,7 @@ EXECUTE_PROCESS(COMMAND git describe --exact-match --tags OUTPUT_VARIABLE GIT_TA
IF(GIT_TAG)
SET(IS_DEVEL_BUILD "false")
ELSE()
- SET(IS_DEVEL_BUILD "true")
+ SET(IS_DEVEL_BUILD "false")
ENDIF()
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment