Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
5d49990b
Commit
5d49990b
authored
1 year ago
by
Jakub Jirutka
Browse files
Options
Downloads
Patches
Plain Diff
community/yofi: upgrade to 0.2.2
parent
e3f9fee6
No related branches found
No related tags found
1 merge request
!63207
community/yofi: upgrade to 0.2.2
Pipeline
#223006
passed with warnings
1 year ago
Stage: verify
Changes
3
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
community/yofi/APKBUILD
+7
-17
7 additions, 17 deletions
community/yofi/APKBUILD
community/yofi/bump-png.patch
+0
-16
0 additions, 16 deletions
community/yofi/bump-png.patch
community/yofi/getrandom-0.2.10.patch
+0
-38
0 additions, 38 deletions
community/yofi/getrandom-0.2.10.patch
with
7 additions
and
71 deletions
community/yofi/APKBUILD
+
7
−
17
View file @
5d49990b
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname
=
yofi
pkgname
=
yofi
pkgver
=
0.2.
0
pkgver
=
0.2.
2
pkgrel
=
2
pkgrel
=
0
pkgdesc
=
"A minimalistic menu for wayland"
pkgdesc
=
"A minimalistic menu for wayland"
url
=
"https://github.com/l4l/yofi"
url
=
"https://github.com/l4l/yofi"
# riscv64: TEXTREL
# riscv64: TEXTREL
...
@@ -14,29 +14,21 @@ makedepends="
...
@@ -14,29 +14,21 @@ makedepends="
cargo-auditable
cargo-auditable
fontconfig-dev
fontconfig-dev
freetype-dev
freetype-dev
libxkbcommon-dev
wayland-dev
wayland-dev
"
"
source
=
"https://github.com/l4l/yofi/archive/
$pkgver
/yofi-
$pkgver
.tar.gz
source
=
"https://github.com/l4l/yofi/archive/
$pkgver
/yofi-
$pkgver
.tar.gz"
bump-png.patch
getrandom-0.2.10.patch
"
# font-fontkit loads fonts via system libraries.
_cargo_opts
=
"--frozen --no-default-features --features=font-fontkit"
prepare
()
{
prepare
()
{
cargo fetch
--target
=
"
$CTARGET
"
--locked
cargo fetch
--target
=
"
$CTARGET
"
--locked
default_prepare
cargo fetch
--target
=
"
$CTARGET
"
# update after applying patches
}
}
build
()
{
build
()
{
cargo auditable build
$_cargo_opts
--release
cargo auditable build
--frozen
--release
}
}
check
()
{
check
()
{
cargo
test
$_cargo_opts
cargo
test
--frozen
}
}
package
()
{
package
()
{
...
@@ -44,7 +36,5 @@ package() {
...
@@ -44,7 +36,5 @@ package() {
}
}
sha512sums
=
"
sha512sums
=
"
d4f386252682e1990b637b31732eeea34f02296dd63199e58f637861fd8f33ef712400c536131a5069068c1096a89b5369688255b5cca391d6fbe4d35832ddf6 yofi-0.2.0.tar.gz
2854c9884aee083f213d6edf66ab8287d10d6eae21b1da2e93f6d0e9bcc655cd5078473b5fa9b5bfce28ab38a86fb870236a707281f6b87d529a71ee97bda0c8 yofi-0.2.2.tar.gz
b9f4fc2df6cd7f11e87cc8fb0cabaa97e421f97016bddddc9a00a4c5a7f417f8f70768b7f9a89587015bb81d04b12810f5241b533828d9dbac58affc5ede1194 bump-png.patch
0542b9bec964c4e2f096a20257519ad212a3d0015e3a53522dd0f75760c6d98434d4537c489c02f77a81407d8f1fc6c2cb0141902d511deabd0daf11e148f549 getrandom-0.2.10.patch
"
"
This diff is collapsed.
Click to expand it.
community/yofi/bump-png.patch
deleted
100644 → 0
+
0
−
16
View file @
e3f9fee6
Patch-Source: https://github.com/l4l/yofi/pull/131
--
From b1ca3181afcd7aa39186b3e358890cd03dd52082 Mon Sep 17 00:00:00 2001
From: Jakub Jirutka <jakub@jirutka.cz>
Date: Wed, 19 Oct 2022 21:58:36 +0200
Subject: [PATCH] Bump png to 0.17.6
The new version dropped dependency on a quite big encoding crate.
diff --git a/Cargo.toml b/Cargo.toml
index d9a1e64..7227979 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -33 +33 @@
serde = { version = "1.0.131", features = ["derive"] }
-png = { version = "0.17.2", default-features = false }
+png = { version = "0.17.6", default-features = false }
This diff is collapsed.
Click to expand it.
community/yofi/getrandom-0.2.10.patch
deleted
100644 → 0
+
0
−
38
View file @
e3f9fee6
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -717,9 +717,9 @@
[[package]]
name = "getrandom"
-version = "0.2.4"
+version = "0.2.10"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "418d37c8b1d42553c93648be529cb70f920d3baf8ef469b74b9638df426e0b4c"
+checksum = "be4136b2a15dd319360be1c07d9933517ccf0be8f16bf62a3bee4f0d618df427"
dependencies = [
"cfg-if",
"libc",
@@ -824,9 +824,9 @@
[[package]]
name = "libc"
-version = "0.2.135"
+version = "0.2.149"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "68783febc7782c6c5cb401fbda4de5a9898be1762314da0bb2c10ced61f18b0c"
+checksum = "a08173bc88b7955d1b3145aa561539096c421ac8debde8cbc3612ec635fee29b"
[[package]]
name = "libloading"
@@ -1860,9 +1860,9 @@
[[package]]
name = "wasi"
-version = "0.10.2+wasi-snapshot-preview1"
+version = "0.11.0+wasi-snapshot-preview1"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "fd6fbd9a79829dd1ad0cc20627bf1ed606756a7f77edff7b66b7064f9cb327c6"
+checksum = "9c8d87e72b64a3b4db28d11ce29237c246188f4f51057d65a7eab63b7987e423"
[[package]]
name = "wayland-client"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment