Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
5be78316
Commit
5be78316
authored
1 year ago
by
Francesco Colista
Browse files
Options
Downloads
Patches
Plain Diff
community/tilda: upgrade to 2.0.0
parent
4d55a9d8
No related branches found
No related tags found
1 merge request
!61741
community/tilda: upgrade to 2.0.0
Pipeline
#217361
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/tilda/0001-Fix-OOB-write-in-start_default_shell.patch
+0
-22
0 additions, 22 deletions
...ity/tilda/0001-Fix-OOB-write-in-start_default_shell.patch
community/tilda/APKBUILD
+5
-7
5 additions, 7 deletions
community/tilda/APKBUILD
with
5 additions
and
29 deletions
community/tilda/0001-Fix-OOB-write-in-start_default_shell.patch
deleted
100644 → 0
+
0
−
22
View file @
4d55a9d8
From 51a980a55ad6d750daa21d43a66d44577dad277b Mon Sep 17 00:00:00 2001
From: xtkoba <69125751+xtkoba@users.noreply.github.com>
Date: Sun, 24 Apr 2022 11:32:41 +0900
Subject: [PATCH] Fix OOB write in `start_default_shell()`
---
src/tilda_terminal.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/tilda_terminal.c b/src/tilda_terminal.c
index 84baab7..c9f613a 100644
--- a/src/tilda_terminal.c
+++ b/src/tilda_terminal.c
@@ -573,7 +573,7 @@
start_default_shell (tilda_term *tt)
*/
flags |= G_SPAWN_FILE_AND_ARGV_ZERO;
} else {
- argv = malloc(1 * sizeof(void *));
+ argv = malloc(2 * sizeof(void *));
argv[0] = default_command;
argv[1] = NULL;
}
This diff is collapsed.
Click to expand it.
community/tilda/APKBUILD
+
5
−
7
View file @
5be78316
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname
=
tilda
pkgname
=
tilda
pkgver
=
1.5.4
pkgver
=
2.0.0
pkgrel
=
2
pkgrel
=
0
pkgdesc
=
"A Gtk based drop down terminal for Linux and Unix"
pkgdesc
=
"A Gtk based drop down terminal for Linux and Unix"
url
=
"https://github.com/lanoxx/tilda"
url
=
"https://github.com/lanoxx/tilda"
arch
=
"all"
arch
=
"all"
...
@@ -11,9 +11,8 @@ depends="procps"
...
@@ -11,9 +11,8 @@ depends="procps"
makedepends
=
"automake autoconf libtool
makedepends
=
"automake autoconf libtool
confuse-dev vte3-dev libx11-dev libxml2-utils
confuse-dev vte3-dev libx11-dev libxml2-utils
pcre2-dev"
pcre2-dev"
subpackages
=
"
$pkgname
-lang"
subpackages
=
"
$pkgname
-lang
$pkgname
-doc"
source
=
"https://github.com/lanoxx/tilda/archive/tilda-
$pkgver
.tar.gz
source
=
"https://github.com/lanoxx/tilda/archive/tilda-
$pkgver
.tar.gz"
0001-Fix-OOB-write-in-start_default_shell.patch"
builddir
=
"
$srcdir
"
/
$pkgname
-
$pkgname
-
$pkgver
builddir
=
"
$srcdir
"
/
$pkgname
-
$pkgname
-
$pkgver
prepare
()
{
prepare
()
{
...
@@ -40,6 +39,5 @@ package() {
...
@@ -40,6 +39,5 @@ package() {
}
}
sha512sums
=
"
sha512sums
=
"
6982a14a89d148c04e08df0c7566ea7b3e340252fa1a3e434450443f7464e6805caee46afda9b385633a4b9c22d2f2d283641082a1e009f301c3a1bf508c3b29 tilda-1.5.4.tar.gz
e68c04e1c8dd862ab850a06036d67544a910ccd3143eb9d33171d551f34ef47445d6b387bf087ada6f3deddcf115ba928f3bb0497b8a3d2305b202b3b84fd476 tilda-2.0.0.tar.gz
0d35288b4527063a672d4d0cbd9a4da2636df1b4477ea5e654562d4e93f51a3d82ee3c24fe2eff792d190923f1136c0fc95630d6651d4245ca2ca0c2783c3aaa 0001-Fix-OOB-write-in-start_default_shell.patch
"
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment