Skip to content
Snippets Groups Projects
Commit 5aa73673 authored by Celeste's avatar Celeste Committed by Francesco Colista
Browse files

community/lastpass-cli: upgrade to 1.3.7

parent 180057dc
No related branches found
No related tags found
1 merge request!55240community/lastpass-cli: upgrade to 1.3.7
Pipeline #194378 skipped
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=lastpass-cli
pkgver=1.3.6
pkgver=1.3.7
pkgrel=0
pkgdesc="LastPass command line interface tool"
url="https://lastpass.com"
......@@ -22,9 +22,7 @@ subpackages="
$pkgname-bash-completion
$pkgname-fish-completion
"
source="$pkgname-$pkgver.tar.gz::https://github.com/lastpass/lastpass-cli/archive/v$pkgver.tar.gz
e3311cebdb29a3267843cf656a32f01c5062897e.patch
"
source="$pkgname-$pkgver.tar.gz::https://github.com/lastpass/lastpass-cli/archive/v$pkgver.tar.gz"
build() {
cmake -B build -G Ninja \
......@@ -55,6 +53,5 @@ package() {
}
sha512sums="
28c9cff15fe9433d2473b3bfc6d958115e0f49044ff13afe77b82c41b9a5efb78c657e9ed740b99df305693bdf2cacc0389318f10540e10774030405feabc998 lastpass-cli-1.3.6.tar.gz
0f624e6b83d7d193089b2b13d03f261dc8e9df88cafa9b295ad55a6242ef5cca65c2d8ecb3d7330034a1b3d1bfef4a76d5d07491439f0360ac285cba4f050de5 e3311cebdb29a3267843cf656a32f01c5062897e.patch
23128bf93f63c2d9154e533a3e15c3fea508fade151fe374327a2ae9994013f7b058c936e03753168be81bb19b22c217e88fc3e909b05658c6f827302c0be653 lastpass-cli-1.3.7.tar.gz
"
From e3311cebdb29a3267843cf656a32f01c5062897e Mon Sep 17 00:00:00 2001
From: Eric Engestrom <eric@engestrom.ch>
Date: Sun, 25 Oct 2020 09:49:29 +0100
Subject: [PATCH] Fix GCC 10+ build
GCC 10 changed the default option from `-fcommon` to `-fno-common`.
A quick and dirty fix could be to just set `-fcommon` in CMakeLists.txt,
but the proper fix is to move the variables to a single compilation unit
and simply reference them in the other CU, instead of each CU having its
own copy.
Signed-off-by: Eric Engestrom <eric@engestrom.ch>
---
process.c | 3 +++
process.h | 4 ++--
2 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/process.c b/process.c
index 59bdf10..8ccbf34 100644
--- a/process.c
+++ b/process.c
@@ -127,6 +127,9 @@ static int pid_to_cmd(pid_t pid, char *cmd, size_t cmd_size)
#error "Please provide a pid_to_cmd for your platform"
#endif
+int ARGC;
+char **ARGV;
+
void process_set_name(const char *name)
{
size_t argslen = 0;
diff --git a/process.h b/process.h
index 58c2480..4cc2cf4 100644
--- a/process.h
+++ b/process.h
@@ -4,8 +4,8 @@
#include <stdbool.h>
#include <sys/types.h>
-int ARGC;
-char **ARGV;
+extern int ARGC;
+extern char **ARGV;
void process_set_name(const char *name);
void process_disable_ptrace(void);
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment