Skip to content
Snippets Groups Projects
Commit 569cdb02 authored by Leo's avatar Leo
Browse files

main/jansson: upgrade to 2.13.1

parent b3401463
No related branches found
No related tags found
1 merge request!7565main/jansson: upgrade to 2.13.1
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=jansson
pkgver=2.12
pkgver=2.13.1
pkgrel=0
pkgdesc="lightweight JSON library"
url="http://www.digip.org/jansson/"
arch="all"
license="MIT"
checkdepends="bash"
subpackages="$pkgname-dev"
source="http://www.digip.org/jansson/releases/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
source="http://www.digip.org/jansson/releases/jansson-$pkgver.tar.bz2"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
......@@ -19,18 +18,17 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var
--localstatedir=/var \
--disable-static
  • @Leo out of interest why did you add the --disable-static flag? It broke some of our docker builds which statically linked against jansson. No worries we can work around it, just wondering if it was intentional.

  • Author Developer

    It removes the static library that we should not support by default as it is harder to get security fixes into.

    But we are willing to enable them if there are people that need it. Just open an issue asking for it or a Merge Request enabling it (along with adding $pkgname-static to subpackages= and mention it in the APKBUILD in the form a comment).

  • Thanks for the quick response. I'll take a look to see if I can contribute a MR, otherwise will open an issue.

  • I looked at a bunch of other APKBUILD files which have static as a subpackage and it seems pretty straight forward. However, I didn't come across any which had comments about the static build/package. What do you mean? This is what I have and will submit if there is no need for a comment.

    diff --git a/main/jansson/APKBUILD b/main/jansson/APKBUILD
    index 2e29bdae..db0a42aa 100644
    --- a/main/jansson/APKBUILD
    +++ b/main/jansson/APKBUILD
    @@ -7,7 +7,7 @@ url="http://www.digip.org/jansson/"
     arch="all"
     license="MIT"
     checkdepends="bash"
    -subpackages="$pkgname-dev"
    +subpackages="$pkgname-dev $pkgname-static"
     source="http://www.digip.org/jansson/releases/jansson-$pkgver.tar.bz2"
     
     build() {
    @@ -18,8 +18,7 @@ build() {
     		--sysconfdir=/etc \
     		--mandir=/usr/share/man \
     		--infodir=/usr/share/info \
    -		--localstatedir=/var \
    -		--disable-static
    +		--localstatedir=/var
     	make
     }
     
  • Author Developer

    the $pkgname-static should come before $pkgname-dev and pkgrel should be added by 1

  • Please register or sign in to reply
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="6ed665a441c789cdf7eb22b6e69d02575746c81b00e0a81ced90d30aaf2badc93fac32e5841fd4e07751a27726a327a63fe28bb0689c6bef5b6164b435bbc30d jansson-2.12.tar.bz2"
sha512sums="057f0eda43e4162569888d739f4d78d1d02fce8359400d8f66fdc6e440b0405cb457e1126820dc8ce51e9c4a7f4b7effc640caf1d54307c78c0c47c3fc093011 jansson-2.13.1.tar.bz2"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment