Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
554d171b
Commit
554d171b
authored
4 years ago
by
Andy Postnikov
Browse files
Options
Downloads
Patches
Plain Diff
community/libcouchbase: upgrade to 3.1.0
parent
35948534
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!14619
community/libcouchbase: upgrade to 3.1.0
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/libcouchbase/APKBUILD
+8
-6
8 additions, 6 deletions
community/libcouchbase/APKBUILD
community/libcouchbase/fix_libdir.patch
+10
-0
10 additions, 0 deletions
community/libcouchbase/fix_libdir.patch
with
18 additions
and
6 deletions
community/libcouchbase/APKBUILD
+
8
−
6
View file @
554d171b
# Contributor: Nathan Johnson <nathan@nathanjohnson.info>
# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
pkgname
=
libcouchbase
pkgver
=
2
.10
.9
pkgver
=
3
.1
.
0
pkgrel
=
0
pkgdesc
=
"C client library for Couchbase"
url
=
"https://developer.couchbase.com/community"
arch
=
"all"
license
=
"Apache-2.0"
depends_dev
=
"musl-dev openssl-dev snappy-dev"
makedepends
=
"
$depends_dev
cmake perl libtool libev-dev libevent-dev libuv-dev"
makedepends
=
"
$depends_dev
cmake perl libtool libev-dev libevent-dev libuv-dev
zlib-dev
"
subpackages
=
"
$pkgname
-dev
$pkgname
-utils
$pkgname
-doc
$pkgname
-libevent
$pkgname
-libev
$pkgname
-libuv"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/couchbase/libcouchbase/archive/
$pkgver
.tar.gz
fix_libdir.patch
fix_socktest.patch"
build
()
{
...
...
@@ -45,7 +46,7 @@ libevent() {
depends
=
"
$pkgname
libevent"
mkdir
-p
"
$subpkgdir
"
/usr/lib
mv
"
$pkgdir
"
/usr/lib/libcouchbase_libevent.so
"
$subpkgdir
"
/usr/lib
mv
"
$pkgdir
"
/usr/lib/libcouchbase
/libcouchbase
_libevent.so
"
$subpkgdir
"
/usr/lib
}
libev
()
{
...
...
@@ -53,7 +54,7 @@ libev() {
depends
=
"
$pkgname
libev"
mkdir
-p
"
$subpkgdir
"
/usr/lib
mv
"
$pkgdir
"
/usr/lib/libcouchbase_libev.so
"
$subpkgdir
"
/usr/lib
mv
"
$pkgdir
"
/usr/lib/libcouchbase
/libcouchbase
_libev.so
"
$subpkgdir
"
/usr/lib
}
libuv
()
{
...
...
@@ -61,7 +62,7 @@ libuv() {
depends
=
"
$pkgname
libuv"
mkdir
-p
"
$subpkgdir
"
/usr/lib
mv
"
$pkgdir
"
/usr/lib/libcouchbase_libuv.so
"
$subpkgdir
"
/usr/lib
mv
"
$pkgdir
"
/usr/lib/libcouchbase
/libcouchbase
_libuv.so
"
$subpkgdir
"
/usr/lib
}
utils
()
{
...
...
@@ -72,5 +73,6 @@ utils() {
amove usr/bin
}
sha512sums
=
"a0f7f18fdf9b30af1568d16f40ddfc5bf540ac3bd25f8441eb3a57231ac30a8179e1de3792a3d2eddd2193d447395c375051a6816c83ac0e86d0871900e0a856 libcouchbase-2.10.9.tar.gz
sha512sums
=
"a321685c387f98e09ef587623bf5c84af2840791c9f8eecb474f70b0b92d57af8fbc4199d67e0b30a05ce4a8300d5be80130b7818e8b14d1b932c2c43ad7eb1e libcouchbase-3.1.0.tar.gz
270123c57e6e760721ad337db154b8d90bddb81e38c644b854a36e2383fe95f3214227943e7040aa409d5d5ab101681369000054e4738c2a2d1facd0eee923e3 fix_libdir.patch
72319b86fdd91728723ccb091e72199788a84e2ec9ea12c0fcd1ed686eb155ec11e0addbff96735f83e7f31764a85650f0483b6e76d3a8bee16f71b2751fe4a9 fix_socktest.patch"
This diff is collapsed.
Click to expand it.
community/libcouchbase/fix_libdir.patch
0 → 100644
+
10
−
0
View file @
554d171b
--- a/cmake/configure
+++ b/cmake/configure
@@ -234,6 +234,7 @@
if ($PREFIX) {
push @CM_OPTIONS, "-DCMAKE_INSTALL_PREFIX=$PREFIX";
}
+push @CM_OPTIONS, "-DCMAKE_INSTALL_LIBDIR=lib";
if ($NO_TESTS) {
push @CM_OPTIONS, "-DLCB_NO_TESTS=1";
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment