Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
553b52b3
Commit
553b52b3
authored
3 years ago
by
Simon F
Committed by
Rasmus Thomsen
3 years ago
Browse files
Options
Downloads
Patches
Plain Diff
main/nagios-plugins: fix use-after-free in check_mysql_query
parent
23264eee
No related branches found
No related tags found
1 merge request
!20718
main/nagios-plugins: fix use-after-free in check_mysql_query
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/nagios-plugins/APKBUILD
+3
-1
3 additions, 1 deletion
main/nagios-plugins/APKBUILD
main/nagios-plugins/check_mysql_query-fix-use-after-free.patch
+33
-0
33 additions, 0 deletions
...nagios-plugins/check_mysql_query-fix-use-after-free.patch
with
36 additions
and
1 deletion
main/nagios-plugins/APKBUILD
+
3
−
1
View file @
553b52b3
...
@@ -4,7 +4,7 @@
...
@@ -4,7 +4,7 @@
# Maintainer: Jeff Bilyk <jbilyk@gmail.com>
# Maintainer: Jeff Bilyk <jbilyk@gmail.com>
pkgname
=
nagios-plugins
pkgname
=
nagios-plugins
pkgver
=
2.3.2
pkgver
=
2.3.2
pkgrel
=
1
pkgrel
=
2
pkgdesc
=
"Plugins for Nagios to check services on hosts"
pkgdesc
=
"Plugins for Nagios to check services on hosts"
url
=
"https://nagios-plugins.org"
url
=
"https://nagios-plugins.org"
arch
=
"all"
arch
=
"all"
...
@@ -29,6 +29,7 @@ pkggroups="nagios"
...
@@ -29,6 +29,7 @@ pkggroups="nagios"
options
=
"suid"
options
=
"suid"
source
=
"https://www.nagios-plugins.org/download/nagios-plugins-
$pkgver
.tar.gz
source
=
"https://www.nagios-plugins.org/download/nagios-plugins-
$pkgver
.tar.gz
fix-compilation-warnings-about-sys-poll.patch
fix-compilation-warnings-about-sys-poll.patch
check_mysql_query-fix-use-after-free.patch
check_openrc
check_openrc
nagios-openrc.sudoers"
nagios-openrc.sudoers"
...
@@ -151,5 +152,6 @@ _all() {
...
@@ -151,5 +152,6 @@ _all() {
sha512sums
=
"c73e13800ad408f9b345fbfc2142ae2275b77e4865ecdb9be33a86024c10be1e54e401450c3f7c848e96bd1152c723426477a1f2874e3bf5dd149f07391b1dd9 nagios-plugins-2.3.2.tar.gz
sha512sums
=
"c73e13800ad408f9b345fbfc2142ae2275b77e4865ecdb9be33a86024c10be1e54e401450c3f7c848e96bd1152c723426477a1f2874e3bf5dd149f07391b1dd9 nagios-plugins-2.3.2.tar.gz
7a62e4808eb8b07ca43bc17a625f4199708da6c52b79eca7a756817cb734648fc3054cd89862638ae925022017db32479d2cfcfddeba79ab4557d7b9ec97c323 fix-compilation-warnings-about-sys-poll.patch
7a62e4808eb8b07ca43bc17a625f4199708da6c52b79eca7a756817cb734648fc3054cd89862638ae925022017db32479d2cfcfddeba79ab4557d7b9ec97c323 fix-compilation-warnings-about-sys-poll.patch
0daff387c80d2132ec16b3d161e5fffe9e2cae1d3e08fc1c4e65b2bfdf4685c42fb129e4df92b08a17f250018f57eac39b2c8ff299ae378d4442681a88e39f9e check_mysql_query-fix-use-after-free.patch
12d87542631494df1c961e547c19107a025829509e174e8208111736141c12e20dbf490c55d487af39d47cefca5507cd98c973b7b20ae3f961dcbfd167195d8e check_openrc
12d87542631494df1c961e547c19107a025829509e174e8208111736141c12e20dbf490c55d487af39d47cefca5507cd98c973b7b20ae3f961dcbfd167195d8e check_openrc
171c9ad14d1027541b78df76063e6d34483dd536219fb83e0346e191739529d59c8d6be468af7f1c4c93b20baf9a32879510f15ec3d06aa1eefaf5d785ea8546 nagios-openrc.sudoers"
171c9ad14d1027541b78df76063e6d34483dd536219fb83e0346e191739529d59c8d6be468af7f1c4c93b20baf9a32879510f15ec3d06aa1eefaf5d785ea8546 nagios-openrc.sudoers"
This diff is collapsed.
Click to expand it.
main/nagios-plugins/check_mysql_query-fix-use-after-free.patch
0 → 100644
+
33
−
0
View file @
553b52b3
From: simon-alpine@fraho.eu
Subject: mysql_check_query crashes on alpine 3.13 after accessing free'd data
Upstream: reported
see https://gitlab.alpinelinux.org/alpine/aports/-/issues/12601
and https://github.com/nagios-plugins/nagios-plugins/issues/602
--- a/plugins/check_mysql_query.c
+++ b/plugins/check_mysql_query.c
@@ -143,17 +143,17 @@
die (STATE_CRITICAL, "QUERY %s: Fetch row error - %s\n", _("CRITICAL"), error);
}
- /* free the result */
- mysql_free_result (res);
-
- /* close the connection */
- mysql_close (&mysql);
-
if (! is_numeric(row[0])) {
die (STATE_CRITICAL, "QUERY %s: %s - '%s'\n", _("CRITICAL"), _("Is not a numeric"), row[0]);
}
value = strtod(row[0], NULL);
+
+ /* free the result */
+ mysql_free_result (res);
+
+ /* close the connection */
+ mysql_close (&mysql);
if (verbose >= 3)
printf("mysql result: %f\n", value);
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment