Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
5329d305
Commit
5329d305
authored
7 years ago
by
Leonardo Arena
Browse files
Options
Downloads
Patches
Plain Diff
testing/py-coreschema: new aport
parent
14f680b4
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/py-coreschema/APKBUILD
+59
-0
59 additions, 0 deletions
testing/py-coreschema/APKBUILD
testing/py-coreschema/use-system-py-test.patch
+5
-0
5 additions, 0 deletions
testing/py-coreschema/use-system-py-test.patch
with
64 additions
and
0 deletions
testing/py-coreschema/APKBUILD
0 → 100644
+
59
−
0
View file @
5329d305
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer:
pkgname
=
py-coreschema
_pkgname
=
${
pkgname
/py/python
}
pkgver
=
0.0.4
pkgrel
=
0
pkgdesc
=
"No description or topics provided"
url
=
"https://github.com/core-api/python-coreschema"
arch
=
"noarch"
license
=
"BSD"
depends
=
"py-jinja2"
makedepends
=
"python2-dev python3-dev py-setuptools"
checkdepends
=
"pytest"
options
=
"!check"
#currently broken
subpackages
=
"py2-
${
pkgname
#py-
}
:_py2 py3-
${
pkgname
#py-
}
:_py3"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/core-api/python-coreschema/archive/
$pkgver
.tar.gz
use-system-py-test.patch
"
builddir
=
"
$srcdir
"
/
$_pkgname
-
$pkgver
build
()
{
cd
"
$builddir
"
python2 setup.py
--quiet
build
python3 setup.py
--quiet
build
}
package
()
{
cd
"
$builddir
"
mkdir
-p
"
$pkgdir
"
/usr/bin
}
check
()
{
cd
"
$builddir
"
./runtests
}
_py2
()
{
depends
=
"
${
depends
//py-/py2-
}
"
_py python2
}
_py3
()
{
depends
=
"
${
depends
//py-/py3-
}
"
_py python3
}
_py
()
{
local
python
=
"
$1
"
local
pyver
=
"
${
1
:6:1
}
"
pkgdesc
=
"
$pkgdesc
(for
$python
)"
depends
=
"
$depends
$python
"
install_if
=
"
$pkgname
=
$pkgver
-r
$pkgrel
$python
"
cd
"
$builddir
"
$python
setup.py
--quiet
install
--prefix
=
/usr
--root
=
"
$subpkgdir
"
}
sha512sums
=
"28badbae07284fb4dbd3f01f613edda1202902115fb166bd95bbac549d398c9e02548b473524d3b530a42319a99d7e55e92bf54269827a9812249cfb285670c3 py-coreschema-0.0.4.tar.gz
044f95c17094d806e9cacd1bd9d8e358859b24fb0c27f97c47e3dd89f3f16b4151a7b8f47aadfa5e6ca664d185a16e45a947c4a88156a78217f17031191eda14 use-system-py-test.patch"
This diff is collapsed.
Click to expand it.
testing/py-coreschema/use-system-py-test.patch
0 → 100644
+
5
−
0
View file @
5329d305
--- a/runtests
+++ b/runtests
@@ -1,2 +1 @@
-export PYTHONPATH=.
py.test tests/ --cov=coreschema --cov-report html
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment