Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
4da29e81
Commit
4da29e81
authored
1 year ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
community/plan9port: fix O_LARGEFILE for aarch64
parent
134afcf9
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/plan9port/APKBUILD
+3
-1
3 additions, 1 deletion
community/plan9port/APKBUILD
community/plan9port/o_largefile.patch
+18
-0
18 additions, 0 deletions
community/plan9port/o_largefile.patch
with
21 additions
and
1 deletion
community/plan9port/APKBUILD
+
3
−
1
View file @
4da29e81
...
@@ -3,7 +3,7 @@
...
@@ -3,7 +3,7 @@
pkgname
=
plan9port
pkgname
=
plan9port
_commit
=
ffbdd1aa20c8a20a8e9dcd3cec644b6dfa3c6acb
_commit
=
ffbdd1aa20c8a20a8e9dcd3cec644b6dfa3c6acb
pkgver
=
0_git20220912
pkgver
=
0_git20220912
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Port of many Plan 9 libraries and programs to Unix"
pkgdesc
=
"Port of many Plan 9 libraries and programs to Unix"
url
=
"https://9fans.github.io/plan9port/"
url
=
"https://9fans.github.io/plan9port/"
arch
=
"all"
arch
=
"all"
...
@@ -15,6 +15,7 @@ subpackages="$pkgname-doc"
...
@@ -15,6 +15,7 @@ subpackages="$pkgname-doc"
source
=
"
$pkgname
-
$pkgver
-
$_commit
.tar.gz::https://github.com/9fans/plan9port/archive/
$_commit
.tar.gz
source
=
"
$pkgname
-
$pkgver
-
$_commit
.tar.gz::https://github.com/9fans/plan9port/archive/
$_commit
.tar.gz
no-html-man-pages.patch
no-html-man-pages.patch
libucontext.patch
libucontext.patch
o_largefile.patch
plan9.sh"
plan9.sh"
builddir
=
"
$srcdir
/
$pkgname
-
$_commit
"
builddir
=
"
$srcdir
/
$pkgname
-
$_commit
"
...
@@ -58,5 +59,6 @@ sha512sums="
...
@@ -58,5 +59,6 @@ sha512sums="
12889ca91d04cb623d44efb39196dca7591b4fb81f06e6b47bb07aae7aeff054191353ff44c8fd75c56505a42102c1ad7eb058e428b59c0d098c76df0ce6b7d4 plan9port-0_git20220912-ffbdd1aa20c8a20a8e9dcd3cec644b6dfa3c6acb.tar.gz
12889ca91d04cb623d44efb39196dca7591b4fb81f06e6b47bb07aae7aeff054191353ff44c8fd75c56505a42102c1ad7eb058e428b59c0d098c76df0ce6b7d4 plan9port-0_git20220912-ffbdd1aa20c8a20a8e9dcd3cec644b6dfa3c6acb.tar.gz
117c450854ebebfb9fc826c11fac5ef3f06185f4c28aee40eb12beeeaf300bd7b6be414d10a1d4a461f3983c721f7de7ca66a45b40aff6a95788fa859daf7da8 no-html-man-pages.patch
117c450854ebebfb9fc826c11fac5ef3f06185f4c28aee40eb12beeeaf300bd7b6be414d10a1d4a461f3983c721f7de7ca66a45b40aff6a95788fa859daf7da8 no-html-man-pages.patch
15c3427d36cf9dfaa58c301756d3a8c94ea3acc7edbe3d1b484032acad5c401691e159949844ce277d4bf90b3fc8a38ff8e7c92567b2084c697895f609f11008 libucontext.patch
15c3427d36cf9dfaa58c301756d3a8c94ea3acc7edbe3d1b484032acad5c401691e159949844ce277d4bf90b3fc8a38ff8e7c92567b2084c697895f609f11008 libucontext.patch
456da6462d8ee0efd4052cefffa18a642c49fea390a99bcc2da74bcf22895844dade3bdc991bb85d4ed558cd0894a44b51bdb1447a352189e9ca9028da2887e7 o_largefile.patch
1862807e8c45280fbd3e7827c253de093deb773d846713e3c46256e77c409b2d69cce44a2fe086d2776ebf5204707f84a3577324800173daa2f3d4fb3eae09f0 plan9.sh
1862807e8c45280fbd3e7827c253de093deb773d846713e3c46256e77c409b2d69cce44a2fe086d2776ebf5204707f84a3577324800173daa2f3d4fb3eae09f0 plan9.sh
"
"
This diff is collapsed.
Click to expand it.
community/plan9port/o_largefile.patch
0 → 100644
+
18
−
0
View file @
4da29e81
redefining O_LARGEFILE like this breaks it on aarch64,
because it is 0400000(!).
musl defines this correctly, so don't redefine it
https://github.com/9fans/plan9port/issues/619
--
diff --git a/src/cmd/9pfuse/main.c b/src/cmd/9pfuse/main.c
index 4fa330a..2b66875 100644
--- a/src/cmd/9pfuse/main.c
+++ b/src/cmd/9pfuse/main.c
@@ -38,7 +38,7 @@
* On ARM however, the O_LARGEFILE is set correctly.
*/
-#if defined(__linux__) && !defined(__arm__)
+#if defined(__GLIBC__)
# undef O_LARGEFILE
# define O_LARGEFILE 0100000
#endif
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment