Skip to content
Snippets Groups Projects
Commit 4d72e20c authored by qaqland's avatar qaqland Committed by Kevin Daudt
Browse files

community/starship: upgrade to 1.20.1

parent 3db88b0f
No related branches found
No related tags found
1 merge request!73601community/starship: upgrade to 1.20.1
Pipeline #266287 skipped
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=starship
pkgver=1.19.0
pkgver=1.20.1
pkgrel=0
pkgdesc="Minimal, blazing-fast and infinitely customizable prompt for any shell"
url="https://starship.rs"
......@@ -24,8 +24,6 @@ subpackages="
source="https://github.com/starship/starship/archive/v$pkgver/starship-$pkgver.tar.gz
use-libdbus.patch
starship.plugin.zsh
bump-libc.patch
bump-time.patch
"
options="net" # fetching dependencies
......@@ -87,9 +85,7 @@ _zsh_plugin() {
}
sha512sums="
12347b7db82425ea6656eaccb2c1e9f3c62416b1c4d1c2937cdea2aae724dfc1d6a5a93319178c9844d3f1cc2d6ae15d3e34adbe3ead7df695df87efe5d1b827 starship-1.19.0.tar.gz
bf959be577037f9b68925ed3e1640edc87ccbf9a487a61d667d05baab8e726e8337e1d816a0ff40cb8cc4ab2593db9f363147554d1e79aace839ed7eec4b632a use-libdbus.patch
a72ff68a182340aaebaf60f96b7c815c1ee31d8e513aca08eaf81f76427b047cad83bf7931ee64abf70e75ad8f08e1cb03bcea00441125a5a14a6fa17a6cd129 starship-1.20.1.tar.gz
8d28559f37b1794e95035e007612428c023be0c659f668b77d65ba2fd27a47940ab98d946b1671120cb530aca4c1c6628683ebc0bb3f99cdad8b6f454d246539 use-libdbus.patch
384a3b84b103005d347ef76c9a61f8c5e21cc97f17f195cff157f71f42dbd76fd6f54f93715cbebbee2eab70a275e39917334721fa21d130bd715a7b6334418b starship.plugin.zsh
715bb5e811e4aaa2c0289d1cbcef10d54ddd7767810b8f5fcd90380e370b0ef7d845cfbcdb2f42e95769eba81e449d07e4fc180973f28fd0d22da3ff1e868f85 bump-libc.patch
d3670a2b1a2a7d8e08e106f99cbb1b92244e5dac05492fd2a85d9182ed271d2d425d4f5b96703d38bda4c37b7da6a1934a1f866caac0bf238cdc76cfb4b629d5 bump-time.patch
"
diff --git a/Cargo.lock b/Cargo.lock
index ef92361..d1474b0 100644
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -1451,9 +1451,9 @@ checksum = "830d08ce1d1d941e6b30645f1a0eb5643013d835ce3779a5fc208261dbe10f55"
[[package]]
name = "libc"
-version = "0.2.153"
+version = "0.2.155"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "9c198f91728a82281a64e1f4f9eeb25d82cb32a5de251c6bd1b5154d63a8e7bd"
+checksum = "97b3888a4aecf77e811145cadf6eef5901f4782c53886191b2f693f24761847c"
[[package]]
name = "libdbus-sys"
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -1983,6 +1667,12 @@
]
[[package]]
+name = "num-conv"
+version = "0.1.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "51d515d32fb182ee37cda2ccdcb92950d6a3c2893aa280e540671c2cd0f3b1d9"
+
+[[package]]
name = "num-derive"
version = "0.3.3"
source = "registry+https://github.com/rust-lang/crates.io-index"
@@ -3014,13 +2616,14 @@
[[package]]
name = "time"
-version = "0.3.31"
+version = "0.3.36"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "f657ba42c3f86e7680e53c8cd3af8abbe56b5491790b46e22e19c0d57463583e"
+checksum = "5dfd88e563464686c916c7e46e623e520ddc6d79fa6641390f2e3fa86e83e885"
dependencies = [
"deranged",
"itoa",
"libc",
+ "num-conv",
"num_threads",
"powerfmt",
"serde",
@@ -3036,10 +2639,11 @@
[[package]]
name = "time-macros"
-version = "0.2.16"
+version = "0.2.18"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "26197e33420244aeb70c3e8c78376ca46571bc4e701e4791c2cd9f57dcb3a43f"
+checksum = "3f252a68540fde3a3877aeea552b832b40ab9a69e318efd078774a01ddee1ccf"
dependencies = [
+ "num-conv",
"time-core",
]
......@@ -5,11 +5,11 @@ index ea36bc0..0f115a8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -55,7 +55,7 @@ indexmap = { version = "2.2.6", features = ["serde"] }
log = { version = "0.4.21", features = ["std"] }
log = { version = "0.4.22", features = ["std"] }
# notify-rust is optional (on by default) because the crate doesn't currently build for darwin with nix
# see: https://github.com/NixOS/nixpkgs/issues/160876
-notify-rust = { version = "4.11.0", optional = true }
+notify-rust = { version = "4.11.0", default-features = false, features = ["d"], optional = true }
nu-ansi-term = "0.50.0"
nu-ansi-term = "0.50.1"
once_cell = "1.19.0"
open = "5.1.2"
open = "5.3.0"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment