Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
48f362c6
Commit
48f362c6
authored
7 years ago
by
Sören Tempel
Browse files
Options
Downloads
Patches
Plain Diff
Revert "main/gnutls: add check"
This reverts commit
9cbbd455
.
parent
9cbbd455
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/gnutls/APKBUILD
+3
-9
3 additions, 9 deletions
main/gnutls/APKBUILD
main/gnutls/fix-tests.patch
+0
-16
0 additions, 16 deletions
main/gnutls/fix-tests.patch
with
3 additions
and
25 deletions
main/gnutls/APKBUILD
+
3
−
9
View file @
48f362c6
...
...
@@ -3,12 +3,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
gnutls
pkgver
=
3.5.13
pkgrel
=
1
pkgrel
=
0
pkgdesc
=
"A TLS protocol implementation"
url
=
"http://www.gnutls.org/"
arch
=
"all"
license
=
"GPL"
checkdepends
=
"diffutils"
makedepends
=
"nettle-dev zlib-dev libtasn1-dev p11-kit-dev libunistring-dev texinfo"
subpackages
=
"
$pkgname
-dbg
$pkgname
-doc
$pkgname
-dev
$pkgname
-utils
$pkgname
-c++:xx"
_v
=
${
pkgver
%.*
}
...
...
@@ -16,7 +15,7 @@ case $pkgver in
*
.
*
.
*
.
*
)
_v
=
${
_v
%.*
}
;;
esac
source
=
"ftp://ftp.gnutls.org/gcrypt/gnutls/v
${
_v
}
/
$pkgname
-
$pkgver
.tar.xz
fix-tests.patch
"
"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
...
...
@@ -41,10 +40,6 @@ build() {
make
}
check
()
{
make
-C
"
$builddir
"
check
}
package
()
{
make
-j1
DESTDIR
=
"
$pkgdir
"
\
-C
"
$builddir
"
install
...
...
@@ -62,5 +57,4 @@ xx() {
mv
"
$pkgdir
"
/usr/lib/lib
*
xx.so.
*
"
$subpkgdir
"
/usr/lib/
}
sha512sums
=
"e98f23a589042f879936c3f8b474535e695fb7dd68a9e81323668c013241f765c2d3af6c6a072ecf867acc1e551ec46e15bb842144d3a06bdd5d2f4fc3d828a7 gnutls-3.5.13.tar.xz
f4f0a00d8f5f63cc099c8ddfc0ddf983a8d8fe3a27540b1a28a5723724111bc5888db3de7f30a9fa812ef4660a3ce8659d2e8b00a0e3456391469baa66645b0e fix-tests.patch"
sha512sums
=
"e98f23a589042f879936c3f8b474535e695fb7dd68a9e81323668c013241f765c2d3af6c6a072ecf867acc1e551ec46e15bb842144d3a06bdd5d2f4fc3d828a7 gnutls-3.5.13.tar.xz"
This diff is collapsed.
Click to expand it.
main/gnutls/fix-tests.patch
deleted
100644 → 0
+
0
−
16
View file @
9cbbd455
Replace the expression for calculating a random port number, which
causes an arithmetic error on ash, with a simpler expression which
should also get the job done.
diff -upr gnutls-3.5.13.orig/tests/scripts/common.sh gnutls-3.5.13/tests/scripts/common.sh
--- gnutls-3.5.13.orig/tests/scripts/common.sh 2017-08-22 20:43:46.767748915 +0200
+++ gnutls-3.5.13/tests/scripts/common.sh 2017-08-22 20:47:45.474435430 +0200
@@ -61,7 +61,7 @@
check_if_port_listening() {
# Find a port number not currently in use.
GETPORT='rc=0; myrandom=$(date +%N | sed s/^0*//)
while test $rc = 0;do
- PORT="$(((($$<<15)|$myrandom) % 63001 + 2000))"
+ PORT="$(($((myrandom + $$)) % 63001 + 2000))"
check_if_port_in_use $PORT;rc=$?
done
'
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment