Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
4628561e
Commit
4628561e
authored
3 years ago
by
rahmanshaber
Committed by
Kevin Daudt
3 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/coretoppings: upgrade to 4.2.0
parent
34980940
Loading
Loading
1 merge request
!22157
community/coretoppings: upgrade to 4.2.0
Pipeline
#84125
canceled
3 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/coretoppings/APKBUILD
+12
-10
12 additions, 10 deletions
community/coretoppings/APKBUILD
community/coretoppings/fix-qt5.12-build.patch
+0
-13
0 additions, 13 deletions
community/coretoppings/fix-qt5.12-build.patch
with
12 additions
and
23 deletions
community/coretoppings/APKBUILD
+
12
−
10
View file @
4628561e
# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
pkgname
=
coretoppings
pkgver
=
4.
1
.0
pkgver
=
4.
2
.0
pkgrel
=
0
pkgdesc
=
"An activity viewer from the CoreApps family."
arch
=
""
# FTBFS
"all !armhf !s390x !mips64" # qt5-qtlocation, polkit
arch
=
"all !armhf !s390x !mips64"
# qt5-qtlocation, polkit
url
=
"https://gitlab.com/cubocore"
license
=
"GPL-3.0-or-later"
depends
=
"qt5-qtsvg"
makedepends
=
"qt5-qtbase-dev libcprime-dev qt5-qtx11extras-dev qt5-qtconnectivity-dev qt5-qtlocation-dev libcsys-dev libdbusmenu-qt-dev libxcomposite-dev xcb-util-dev libxrender-dev xcb-util-wm-dev"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://gitlab.com/cubocore/coretoppings/-/archive/v
$pkgver
/coretoppings-v
$pkgver
.tar.gz
fix-qt5.12-build.patch"
makedepends
=
"qt5-qtbase-dev libcprime-dev qt5-qtx11extras-dev qt5-qtconnectivity-dev qt5-qtlocation-dev libcsys-dev libdbusmenu-qt-dev libxcomposite-dev xcb-util-dev libxrender-dev xcb-util-wm-dev cmake ninja"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://gitlab.com/cubocore/coretoppings/-/archive/v
$pkgver
/coretoppings-v
$pkgver
.tar.gz"
builddir
=
"
$srcdir
/
$pkgname
-v
$pkgver
"
options
=
"!check"
# No test suite
build
()
{
qmake-qt5
make
cmake
-B
build
\
-GNinja
\
-DCMAKE_INSTALL_PREFIX
=
/usr
\
-DCMAKE_INSTALL_LIBDIR
=
lib
\
-DCMAKE_BUILD_TYPE
=
None
cmake
--build
build
}
package
()
{
INSTALL_ROOT
=
"
$pkgdir
"
make
install
DESTDIR
=
"
$pkgdir
"
c
make
--
install
build
}
sha512sums
=
"bbad49c322f5fbf39633a6a56269b3bddde42c8e515b6c25471dbf74f59f24b2217a89593d06b67dda6cca0ef3fc93b50fec1ab7cd523ff23b3c8bad76f0d71e coretoppings-4.1.0.tar.gz
a7094149d1f2da50baf9d6eb618016eef94a751a27ebe9ae19d00d83f2749f220a9e3d1847482e3c183a5f8e2a91c7ee97f52d95427d8e0d96c7f13ef49dc1fb fix-qt5.12-build.patch"
sha512sums
=
"f3d433db645308183e51fb250895088e6fca6d32f1d1ffcf8e758d749daa09a96707549d4b51c8ac51711481e78d7c4be1d4dfe496f32dd28bd14cb0b5da4af7 coretoppings-4.2.0.tar.gz"
This diff is collapsed.
Click to expand it.
community/coretoppings/fix-qt5.12-build.patch
deleted
100644 → 0
+
0
−
13
View file @
34980940
diff --git a/sni/statusnotifierbutton.cpp b/sni/statusnotifierbutton.cpp
index d07eb6b0163fc33db8e4e03731df7ee31ce671b2..c339657d538ded7544520386a31e01237e423304 100644
--- a/sni/statusnotifierbutton.cpp
+++ b/sni/statusnotifierbutton.cpp
@@ -267,7 +267,7 @@
void StatusNotifierButton::mouseReleaseEvent(QMouseEvent *event)
{
if (event->button() == Qt::LeftButton)
interface->Activate(QCursor::pos().x(), QCursor::pos().y());
- else if (event->button() == Qt::MidButton)
+ else if (event->button() == Qt::MiddleButton)
interface->SecondaryActivate(QCursor::pos().x(), QCursor::pos().y());
else if (Qt::RightButton == event->button())
{
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment