Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
45b76ea7
Commit
45b76ea7
authored
4 months ago
by
Hoang Nguyen
Committed by
omni
2 months ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/typstyle: new aport
parent
3fe4e58d
No related branches found
Branches containing commit
No related tags found
Tags containing commit
2 merge requests
!79570
community/firefox-esr: upgrade to 128.7.0
,
!75293
testing/typstyle: new aport
Pipeline
#289948
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/typstyle/APKBUILD
+40
-0
40 additions, 0 deletions
testing/typstyle/APKBUILD
testing/typstyle/skip-sensitive-test.patch
+15
-0
15 additions, 0 deletions
testing/typstyle/skip-sensitive-test.patch
with
55 additions
and
0 deletions
testing/typstyle/APKBUILD
0 → 100644
+
40
−
0
View file @
45b76ea7
maintainer
=
"Hoang Nguyen <folliekazetani@protonmail.com>"
pkgname
=
typstyle
pkgver
=
0.12.14
pkgrel
=
0
pkgdesc
=
"Beautiful and reliable typst code formatter"
url
=
"https://enter-tainer.github.io/typstyle/"
arch
=
"all"
license
=
"Apache-2.0"
makedepends
=
"cargo cargo-auditable openssl-dev"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/Enter-tainer/typstyle/archive/refs/tags/v
$pkgver
.tar.gz
skip-sensitive-test.patch
"
export
OPENSSL_NO_VENDOR
=
1
export
PKG_CONFIG_ALL_DYNAMIC
=
1
prepare
()
{
default_prepare
cargo fetch
--target
=
"
$CTARGET
"
--locked
}
build
()
{
cargo auditable build
--frozen
--release
--bin
typstyle
}
check
()
{
# Remove the default `consistency` feature in typstyle-tests crate.
# The feature enables running repo-e2e tests, which easily panic on our builder.
cargo
test
--frozen
--workspace
--no-default-features
}
package
()
{
install
-Dm755
target/release/typstyle
-t
"
$pkgdir
"
/usr/bin/
}
sha512sums
=
"
76ed0780e03fcb4b22774fe01ae3d8ba6e47e0330d8c6635ac0d94acf507b199f110581d85e443738b8ffc678554e02deaf5be1bc6f7ad3775e6c23212e24dc9 typstyle-0.12.14.tar.gz
466fedd6eef1fc6bf3408a4836e7271b797131761d046096da94f986c00e897bfcf14416758dd6469a08dbf2884e28a4467b929554422b866317b56d235ee0ce skip-sensitive-test.patch
"
This diff is collapsed.
Click to expand it.
testing/typstyle/skip-sensitive-test.patch
0 → 100644
+
15
−
0
View file @
45b76ea7
The test is sensitive about the order of formatted files listed in the snapshot,
compared to the actual stdout output when it is run.
diff --git a/crates/typstyle/tests/test_format_all.rs b/crates/typstyle/tests/test_format_all.rs
index 1b87b06..c069f47 100644
--- a/crates/typstyle/tests/test_format_all.rs
+++ b/crates/typstyle/tests/test_format_all.rs
@@ -72,6 +72,7 @@
fn test_all_2() {
}
#[test]
+#[ignore]
fn test_all_0_check() {
let mut space = Workspace::new();
space.write_tracked("a.typ", "#let a = 0");
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment