Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
4585856c
Commit
4585856c
authored
6 years ago
by
Natanael Copa
Browse files
Options
Downloads
Patches
Plain Diff
main/lua-aports: upgrade to 1.0.0
parent
68055670
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/lua-aports/0001-db-fix-split_deps-to-support-fuzzy-operator.patch
+0
-25
0 additions, 25 deletions
...ts/0001-db-fix-split_deps-to-support-fuzzy-operator.patch
main/lua-aports/APKBUILD
+3
-5
3 additions, 5 deletions
main/lua-aports/APKBUILD
with
3 additions
and
30 deletions
main/lua-aports/0001-db-fix-split_deps-to-support-fuzzy-operator.patch
deleted
100644 → 0
+
0
−
25
View file @
68055670
From 10d9b456afb0f9eba3c24a68b2861f94dc129e07 Mon Sep 17 00:00:00 2001
From: Jakub Jirutka <jakub@jirutka.cz>
Date: Sun, 5 Aug 2018 12:12:00 +0200
Subject: [PATCH] db: fix split_deps() to support fuzzy operator ~
---
aports/db.lua | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/aports/db.lua b/aports/db.lua
index 90dbeef..bb7e136 100644
--- a/aports/db.lua
+++ b/aports/db.lua
@@ -23,7 +23,7 @@
local function split_deps(str)
return nil
end
for e in string.gmatch(str, "%S+") do
- t[#t + 1] = string.gsub(e, "[=<>].*", "")
+ t[#t + 1] = string.gsub(e, "[=<>~].*", "")
end
return t
end
--
2.16.4
This diff is collapsed.
Click to expand it.
main/lua-aports/APKBUILD
+
3
−
5
View file @
4585856c
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
lua-aports
pkgname
=
lua-aports
pkgver
=
0.7
.0
pkgver
=
1.0
.0
pkgrel
=
1
pkgrel
=
0
pkgdesc
=
"Lua modules for parsing aports tree"
pkgdesc
=
"Lua modules for parsing aports tree"
url
=
"https://dev.alpinelinux.org/archive/lua-aports/"
url
=
"https://dev.alpinelinux.org/archive/lua-aports/"
arch
=
"noarch"
arch
=
"noarch"
...
@@ -9,7 +9,6 @@ license="MIT"
...
@@ -9,7 +9,6 @@ license="MIT"
depends
=
"lua5.2-cjson lua5.2-filesystem lua5.2-optarg lua5.2"
depends
=
"lua5.2-cjson lua5.2-filesystem lua5.2-optarg lua5.2"
replaces
=
"abuild"
replaces
=
"abuild"
source
=
"https://dev.alpinelinux.org/archive/lua-aports/lua-aports-
$pkgver
.tar.xz
source
=
"https://dev.alpinelinux.org/archive/lua-aports/lua-aports-
$pkgver
.tar.xz
0001-db-fix-split_deps-to-support-fuzzy-operator.patch
"
"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
...
@@ -18,5 +17,4 @@ package() {
...
@@ -18,5 +17,4 @@ package() {
make
DESTDIR
=
"
$pkgdir
"
install
make
DESTDIR
=
"
$pkgdir
"
install
}
}
sha512sums
=
"35128b086218fd5bb4df8f78c6ccc45beffdd50143656d938e68ca83e718ec6586fbfcadcd838ffd132ea59017f56960603f3fbead6da548258f4a0d532537eb lua-aports-0.7.0.tar.xz
sha512sums
=
"67ea0bd93c7cf8fcfe175a6e90da6e1976e0ca6257b036ef43959a5a839cecc94ceb90a509ec270cb6cdaf4ef234c41adc7269d733ae6ad1c377ef9c4b261f0b lua-aports-1.0.0.tar.xz"
bcf525e06d5125c724474b055b3cf7dc060632cd4aa19fe2079b53352e2c37ce49392d9261fbb78a6d8aba0cbe8b93ef68041185721ab6b31af314e53f196dd1 0001-db-fix-split_deps-to-support-fuzzy-operator.patch"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment