Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
39e4dea3
Commit
39e4dea3
authored
7 months ago
by
mio
Committed by
Ariadne Conill
7 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/ratbag: fix build with gcc 14
parent
6cce1d00
No related branches found
No related tags found
1 merge request
!71162
community/ratbag: fix build with gcc 14
Pipeline
#256008
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/ratbag/APKBUILD
+4
-2
4 additions, 2 deletions
community/ratbag/APKBUILD
community/ratbag/gcc14.patch
+53
-0
53 additions, 0 deletions
community/ratbag/gcc14.patch
with
57 additions
and
2 deletions
community/ratbag/APKBUILD
+
4
−
2
View file @
39e4dea3
...
...
@@ -2,7 +2,7 @@
# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname
=
ratbag
pkgver
=
0.17
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"DBus daemon to configure input devices, mainly gaming mice"
url
=
"https://github.com/libratbag/libratbag"
arch
=
"all"
...
...
@@ -23,7 +23,8 @@ makedepends="
checkdepends
=
"check-dev py3-gobject3 py3-evdev"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc
$pkgname
-tools:_tools"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/libratbag/libratbag/archive/refs/tags/v
$pkgver
.tar.gz
python-3.12.patch"
python-3.12.patch
gcc14.patch"
builddir
=
"
$srcdir
/libratbag-
$pkgver
"
build
()
{
...
...
@@ -55,4 +56,5 @@ _tools() {
sha512sums
=
"
80ab5c895d83e28b6b6adcd0669854944d7932ef037c8d64b923a7362399e861475e9d81c5ee2cf814f654d7796b00a81314cc177f34e13c8684d525974068c8 ratbag-0.17.tar.gz
1e2ebd5c49de257416b5dd2f578ed2ec6060c9067a9e050406ea81103b8294a737d1885186d6d074837216bc608b93485a5c9a26a5604e0f278a58d71ce0c655 python-3.12.patch
5c29040f2c9febe2cb3a7fccffe12d0a97ac4a4dd27fcae9c34a8244e570960ee90ba2bbcd024be7dc4c9bcd61544e9e45257ff4e1eb6c17af1bffa671faef42 gcc14.patch
"
This diff is collapsed.
Click to expand it.
community/ratbag/gcc14.patch
0 → 100644
+
53
−
0
View file @
39e4dea3
Fix -Wimplicit-function-declaration error with gcc 14.
Thanks to Ariadne Conill for the suggested fix.
Example error output:
```
In file included from ../src/asus.h:6,
from ../src/libratbag-data.c:33:
../src/libratbag-data.c: In function 'file_data_matches':
../src/libratbag-data.c:610:66: error: implicit declaration of function
'basename'; did you mean 'g_basename'? [-Wimplicit-function-declaration]
610 | log_error(ratbag, "Missing DeviceMatch in %s\n", basename(path));
| ^~~~~~~~
```
--- libratbag-0.17-origin/src/libratbag-data.c
+++ libratbag-0.17/src/libratbag-data.c
@@ -607,7 +607,7 @@
match_strv = g_key_file_get_string_list(keyfile, GROUP_DEVICE, "DeviceMatch", NULL, NULL);
if (!match_strv) {
- log_error(ratbag, "Missing DeviceMatch in %s\n", basename(path));
+ log_error(ratbag, "Missing DeviceMatch in %s\n", g_basename(path));
return false;
}
@@ -623,7 +623,7 @@
data->driver = g_key_file_get_string(keyfile, GROUP_DEVICE, "Driver", NULL);
if (!data->driver) {
- log_error(ratbag, "Missing Driver in %s\n", basename(path));
+ log_error(ratbag, "Missing Driver in %s\n", g_basename(path));
return false;
} else {
const struct driver_map *map;
@@ -640,14 +640,14 @@
if (data->drivertype == NONE) {
log_error(ratbag, "Unknown driver %s in %s\n",
- data->driver, basename(path));
+ data->driver, g_basename(path));
return false;
}
}
ledtypes_strv = g_key_file_get_string_list(keyfile, GROUP_DEVICE, "LedTypes", NULL, NULL);
if (parse_ledtypes(ledtypes_strv, data->led_types, ARRAY_LENGTH(data->led_types)) < 0) {
- log_error(ratbag, "Invalid LedTypes string in '%s'\n", basename(path));
+ log_error(ratbag, "Invalid LedTypes string in '%s'\n", g_basename(path));
return false;
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment