Skip to content
Snippets Groups Projects
Commit 396fb732 authored by Sergiy Stupar's avatar Sergiy Stupar Committed by alice
Browse files

testing/pokoy: new aport

parent b09ee601
No related branches found
No related tags found
1 merge request!47371testing/pokoy: new aport
Pipeline #165439 canceled
# Contributor: Sergiy Stupar <owner@sestolab.pp.ua>
# Maintainer: Sergiy Stupar <owner@sestolab.pp.ua>
pkgname=pokoy
pkgver=0.2.5
pkgrel=0
pkgdesc="Lightweight daemon that helps prevent RSI and other computer related stress"
url="https://github.com/ttygde/pokoy"
arch="all"
license="GPL-2.0-only"
makedepends="libxcb-dev xcb-util-wm-dev xcb-util-keysyms-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ttygde/pokoy/archive/v$pkgver.tar.gz
broken-makefile.patch
"
options="!check" # No tests
build() {
make PREFIX=/usr STRIP=
}
package() {
make PREFIX=/usr DESTDIR="$pkgdir" install
}
sha512sums="
cd7505f0fc88c51f9a74e19aae3aed0e20a408b70ead93f04043a886c448099b4d56443c8a0404746b3b4ee4ba6b4c7d442793a7f24b93b1f3b06d8c149692ca pokoy-0.2.5.tar.gz
c0973a7300fb77b45b597272bec9d182573a3b8a3eb16f1b4e70c838a1b59bbdc7041a10742bfee03d6191f068dd7bc16fbc046d94b7cce2e62c9736f760d039 broken-makefile.patch
"
diff --git a/Makefile b/Makefile
index 60f6519..b0c0793 100644
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,8 @@
VERSION = 0.2.5
CC ?= gcc
STRIP ?= strip
-CFLAGS = -std=c99 -D_DEFAULT_SOURCE -O2
-LDFLAGS = -lxcb -lxcb-keysyms -lxcb-icccm -lxcb-screensaver
+CFLAGS := -std=c99 -D_DEFAULT_SOURCE -O2 $(CFLAGS)
+LDFLAGS := -lxcb -lxcb-keysyms -lxcb-icccm -lxcb-screensaver $(LDFLAGS)
SRCR = pokoy.c
OBJS = ${SRCR:.c=.o}
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment