Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
37d17dfb
Commit
37d17dfb
authored
1 year ago
by
Sören Tempel
Committed by
Sören Tempel
1 year ago
Browse files
Options
Downloads
Patches
Plain Diff
community/pcc-libs: upgrade to 20230419
parent
a8141ce5
No related branches found
No related tags found
1 merge request
!46230
community/pcc: upgrade to 20230419
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/pcc-libs/APKBUILD
+5
-3
5 additions, 3 deletions
community/pcc-libs/APKBUILD
community/pcc-libs/fix-cflags.patch
+66
-0
66 additions, 0 deletions
community/pcc-libs/fix-cflags.patch
with
71 additions
and
3 deletions
community/pcc-libs/APKBUILD
+
5
−
3
View file @
37d17dfb
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname
=
pcc-libs
pkgver
=
202
206
19
pkgver
=
202
304
19
pkgrel
=
0
pkgdesc
=
"The portable C compiler support libraries."
url
=
"http://pcc.ludd.ltu.se/"
...
...
@@ -9,7 +9,8 @@ arch="x86 x86_64"
license
=
"BSD"
subpackages
=
"
$pkgname
-dev"
source
=
"ftp://pcc.ludd.ltu.se/pub/pcc-libs/pcc-libs-
$pkgver
.tgz
musl-fixes.patch"
musl-fixes.patch
fix-cflags.patch"
prepare
()
{
default_prepare
...
...
@@ -32,6 +33,7 @@ package() {
}
sha512sums
=
"
1e4de973cdf0dfcad2ec43d072de5249c58ef3d3f5d9c3d23373d8f013f6ef6f72f3d27501bfd8514c106fda
3e
f
80
659070f79206efbbd2615f89b659c34127
9 pcc-libs-202
206
19.tgz
b193e32d10cb7a7ce33e00c33842a6a3bc35f385422e87e5bd1975324672897ec6d492c496f83a4
3e
9
80
d9e469ca2b6a556826ea1fe965152f394d2a66d0bd8
9 pcc-libs-202
304
19.tgz
fd8c71cd583c6be29553f2b7e6ce66073afd6d0406ae86f6fbb6a36efe8685be4732d2989180a9b31af734cc9a0973c1c731472f02bad076121f6c3c58391fc4 musl-fixes.patch
2e2daa89350e9160fd7fe7f98189eebedb62be0eef712d9cbb8fdc2d7d2d47eece0d2d9756bca00fb44784c1067616fd114bed70ff6beb297db8da9d35fcb65b fix-cflags.patch
"
This diff is collapsed.
Click to expand it.
community/pcc-libs/fix-cflags.patch
0 → 100644
+
66
−
0
View file @
37d17dfb
csu/Makefile passes CFLAGS to csu/linux/Makefile via a recursive make
invocation on the command-line. This causes CFLAGS of csu/linux/Makefile
to be overwritten by the value supplied on the command-line. This patch
is a hacky workaround to fix this.
diff -upr pcc-libs-20230419.orig/csu/linux/Makefile pcc-libs-20230419/csu/linux/Makefile
--- pcc-libs-20230419.orig/csu/linux/Makefile 2023-04-19 18:51:37.262841602 +0200
+++ pcc-libs-20230419/csu/linux/Makefile 2023-04-19 18:52:03.996245974 +0200
@@ -4,7 +4,7 @@
VERSION ?= 1.1.0
PCCLIBDIR ?= /usr/local/lib/pcc/$(TARGET)/$(VERSION)/lib
SRCDIR ?= .
-CFLAGS = -I$(SRCDIR)/$(MACH) -I$(SRCDIR) -Wall -Wstrict-prototypes -Wmissing-prototypes
+CFLAGS_EXTRA = -I$(SRCDIR)/$(MACH) -I$(SRCDIR) -Wall -Wstrict-prototypes -Wmissing-prototypes
#OBJS = crt0.o crt1.o gcrt1.o crti.o crtn.o crtbegin.o crtend.o \
# crtbeginS.o crtendS.o crtbeginT.o crtendT.o
@@ -14,37 +14,37 @@
OBJS = crtbegin.o crtend.o crtbeginS.o c
all: $(OBJS)
crt0.o: $(MACH)/crt0.c
- $(CC) -O2 $(CFLAGS) -c -o $@ $<
+ $(CC) -O2 $(CFLAGS) $(CFLAGS_EXTRA) -c -o $@ $<
crt1.o: $(MACH)/crt0.c
- $(CC) -O2 $(CFLAGS) -c -o $@ $<
+ $(CC) -O2 $(CFLAGS) $(CFLAGS_EXTRA) -c -o $@ $<
gcrt1.o: $(MACH)/crt0.c
- $(CC) -O2 -DPROFILE $(CFLAGS) -c -o $@ $<
+ $(CC) -O2 -DPROFILE $(CFLAGS) $(CFLAGS_EXTRA) -c -o $@ $<
crti.o: $(MACH)/crti.c
- $(CC) -O2 $(CFLAGS) -c -o $@ $<
+ $(CC) -O2 $(CFLAGS) $(CFLAGS_EXTRA) -c -o $@ $<
crtn.o: $(MACH)/crtn.c
- $(CC) -O2 $(CFLAGS) -c -o $@ $<
+ $(CC) -O2 $(CFLAGS) $(CFLAGS_EXTRA) -c -o $@ $<
crtbegin.o: crtbegin.c
- $(CC) -O2 $(CFLAGS) -c -o $@ $<
+ $(CC) -O2 $(CFLAGS) $(CFLAGS_EXTRA) -c -o $@ $<
crtend.o: crtend.c
- $(CC) -O2 $(CFLAGS) -c -o $@ $<
+ $(CC) -O2 $(CFLAGS) $(CFLAGS_EXTRA) -c -o $@ $<
crtbeginS.o: crtbegin.c
- $(CC) -O2 $(CFLAGS) -fpic -c -o $@ $<
+ $(CC) -O2 $(CFLAGS) $(CFLAGS_EXTRA) -fpic -c -o $@ $<
crtendS.o: crtend.c
- $(CC) -O2 $(CFLAGS) -fpic -c -o $@ $<
+ $(CC) -O2 $(CFLAGS) $(CFLAGS_EXTRA) -fpic -c -o $@ $<
crtbeginT.o: crtbegin.c
- $(CC) -O2 $(CFLAGS) -c -o $@ $<
+ $(CC) -O2 $(CFLAGS) $(CFLAGS_EXTRA) -c -o $@ $<
crtendT.o: crtend.c
- $(CC) -O2 $(CFLAGS) -c -o $@ $<
+ $(CC) -O2 $(CFLAGS) $(CFLAGS_EXTRA) -c -o $@ $<
install:
mkdir -p ${DESTDIR}$(PCCLIBDIR)
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment