Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
37aad063
Commit
37aad063
authored
3 months ago
by
Will Sinatra
Committed by
Natanael Copa
2 months ago
Browse files
Options
Downloads
Patches
Plain Diff
community/py3-pygit2: upgrade to 1.16.0
parent
29c6cb3b
No related branches found
No related tags found
1 merge request
!75440
community/libgit2: upgrade to 1.8.2
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/py3-pygit2/0006-Revert-const-correctness-change-from-libgit2-1.8.1.patch
+32
-0
32 additions, 0 deletions
...-Revert-const-correctness-change-from-libgit2-1.8.1.patch
community/py3-pygit2/APKBUILD
+6
-3
6 additions, 3 deletions
community/py3-pygit2/APKBUILD
with
38 additions
and
3 deletions
community/py3-pygit2/0006-Revert-const-correctness-change-from-libgit2-1.8.1.patch
0 → 100644
+
32
−
0
View file @
37aad063
From: =?utf-8?q?Timo_R=C3=B6hling?= <roehling@debian.org>
Date: Sun, 15 Sep 2024 10:04:24 +0200
Subject: Revert const correctness change from libgit2 1.8.1
---
src/repository.c | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/src/repository.c b/src/repository.c
index d1d42ec..1335606 100644
--- a/src/repository.c
+++ b/src/repository.c
@@ -1065,7 +1065,8 @@
Repository_create_commit(Repository *self, PyObject *args)
err = git_commit_create(&oid, self->repo, update_ref,
py_author->signature, py_committer->signature,
- encoding, message, tree, parent_count, parents);
+ encoding, message, tree, parent_count,
+ (const git_commit**)parents);
if (err < 0) {
Error_set(err);
goto out;
@@ -1147,7 +1148,8 @@
Repository_create_commit_string(Repository *self, PyObject *args)
err = git_commit_create_buffer(&buf, self->repo,
py_author->signature, py_committer->signature,
- encoding, message, tree, parent_count, parents);
+ encoding, message, tree, parent_count,
+ (const git_commit**)parents);
if (err < 0) {
Error_set(err);
goto out;
This diff is collapsed.
Click to expand it.
community/py3-pygit2/APKBUILD
+
6
−
3
View file @
37aad063
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Pierre-Gildas MILLON <pgmillon@gmail.com>
# Maintainer: Will Sinatra <wpsinatra@gmail.com>
maintainer
=
"Will Sinatra <wpsinatra@gmail.com>"
pkgname
=
py3-pygit2
_pkgname
=
pygit2
pkgver
=
1.1
4.1
pkgrel
=
1
pkgver
=
1.1
6.0
pkgrel
=
0
pkgdesc
=
"Python bindings for libgit2"
url
=
"https://github.com/libgit2/pygit2"
arch
=
"all"
...
...
@@ -25,6 +26,7 @@ subpackages="$pkgname-pyc"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/libgit2/pygit2/archive/refs/tags/v
$pkgver
.tar.gz
s390x-patch-context-mark-xfail.patch
test-skip-ls-remote-github.patch
0006-Revert-const-correctness-change-from-libgit2-1.8.1.patch
"
builddir
=
"
$srcdir
/
$_pkgname
-
$pkgver
"
...
...
@@ -52,7 +54,8 @@ package() {
}
sha512sums
=
"
7d48c60df5af47fe5f90661cec6d53e3b4adb5e14b4d605fc4634f38222b4053d59156a55814849b1cd0619b169c6d35bc387912695e54c18fdd2b57de7b561d
py3-pygit2-1.1
4.1
.tar.gz
a0ea1853a8e34d74ff0f477d1d66949349ae6bbeb550b952d5427dff4ba92b38c6d16f890a37adf161f9bc0b712c7d1f769bccc2d291cfdadb470aa1b9c6db31
py3-pygit2-1.1
6.0
.tar.gz
e7f3a43f2de1503d75c5583c4d9a30027dd3d619ba02e7e62bed3b912e8c91e4bc58ad395b110eb506b365bebf99d4245837c65c9988f15e4dc41f0f87fe7c13 s390x-patch-context-mark-xfail.patch
c0114b96d0064f272f166a6af915a1abcadc1ec8aac0c84007e4f24d669784d42c24f50ad71118453f0fb25b6f38f991a9d6f968d1a21f017c4662c9ba9c5c41 test-skip-ls-remote-github.patch
22219b2b8cc0fde0592b391285a2512705498a28323c7f1758fb07376e8ca6f02ff56036aa08904da31e6fc1b712046458d221546a5e9ca3109dac5e47f594cb 0006-Revert-const-correctness-change-from-libgit2-1.8.1.patch
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment