Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
36b7031b
Commit
36b7031b
authored
4 years ago
by
Michał Adamski
Committed by
Leo
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/libupnp: upgrade to 1.14.0 and remove patch
parent
0f5d65b5
No related branches found
No related tags found
1 merge request
!14389
community/libupnp: upgrade to 1.14.0 and remove patch
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
community/libupnp/APKBUILD
+4
-6
4 additions, 6 deletions
community/libupnp/APKBUILD
community/libupnp/CVE-2020-13848.patch
+0
-39
0 additions, 39 deletions
community/libupnp/CVE-2020-13848.patch
testing/amule/APKBUILD
+1
-1
1 addition, 1 deletion
testing/amule/APKBUILD
with
5 additions
and
46 deletions
community/libupnp/APKBUILD
+
4
−
6
View file @
36b7031b
...
@@ -2,16 +2,15 @@
...
@@ -2,16 +2,15 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Contributor: Mike Crute <mike@crute.us>
# Contributor: Mike Crute <mike@crute.us>
pkgname
=
libupnp
pkgname
=
libupnp
pkgver
=
1.1
2.1
pkgver
=
1.1
4.0
pkgrel
=
1
pkgrel
=
0
pkgdesc
=
"Portable Open Source UPnP Development Kit"
pkgdesc
=
"Portable Open Source UPnP Development Kit"
url
=
"http://pupnp.sourceforge.net"
url
=
"http://pupnp.sourceforge.net"
arch
=
"all"
arch
=
"all"
license
=
"BSD-3-Clause"
license
=
"BSD-3-Clause"
makedepends
=
"automake autoconf libtool"
makedepends
=
"automake autoconf libtool"
subpackages
=
"
$pkgname
-dev"
subpackages
=
"
$pkgname
-dev"
source
=
"https://github.com/pupnp/pupnp/releases/download/release-
$pkgver
/libupnp-
$pkgver
.tar.bz2
source
=
"https://github.com/pupnp/pupnp/releases/download/release-
$pkgver
/libupnp-
$pkgver
.tar.bz2"
CVE-2020-13848.patch"
# secfixes:
# secfixes:
# 1.12.1-r1:
# 1.12.1-r1:
...
@@ -39,5 +38,4 @@ package() {
...
@@ -39,5 +38,4 @@ package() {
make
DESTDIR
=
"
$pkgdir
"
install
make
DESTDIR
=
"
$pkgdir
"
install
}
}
sha512sums
=
"f13833118d08fc05273dc65a12596854b937c505b20d82e58eb1c2e1fa35dba0cafd5799475e030f3c698069046cc5256e6ef5afe398680e7ea881df953b95e6 libupnp-1.12.1.tar.bz2
sha512sums
=
"c1ceaa4116dc514607d092126f98a32b6b01d3251464615e3a716254d474559d1df785203daf21b44b0edb34a72e978f8a9fde697336258a8c225b55aa9e0db5 libupnp-1.14.0.tar.bz2"
ece4d1a27fec40b9714200d66013c105b50dedf41f5435df9122be763b78c74ec419ffc60e75088f9706ab6d8f01afa07f8262c3b9af9134ba42cfe9b5f2fb59 CVE-2020-13848.patch"
This diff is collapsed.
Click to expand it.
community/libupnp/CVE-2020-13848.patch
deleted
100644 → 0
+
0
−
39
View file @
0f5d65b5
diff --git a/upnp/src/genlib/service_table/service_table.c b/upnp/src/genlib/service_table/service_table.c
index 98c2c0f..c2c4545 100644
--- a/upnp/src/genlib/service_table/service_table.c
+++ b/upnp/src/genlib/service_table/service_table.c
@@ -300,12 +300,12 @@
FindServiceEventURLPath( service_table * table,
uri_type parsed_url;
uri_type parsed_url_in;
- if( ( table )
- &&
- ( parse_uri( eventURLPath,
- strlen( eventURLPath ),
- &parsed_url_in ) == HTTP_SUCCESS ) ) {
+ if (!table || !eventURLPath) {
+ return NULL;
+ }
+ if (parse_uri(eventURLPath, strlen(eventURLPath), &parsed_url_in) ==
+ HTTP_SUCCESS) {
finger = table->serviceList;
while( finger ) {
if( finger->eventURL )
@@ -352,11 +352,11 @@
FindServiceControlURLPath( service_table * table,
uri_type parsed_url;
uri_type parsed_url_in;
- if( ( table )
- &&
- ( parse_uri
- ( controlURLPath, strlen( controlURLPath ),
- &parsed_url_in ) == HTTP_SUCCESS ) ) {
+ if (!table || !controlURLPath) {
+ return NULL;
+ }
+ if (parse_uri(controlURLPath, strlen(controlURLPath), &parsed_url_in) ==
+ HTTP_SUCCESS) {
finger = table->serviceList;
while( finger ) {
if( finger->controlURL )
This diff is collapsed.
Click to expand it.
testing/amule/APKBUILD
+
1
−
1
View file @
36b7031b
...
@@ -3,7 +3,7 @@
...
@@ -3,7 +3,7 @@
pkgname
=
amule
pkgname
=
amule
_commit
=
eba0b7ac753680264a77b3dff12f82665ff180d4
_commit
=
eba0b7ac753680264a77b3dff12f82665ff180d4
pkgver
=
11066
pkgver
=
11066
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"eMule-like client for the eD2k and Kademlia networks"
pkgdesc
=
"eMule-like client for the eD2k and Kademlia networks"
url
=
"http://www.amule.org"
url
=
"http://www.amule.org"
arch
=
"all"
arch
=
"all"
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment