Skip to content
Snippets Groups Projects
Commit 35a0e37f authored by Milan P. Stanić's avatar Milan P. Stanić
Browse files

testing/ameba: upgrade to 0.10.1

enable build on aarch64
remove fix-makefile.patch, not needed with this version
parent fb5b97d0
No related branches found
No related tags found
No related merge requests found
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ameba
pkgver=0.8.0
pkgver=0.10.1
pkgrel=0
pkgdesc="A static code analysis tool for Crystal"
url="https://veelenga.github.io/ameba/"
arch="x86_64" # limited by crystal. build fails on aarch64
arch="x86_64 aarch64"
license="MIT"
makedepends="crystal libxml2-dev shards yaml-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/veelenga/$pkgname/archive/v$pkgver.tar.gz
fix-makefile.patch"
source="$pkgname-$pkgver.tar.gz::https://github.com/veelenga/$pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
export CRYSTAL_CACHE_DIR="$srcdir/.cache"
......@@ -29,5 +28,4 @@ package() {
make install PREFIX="$pkgdir/usr"
}
sha512sums="5ee602374f7b3c7241bfe16d0afeb74af5acf5b3530d8cac3b3b59c8c9b39e017bec018b04bdb79d973cd473ed84c07a7d8e8ed376d1f0c7ecff9a3fe48971c6 ameba-0.8.0.tar.gz
0acb42fe00c650b801f88911457e3d83f7297719494094e8687b67093d5641b6f892d63c603fd2d346a8db06128158ae4ace3a8a9bd5852b838c6a4d6104e9d6 fix-makefile.patch"
sha512sums="1a9e2591e603eb1824584aced7025903554a24c42d7eab4d370b471db944340df03abe4c0447a4016a62501265bb27aafedb923faf2a06024c66c97406e52f36 ameba-0.10.1.tar.gz"
--- a/Makefile
+++ b/Makefile
@@ -3,17 +3,19 @@
PREFIX ?= /usr/local
SHARD_BIN ?= ../../bin
+.PHONY: build
build: bin/ameba
+
bin/ameba:
$(SHARDS_BIN) build $(CRFLAGS)
clean:
rm -f ./bin/ameba ./bin/ameba.dwarf
-install: build
+install: bin/ameba
mkdir -p $(PREFIX)/bin
cp ./bin/ameba $(PREFIX)/bin
-bin: build
+bin: bin/ameba
mkdir -p $(SHARD_BIN)
cp ./bin/ameba $(SHARD_BIN)
-test: build
- $(CRYSTAL_BIN) spec
+test: bin/ameba
+ $(CRYSTAL_BIN) spec $(SPEC_FLAGS)
./bin/ameba --all
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment