Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
340d7162
Commit
340d7162
authored
2 years ago
by
Milan P. Stanić
Browse files
Options
Downloads
Patches
Plain Diff
community/iwd: upgrade to 1.28
pick upstream patch to fix build with musl
parent
cee7a0ea
No related branches found
No related tags found
2 merge requests
!39304
[3.16] main/expat: security upgrade to 2.4.9
,
!35132
community/iwd: upgrade to 1.28
Pipeline
#124567
canceled
2 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/iwd/0001-build-fix-time.h-related-breakage-on-musl.patch
+79
-0
79 additions, 0 deletions
.../iwd/0001-build-fix-time.h-related-breakage-on-musl.patch
community/iwd/APKBUILD
+5
-2
5 additions, 2 deletions
community/iwd/APKBUILD
with
84 additions
and
2 deletions
community/iwd/0001-build-fix-time.h-related-breakage-on-musl.patch
0 → 100644
+
79
−
0
View file @
340d7162
From 0cee9267ef95b3a13917e042dc205bc24be9328e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Milan=20P=2E=20Stani=C4=87?= <mps@arvanta.net>
Date: Mon, 6 Jun 2022 17:05:48 +0000
Subject: [PATCH] build: fix time.h related breakage on musl
missing time.h for struct timeval usage
forward declaration of struct timeval in time-private.h
---
ell/dhcp-transport.c | 1 +
ell/dhcp6-transport.c | 1 +
ell/icmp6.c | 1 +
ell/time-private.h | 2 +-
ell/time.c | 1 +
5 files changed, 5 insertions(+), 1 deletion(-)
diff --git a/ell/dhcp-transport.c b/ell/dhcp-transport.c
index ef030de..c4cf0ca 100644
--- a/ell/dhcp-transport.c
+++ b/ell/dhcp-transport.c
@@ -40,6 +40,7 @@
#include <linux/filter.h>
#include <net/if_arp.h>
#include <errno.h>
+#include <sys/time.h>
#include "io.h"
#include "util.h"
diff --git a/ell/dhcp6-transport.c b/ell/dhcp6-transport.c
index 30c425f..5ff6516 100644
--- a/ell/dhcp6-transport.c
+++ b/ell/dhcp6-transport.c
@@ -35,6 +35,7 @@
#include <net/if.h>
#include <unistd.h>
#include <errno.h>
+#include <sys/time.h>
#include "private.h"
#include "missing.h"
diff --git a/ell/icmp6.c b/ell/icmp6.c
index 368977f..7319903 100644
--- a/ell/icmp6.c
+++ b/ell/icmp6.c
@@ -36,6 +36,7 @@
#include <net/if.h>
#include <unistd.h>
#include <errno.h>
+#include <sys/time.h>
#include "private.h"
#include "useful.h"
diff --git a/ell/time-private.h b/ell/time-private.h
index 5295d94..83c23dd 100644
--- a/ell/time-private.h
+++ b/ell/time-private.h
@@ -19,7 +19,7 @@
* Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
*
*/
-
+struct timeval;
uint64_t _time_pick_interval_secs(uint32_t min_secs, uint32_t max_secs);
uint64_t _time_fuzz_msecs(uint64_t ms);
uint64_t _time_fuzz_secs(uint32_t secs, uint32_t max_offset);
diff --git a/ell/time.c b/ell/time.c
index 10e10b0..41e5725 100644
--- a/ell/time.c
+++ b/ell/time.c
@@ -26,6 +26,7 @@
#define _GNU_SOURCE
#include <time.h>
+#include <sys/time.h>
#include "time.h"
#include "time-private.h"
--
2.36.1
This diff is collapsed.
Click to expand it.
community/iwd/APKBUILD
+
5
−
2
View file @
340d7162
...
...
@@ -2,7 +2,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname
=
iwd
pkgver
=
1.2
7
pkgver
=
1.2
8
pkgrel
=
0
pkgdesc
=
"Internet Wireless Daemon"
url
=
"https://iwd.wiki.kernel.org/"
...
...
@@ -24,6 +24,8 @@ source="https://mirrors.edge.kernel.org/pub/linux/network/wireless/iwd-$pkgver.t
ead.initd
ead.confd
main.conf
0001-build-fix-time.h-related-breakage-on-musl.patch
"
build
()
{
...
...
@@ -77,10 +79,11 @@ ead_openrc() {
}
sha512sums
=
"
f
0bb7356e3c408f54c594d65b294ba5abfafa11748f45635d86323452aa22f53140f46930e72bfe0790f282e2e15a394c093b816547fda28f50f49716193913a
iwd-1.2
7
.tar.gz
f
5d366f62fdbd7b6921719aefc7da26a618c596364744c0bba04490b6d249156f9c16bc236526282700cd5949a1546b54508be169d5cfb47526c6cf1ddef267d
iwd-1.2
8
.tar.gz
6db0cd6350eeb1e594290b87329a813651db6ae93f5cd917e26a6f1612f3df2e7f2c82779ef897a1c9b491d328d7059283761e4728f7830308cac37cc6e5cdc3 iwd.initd
e940b1b5f122f1eb2b7e53d3b56d2b74139922941b429aa92778ed54d856d770e280c06fdda192aa49c2b6e7d69723ffec59b2839f7cea1b08b1e7a2d336636f iwd.confd
509401a385476b2491f175893013093217351409729ebf3746b8c4cb33c5b6c812fd5ca3d85881a520ad40696c414dfb3a0b585b5dd937c9437142677dc49492 ead.initd
c44abe2943b7befea0afa2bad55cc022078c2c3103bb99028a5f0e9210ecb9c7b746b339fc15ab866ee8664ccc2c226e2776eeb8e4288da83cb7427adf7a6cd2 ead.confd
09f4097e653cfecfa1e4bc7b4843832785d0a8ef2a8ecf7daa3d5be704d9ac311fbbecf9f9f5b8b1c75beff894e4cf0d8fda4d6ff728a638dedf77aff0197179 main.conf
9543fb27bf364848798e9219de57e8fa60b46372ff0719769d413957098ed4ee6835a4a2661536214a8bcd48b94f8a30217770eb243be01669f8d47fbec11c3d 0001-build-fix-time.h-related-breakage-on-musl.patch
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment