Skip to content
Snippets Groups Projects
Commit 33843010 authored by Sertonix's avatar Sertonix Committed by Natanael Copa
Browse files

community/polkit: upgrade to 125

parent 3e36742c
No related branches found
No related tags found
1 merge request!70383community/polkit: upgrade to 125
Pipeline #252813 skipped
......@@ -3,10 +3,10 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=polkit
pkgver=124
pkgver=125
pkgrel=0
pkgdesc="Application development toolkit for controlling system-wide privileges"
url="https://www.freedesktop.org/wiki/Software/polkit/"
url="https://github.com/polkit-org/polkit"
arch="all"
license="GPL-2.0-or-later"
options="suid !check" # Needs a functioning dbus daemon
......@@ -34,10 +34,10 @@ subpackages="
$pkgname-elogind-dev:_elogind_dev
$pkgname-elogind-libs:_elogind_libs
"
source="https://gitlab.freedesktop.org/polkit/polkit/-/archive/$pkgver/polkit-$pkgver.tar.bz2
source="https://github.com/polkit-org/polkit/archive/refs/tags/$pkgver/polkit-$pkgver.tar.gz
alpine-polkit.pam
polkit.initd
logind_dep.patch
args.patch
"
# secfixes:
......@@ -51,7 +51,7 @@ build() {
_build no-elogind -Dsession_tracking="ConsoleKit"
msg 'Building with elogind'
_build elogind -Dsession_tracking="libelogind"
_build elogind -Dsession_tracking="elogind"
}
_build() {
......@@ -194,8 +194,8 @@ openrc() {
}
sha512sums="
db520882b0bedf1c96052570bf4c55d7e966d8172f6d26acf0791d98c4b911fce5ee39e6d830f06122ac8df33c6b43c252cdb7ba3a54523804824ebf355405dc polkit-124.tar.bz2
64d85c1557355d6de6483beeb855b74a99dbb30cf9968206dc0aaf147156072ca2604bf667533099ee3972b3eed0421ec0a1ff8bea35a1e4c54da7b9688e0953 polkit-125.tar.gz
f5102dc00d390b3a3c957b62e1712db778c7ffb7378f3d8e816c0757c11a308c5d5303e42595b0d6add9839247c773880cd34e56afacc89eb6efaadf9aae7826 alpine-polkit.pam
f6e5ac0ed41feb392dfd104979ec577c5936f3db2bd252b12b7b9b2609a0901dae38bebec1ea65ccf4f427860b520383ae4d2c66fb74ab986c715f6b0ad50473 polkit.initd
d93b47cbb0a490fba030dfc2a02ddc5e9271856a7b962ccb5dc3a110e7dcbd4361dbaaf62cf02a3d53f3568cf227485c14a3b9ca30536a3d3be29c4e4a48da37 logind_dep.patch
0605c528e25ea1f281ea7708e0185df971174e809ef112c24caa18658b78c6b819890897a4e5d5353098c52be2fccea6a902049c846b3b6b713cb7501f431703 args.patch
"
Add missing arguments
Ref https://github.com/polkit-org/polkit/commit/64f5e4dda5240702ea3ad5d00ba8c5207fbacf72
--- a/src/polkitbackend/polkitbackendduktapeauthority.c
+++ b/src/polkitbackend/polkitbackendduktapeauthority.c
@@ -767,12 +767,14 @@ runaway_killer_common(PolkitBackendJsAuthority *authority, RunawayKillerCtx *ctx
#ifdef HAVE_PTHREAD_CONDATTR_SETCLOCK
if ((pthread_err = pthread_condattr_init(&attr))) {
polkit_backend_authority_log (POLKIT_BACKEND_AUTHORITY (authority),
+ LOG_LEVEL_ERROR,
"Error initializing condition variable attributes: %s",
strerror(pthread_err));
return FALSE;
}
if ((pthread_err = pthread_condattr_setclock(&attr, PK_CLOCK))) {
polkit_backend_authority_log (POLKIT_BACKEND_AUTHORITY (authority),
+ LOG_LEVEL_ERROR,
"Error setting condition variable attributes: %s",
strerror(pthread_err));
goto err_clean_condattr;
@@ -780,6 +782,7 @@ runaway_killer_common(PolkitBackendJsAuthority *authority, RunawayKillerCtx *ctx
/* Init again, with needed attr */
if ((pthread_err = pthread_cond_init(&ctx->cond, &attr))) {
polkit_backend_authority_log (POLKIT_BACKEND_AUTHORITY (authority),
+ LOG_LEVEL_ERROR,
"Error initializing condition variable: %s",
strerror(pthread_err));
goto err_clean_condattr;
--- a/meson.build
+++ b/meson.build
@@ -219,7 +219,7 @@
systemd_systemdsystemunitdir = systemd_dep.get_pkgconfig_variable('systemdsystemunitdir')
endif
- systemd_sysusers_dir = systemd_dep.get_pkgconfig_variable('sysusers_dir', default: '/usr/lib/sysusers.d')
+ systemd_sysusers_dir = logind_dep.get_pkgconfig_variable('sysusers_dir', default: '/usr/lib/sysusers.d')
endif
config_h.set('HAVE_LIBSYSTEMD', enable_logind)
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment