Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
2fd0a7b0
Commit
2fd0a7b0
authored
4 years ago
by
Michał Polański
Committed by
Leo
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/gogs: modernize
parent
556aceb0
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!13434
community/gogs: modernize
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
community/gogs/APKBUILD
+19
-28
19 additions, 28 deletions
community/gogs/APKBUILD
with
19 additions
and
28 deletions
community/gogs/APKBUILD
+
19
−
28
View file @
2fd0a7b0
...
@@ -2,11 +2,10 @@
...
@@ -2,11 +2,10 @@
# Maintainer: 7heo <7heo@mail.com>
# Maintainer: 7heo <7heo@mail.com>
pkgname
=
gogs
pkgname
=
gogs
pkgver
=
0.12.2
pkgver
=
0.12.2
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"
A p
ainless self-hosted Git service"
pkgdesc
=
"
P
ainless self-hosted Git service"
url
=
"https://gogs.io/"
url
=
"https://gogs.io/"
# buildmode=pie not available on mips64
arch
=
"all !mips !mips64"
# limited by go
arch
=
"all !mips !mips64"
license
=
"MIT"
license
=
"MIT"
depends
=
"git"
depends
=
"git"
makedepends
=
"go perl libcap"
makedepends
=
"go perl libcap"
...
@@ -14,8 +13,8 @@ install="$pkgname.pre-install"
...
@@ -14,8 +13,8 @@ install="$pkgname.pre-install"
pkgusers
=
"gogs"
pkgusers
=
"gogs"
pkggroups
=
"www-data"
pkggroups
=
"www-data"
options
=
"!check"
# go race fails
options
=
"!check"
# go race fails
subpackages
=
"
$
{
pkgname
}
-openrc"
subpackages
=
"
$pkgname
-openrc"
source
=
"
$
{
pkgname
}
-
$
{
pkgver
}
.tar.gz::https://github.com/gogs/
$pkgname
/archive/v
$pkgver
.tar.gz
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/gogs/
gogs
/archive/v
$pkgver
.tar.gz
$pkgname
.initd
$pkgname
.initd
$pkgname
.confd
$pkgname
.confd
$pkgname
.ini"
$pkgname
.ini"
...
@@ -23,24 +22,20 @@ builddir="$srcdir/github.com/gogs/$pkgname"
...
@@ -23,24 +22,20 @@ builddir="$srcdir/github.com/gogs/$pkgname"
prepare
()
{
prepare
()
{
mkdir
-p
"
$srcdir
"
/github.com/gogs
mkdir
-p
"
$srcdir
"
/github.com/gogs
mv
"
$srcdir
"
/
$pkgname
-
$pkgver
"
$builddir
"
/
||
return
1
mv
"
$srcdir
"
/
$pkgname
-
$pkgver
"
$builddir
"
/
default_prepare
default_prepare
}
}
build
()
{
build
()
{
export
GOPATH
=
"
$startdir
"
export
GOPATH
=
"
$startdir
"
cd
"
$builddir
"
||
return
1
go fix
go fix
||
return
1
# Note: sqlite causes problems without the pie buildmode
# Note: sqlite causes problems without the pie buildmode
go build
-buildmode
=
pie
-v
-tags
"sqlite redis memcache cert"
||
return
1
go build
-buildmode
=
pie
-v
-tags
"sqlite redis memcache cert"
}
}
package
()
{
package
()
{
cd
"
$builddir
"
install
-dm755
"
$pkgdir
"
/usr/share/webapps/
$pkgname
install
-d
-m
0755
\
"
$pkgdir
"
/usr/share/webapps/
$pkgname
||
return
1
# TODO: Is it really necessary to be world-readable?!
# TODO: Is it really necessary to be world-readable?!
install
-d
-m
0
755
-o
gogs
-g
www-data
\
install
-d
m
755
-o
gogs
-g
www-data
\
"
$pkgdir
"
/var/lib/
$pkgname
\
"
$pkgdir
"
/var/lib/
$pkgname
\
"
$pkgdir
"
/var/lib/
$pkgname
/git
\
"
$pkgdir
"
/var/lib/
$pkgname
/git
\
"
$pkgdir
"
/var/lib/
$pkgname
/db
\
"
$pkgdir
"
/var/lib/
$pkgname
/db
\
...
@@ -48,23 +43,19 @@ package() {
...
@@ -48,23 +43,19 @@ package() {
"
$pkgdir
"
/var/lib/
$pkgname
/attachements
\
"
$pkgdir
"
/var/lib/
$pkgname
/attachements
\
"
$pkgdir
"
/var/cache/
$pkgname
/sessions
\
"
$pkgdir
"
/var/cache/
$pkgname
/sessions
\
"
$pkgdir
"
/var/log/
$pkgname
\
"
$pkgdir
"
/var/log/
$pkgname
\
"
$pkgdir
"
/etc/
$pkgname
/conf
||
return
1
"
$pkgdir
"
/etc/
$pkgname
/conf
install
-D
-m
0755
$pkgname
\
install
-Dm755
$pkgname
"
$pkgdir
"
/usr/bin/
$pkgname
"
$pkgdir
"
/usr/bin/
$pkgname
||
return
1
# Allow to bind to port 80
# Allow to bind to port 80.
setcap
cap_net_bind_service
=
+ep
"
$pkgdir
"
/usr/bin/
$pkgname
setcap
cap_net_bind_service
=
+ep
\
"
$pkgdir
"
/usr/bin/
$pkgname
||
return
1
install
-D
-m
0
664
-o
gogs
-g
www-data
"
$srcdir
"
/
$
{
pkgname
}
.ini
\
install
-D
m
664
-o
gogs
-g
www-data
"
$srcdir
"
/
$pkgname
.ini
\
"
$pkgdir
"
/etc/
$pkgname
/conf/app.ini
||
return
1
"
$pkgdir
"
/etc/
$pkgname
/conf/app.ini
mv
public templates
"
$pkgdir
"
/usr/share/webapps/
$pkgname
/
||
return
1
mv
public templates
"
$pkgdir
"
/usr/share/webapps/
$pkgname
/
install
-m755
-D
"
$srcdir
"
/
$pkgname
.initd
\
install
-Dm755
"
$srcdir
"
/
$pkgname
.initd
"
$pkgdir
"
/etc/init.d/
$pkgname
"
$pkgdir
"
/etc/init.d/
$pkgname
install
-Dm644
"
$srcdir
"
/
$pkgname
.confd
"
$pkgdir
"
/etc/conf.d/
$pkgname
install
-m644
-D
"
$srcdir
"
/
$pkgname
.confd
\
"
$pkgdir
"
/etc/conf.d/
$pkgname
}
}
cleanup_srcdir
()
{
cleanup_srcdir
()
{
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment