Skip to content
Snippets Groups Projects
Commit 2e36f1c2 authored by Thomas Böhler's avatar Thomas Böhler Committed by Patrycja Rosa
Browse files
parent 38dcc8d2
No related branches found
No related tags found
1 merge request!81697testing/cocogitto: upgrade to 6.3.0
Pipeline #309505 canceled
diff --git a/Cargo.lock b/Cargo.lock
index 3e3b8db..ef42ca2 100644
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -1,6 +1,6 @@
# This file is automatically @generated by Cargo.
# It is not intended for manual editing.
-version = 3
+version = 4
[[package]]
name = "aho-corasick"
@@ -341,7 +341,7 @@ dependencies = [
"git2",
"globset",
"indoc",
- "itertools 0.12.1",
+ "itertools",
"log",
"once_cell",
"pest",
@@ -664,9 +664,9 @@ dependencies = [
[[package]]
name = "git2"
-version = "0.18.3"
+version = "0.20.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "232e6a7bfe35766bf715e55a88b39a700596c0ccfd88cd3680b4cdb40d66ef70"
+checksum = "3fda788993cc341f69012feba8bf45c0ba4f3291fcc08e214b4d5a7332d88aff"
dependencies = [
"bitflags 2.5.0",
"libc",
@@ -830,15 +830,6 @@ version = "1.70.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "f8478577c03552c21db0e2724ffb8986a5ce7af88107e6be5d2ee6e158c12800"
-[[package]]
-name = "itertools"
-version = "0.12.1"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "ba291022dbbd398a455acf126c1e341954079855bc60dfdda641363bd6922569"
-dependencies = [
- "either",
-]
-
[[package]]
name = "itertools"
version = "0.13.0"
@@ -886,9 +877,9 @@ checksum = "ae743338b92ff9146ce83992f766a31066a91a8c84a45e0e9f21e7cf6de6d346"
[[package]]
name = "libgit2-sys"
-version = "0.16.2+1.7.2"
+version = "0.18.0+1.9.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "ee4126d8b4ee5c9d9ea891dd875cfdc1e9d0950437179104b183d7d8a74d24e8"
+checksum = "e1a117465e7e1597e8febea8bb0c410f1c7fb93b1e1cddf34363f8390367ffec"
dependencies = [
"cc",
"libc",
@@ -1847,7 +1838,7 @@ checksum = "62e206681a3cc2282151908aab9892c7227fe1a702c8b624700b201e5b66edc9"
dependencies = [
"async-graphql-parser",
"async-graphql-value",
- "itertools 0.13.0",
+ "itertools",
"maplit",
"regex",
"serde",
diff --git a/Cargo.toml b/Cargo.toml
index 68b30c4..ad0cf5e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -20,7 +20,7 @@ codegen-units = 1
panic = "abort"
[dependencies]
-git2 = { version = "0.18.2", default-features = false, features = [] }
+git2 = { version = "0.20.0", default-features = false, features = [] }
# Do not bump anyhow, (see: https://github.com/dtolnay/anyhow/issues/353)
anyhow = "1.0.75"
colored = "^2"
maintainer="Thomas Böhler <witcher@wiredspace.de>" maintainer="Thomas Böhler <witcher@wiredspace.de>"
pkgname=cocogitto pkgname=cocogitto
pkgver=6.2.0 pkgver=6.3.0
pkgrel=2 pkgrel=0
pkgdesc="The Conventional Commits toolbox" pkgdesc="The Conventional Commits toolbox"
url="https://docs.cocogitto.io/" url="https://docs.cocogitto.io/"
arch="all" arch="all"
...@@ -18,8 +18,7 @@ subpackages=" ...@@ -18,8 +18,7 @@ subpackages="
$pkgname-zsh-completion $pkgname-zsh-completion
" "
source="$pkgname-$pkgver.tar.gz::https://github.com/cocogitto/cocogitto/archive/refs/tags/$pkgver.tar.gz source="$pkgname-$pkgver.tar.gz::https://github.com/cocogitto/cocogitto/archive/refs/tags/$pkgver.tar.gz
001-bump-libgit2.patch 001-bump-libc.patch
002-bump-libc.patch
" "
options="net !check" # tests relies on, among other things, specific tags options="net !check" # tests relies on, among other things, specific tags
...@@ -63,7 +62,6 @@ package() { ...@@ -63,7 +62,6 @@ package() {
} }
sha512sums=" sha512sums="
98d6485e74e1e4664e353b29e165a22505207c8ce2fc1467ffe988ed9475349adc9c638f245ce1881c322a87158e39daef17bf0d350424dc444cabd700b4a39f cocogitto-6.2.0.tar.gz 5e83f4be27affbf9d15f22d34e7d43522affd9cc5f5ae7436ce257ac734465190e4f1833747fe51876ae510bc04234579997c6348f9a74c4cddda37bc2adf40f cocogitto-6.3.0.tar.gz
6d10dd59124422cb150ce6633add50b0067df161905725f1e4393b8ecf4d6f55c41bde9c682e3c551160c3f8526787a877aa69c07f59a8766165327978a1b0fc 001-bump-libgit2.patch d1ef6b3e11e845874318c24d8e281ed6526a0dbf1ad688f483d639867dbb0b56843d9b2d62271ad8efa5605fb12864498c57e425dc313fc5cbee84bea53db407 001-bump-libc.patch
d1ef6b3e11e845874318c24d8e281ed6526a0dbf1ad688f483d639867dbb0b56843d9b2d62271ad8efa5605fb12864498c57e425dc313fc5cbee84bea53db407 002-bump-libc.patch
" "
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment