Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
2da511b0
Commit
2da511b0
authored
1 year ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
main/cmake: upgrade to 3.27.0
parent
bcb820c1
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/cmake/APKBUILD
+17
-12
17 additions, 12 deletions
main/cmake/APKBUILD
main/cmake/proto-23-rename.patch
+0
-37
0 additions, 37 deletions
main/cmake/proto-23-rename.patch
with
17 additions
and
49 deletions
main/cmake/APKBUILD
+
17
−
12
View file @
2da511b0
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
cmake
pkgname
=
cmake
pkgver
=
3.2
6.4
pkgver
=
3.2
7.0
pkgrel
=
3
pkgrel
=
0
pkgdesc
=
"Cross-platform, open-source make system"
pkgdesc
=
"Cross-platform, open-source make system"
url
=
"https://www.cmake.org/"
url
=
"https://www.cmake.org/"
arch
=
"all"
arch
=
"all"
...
@@ -33,16 +33,13 @@ case $pkgver in
...
@@ -33,16 +33,13 @@ case $pkgver in
*
.
*
.
*
.
*
)
_v
=
v
${
pkgver
%.*.*
}
;;
*
.
*
.
*
.
*
)
_v
=
v
${
pkgver
%.*.*
}
;;
*
.
*
.
*
)
_v
=
v
${
pkgver
%.*
}
;;
*
.
*
.
*
)
_v
=
v
${
pkgver
%.*
}
;;
esac
esac
source
=
"https://www.cmake.org/files/
$_v
/cmake-
$pkgver
.tar.gz
source
=
"https://www.cmake.org/files/
$_v
/cmake-
$pkgver
.tar.gz"
proto-23-rename.patch
"
options
=
"!check"
options
=
"!check"
build
()
{
build
()
{
# jsoncpp needs cmake to build so to avoid recursive build
# jsoncpp/cppdap needs cmake to build so to avoid recursive build
# dependency, we use the bundled version of jsoncpp.
# dependency, we use the bundled version.
# Do NOT remove --no-system-jsoncpp unless you consulted
# Do NOT remove --no-system-jsoncpp or --no-system-cppdap
# maintainer
./bootstrap
\
./bootstrap
\
--prefix
=
/usr
\
--prefix
=
/usr
\
...
@@ -50,8 +47,17 @@ build() {
...
@@ -50,8 +47,17 @@ build() {
--datadir
=
/share/
$pkgname
\
--datadir
=
/share/
$pkgname
\
--docdir
=
/share/doc/
$pkgname
\
--docdir
=
/share/doc/
$pkgname
\
--sphinx-man
\
--sphinx-man
\
--system-
libs
\
--
no-
system-
cppdap
\
--no-system-jsoncpp
\
--no-system-jsoncpp
\
--system-bzip2
\
--system-curl
\
--system-expat
\
--system-libarchive
\
--system-liblzma
\
--system-librhash
\
--system-libuv
\
--system-nghttp2
\
--system-zlib
\
--generator
=
Ninja
\
--generator
=
Ninja
\
--parallel
=
"
${
JOBS
:-
2
}
"
--parallel
=
"
${
JOBS
:-
2
}
"
ninja
ninja
...
@@ -86,6 +92,5 @@ vim() {
...
@@ -86,6 +92,5 @@ vim() {
}
}
sha512sums
=
"
sha512sums
=
"
fe817c8d5e247db3f0a9a58ee37c466a47220100d9e90711cd5d06c223cef87e41d1a756e75d1537e5f8cd010dcb8971cbeab4684b1ac12bcecf84bf7b720167 cmake-3.26.4.tar.gz
8b5836ac1c1f1e741ebbf6c9a1c9dca322dfd963598838a8789cd926fc071bde2fc53e42b6a2d5d8697f12d96dbf2cebdf03817d7d84b68256ef80b779a27fed cmake-3.27.0.tar.gz
9210cd7821d63871b970b046fb6b8b4771806517829fbb58b17ef3ed611b6d4a5a310f35eb486c1c5d19bcd19b2f3ad177f121a1a5448b44241ea5a50c96fc52 proto-23-rename.patch
"
"
This diff is collapsed.
Click to expand it.
main/cmake/proto-23-rename.patch
deleted
100644 → 0
+
0
−
37
View file @
bcb820c1
Patch-Source: https://gitlab.kitware.com/cmake/cmake/-/commit/fc7dcc6a24ffd33b780104ebd9dbb115d306827e
--
From fc7dcc6a24ffd33b780104ebd9dbb115d306827e Mon Sep 17 00:00:00 2001
From: Jannik Beyerstedt <beyerstedt@consider-it.de>
Date: Mon, 19 Jun 2023 17:29:47 +0200
Subject: [PATCH] FindProtobuf: Support new version number scheme
Protobuf changed it's version number scheme with version 21. The first number
(usually the major version) is not synchronized between compiler and library
version, but the second and third number are. See
https://protobuf.dev/news/2022-05-06/ for more details.
Fixes: #24847
---
Modules/FindProtobuf.cmake | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/Modules/FindProtobuf.cmake b/Modules/FindProtobuf.cmake
index c73a2d81ab0..b046fcc7334 100644
--- a/Modules/FindProtobuf.cmake
+++ b/Modules/FindProtobuf.cmake
@@ -499,7 +499,11 @@
if(Protobuf_INCLUDE_DIR)
math(EXPR _PROTOBUF_MAJOR_VERSION "${Protobuf_LIB_VERSION} / 1000000")
math(EXPR _PROTOBUF_MINOR_VERSION "${Protobuf_LIB_VERSION} / 1000 % 1000")
math(EXPR _PROTOBUF_SUBMINOR_VERSION "${Protobuf_LIB_VERSION} % 1000")
- set(Protobuf_VERSION "${_PROTOBUF_MAJOR_VERSION}.${_PROTOBUF_MINOR_VERSION}.${_PROTOBUF_SUBMINOR_VERSION}")
+ if (_PROTOBUF_MINOR_VERSION GREATER_EQUAL "21")
+ set(Protobuf_VERSION "${_PROTOBUF_MINOR_VERSION}.${_PROTOBUF_SUBMINOR_VERSION}")
+ else()
+ set(Protobuf_VERSION "${_PROTOBUF_MAJOR_VERSION}.${_PROTOBUF_MINOR_VERSION}.${_PROTOBUF_SUBMINOR_VERSION}")
+ endif()
if(Protobuf_DEBUG)
message(STATUS "[ ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE} ] "
--
GitLab
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment