Skip to content
Snippets Groups Projects
Commit 2cfffff9 authored by Jakub Jirutka's avatar Jakub Jirutka :flag_ua:
Browse files

community/julia: upgrade to 0.6.0

parent 243ef376
No related branches found
No related tags found
No related merge requests found
From: Jakub Jirutka <jakub@jirutka.cz> From: Jakub Jirutka <jakub@jirutka.cz>
Date: Sun, 05 Jun 2016 14:11:00 +0200 Date: Sun, 05 Jun 2016 14:11:00 +0200
Last-Updated: Thu, 19 Oct 2017 01:04:00 +0200
Subject: [PATCH] Disable PaX memory protection for julia binary Subject: [PATCH] Disable PaX memory protection for julia binary
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -71,7 +71,13 @@ @@ -111,8 +111,14 @@
julia-sysimg-debug : julia-inference julia-ui-debug julia-sysimg-debug : julia-inference julia-ui-debug
@$(MAKE) $(QUIET_MAKE) $(build_private_libdir)/sys-debug.$(SHLIB_EXT) JULIA_BUILD_MODE=debug @$(MAKE) $(QUIET_MAKE) -C $(BUILDROOT) $(build_private_libdir)/sys-debug$(CPUID_TAG).$(SHLIB_EXT) JULIA_BUILD_MODE=debug
-julia-debug julia-release : julia-% : julia-ui-% julia-sysimg-% julia-symlink julia-libccalltest -julia-debug julia-release : julia-% : julia-ui-% julia-sysimg-% julia-symlink julia-libccalltest
+julia-pax-release : julia-ui-release +julia-pax-release : julia-ui-release
+ paxmark m $(JULIA_EXECUTABLE_release) + paxmark m $(JULIA_EXECUTABLE_release)
+
+julia-pax-debug : julia-ui-debug +julia-pax-debug : julia-ui-debug
+ paxmark m $(JULIA_EXECUTABLE_debug) + paxmark m $(JULIA_EXECUTABLE_debug)
+ +
+julia-debug julia-release : julia-% : julia-ui-% julia-pax-% julia-sysimg-% julia-symlink julia-libccalltest +julia-debug julia-release : julia-% : julia-ui-% julia-pax-% julia-sysimg-% julia-symlink julia-libccalltest
+
debug release : % : julia-% debug release : % : julia-%
@@ -527,7 +533,7 @@ docs: julia-sysimg-$(JULIA_BUILD_MODE)
@@ -551,7 +557,7 @@
test testall testall1 test clean distcleanall cleanall clean-* \ test testall testall1 test clean distcleanall cleanall clean-* \
run-julia run-julia-debug run-julia-release run \ run-julia run-julia-debug run-julia-release run \
install binary-dist light-source-dist.tmp light-source-dist \ install binary-dist light-source-dist.tmp light-source-dist \
- dist full-source-dist source-dist - dist full-source-dist source-dist examples
+ dist full-source-dist source-dist julia-pax-release julia-pax-debug + dist full-source-dist source-dist examples julia-pax-release julia-pax-debug
test: check-whitespace $(JULIA_BUILD_MODE) test: check-whitespace $(JULIA_BUILD_MODE)
@$(MAKE) $(QUIET_MAKE) -C test default JULIA_BUILD_MODE=$(JULIA_BUILD_MODE) @$(MAKE) $(QUIET_MAKE) -C $(BUILDROOT)/test default JULIA_BUILD_MODE=$(JULIA_BUILD_MODE)
Description: Ensure that build is verbose Description: Ensure that build is verbose
Author: Sébastien Villemot <sebastien@debian.org> Author: Sébastien Villemot <sebastien@debian.org>
Author: Shiz <hi@shiz.me> Author: Shiz <hi@shiz.me>
Author: Jakub Jirutka <jakub@jirutka.cz>
Forwarded: not-needed Forwarded: not-needed
Last-Update: 2017-05-19 Last-Updated: 2017-10-19
--- ---
--- a/deps/libuv.mk --- a/deps/libuv.mk
+++ b/deps/libuv.mk +++ b/deps/libuv.mk
@@ -33,7 +33,7 @@ @@ -30,7 +30,7 @@
touch -c $(SRCDIR)/srccache/$(LIBUV_SRC_DIR)/configure touch -c $(SRCDIR)/srccache/$(LIBUV_SRC_DIR)/configure
mkdir -p $(dir $@) mkdir -p $(dir $@)
cd $(dir $@) && \ cd $(dir $@) && \
- $< --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS) - $(dir $<)/configure --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS)
+ $< --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS) --disable-silent-rules + $(dir $<)/configure --with-pic $(CONFIGURE_COMMON) $(UV_FLAGS) --disable-silent-rules
touch -c $@ echo 1 > $@
$(UV_SRC_TARGET): $(BUILDDIR)/$(LIBUV_SRC_DIR)/config.status
$(MAKE) -C $(dir $<) $(UV_MFLAGS) $(BUILDDIR)/$(LIBUV_SRC_DIR)/build-compiled: $(BUILDDIR)/$(LIBUV_SRC_DIR)/build-configured
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -540,7 +540,6 @@ @@ -526,7 +526,6 @@
clean: | $(CLEAN_TARGETS) clean: | $(CLEAN_TARGETS)
@-$(MAKE) -C $(BUILDROOT)/base clean @-$(MAKE) -C $(BUILDROOT)/base clean
...@@ -8,11 +8,11 @@ ...@@ -8,11 +8,11 @@
@-$(MAKE) -C $(BUILDROOT)/src clean @-$(MAKE) -C $(BUILDROOT)/src clean
@-$(MAKE) -C $(BUILDROOT)/ui clean @-$(MAKE) -C $(BUILDROOT)/ui clean
@-$(MAKE) -C $(BUILDROOT)/test clean @-$(MAKE) -C $(BUILDROOT)/test clean
@@ -564,7 +563,6 @@ @@ -548,7 +547,6 @@
distcleanall: cleanall distcleanall: cleanall
@-$(MAKE) -C $(BUILDROOT)/deps distcleanall @-$(MAKE) -C $(BUILDROOT)/deps distcleanall
- @-$(MAKE) -C $(BUILDROOT)/doc cleanall - @-$(MAKE) -C $(BUILDROOT)/doc cleanall
-rm -fr $(build_prefix) $(build_staging)
.PHONY: default debug release check-whitespace release-candidate \ .PHONY: default debug release check-whitespace release-candidate \
julia-debug julia-release julia-deps \
From 6f09a6de41e7e35779e0755d9e52a4bf79424109 Mon Sep 17 00:00:00 2001
From: albap <albapompeo@gmail.com>
Date: Sun, 31 Jan 2016 10:50:02 -0200
Subject: [PATCH] Remove nonstandard header sys/sysctl.h
This header prevents me from building Julia on musl libc.
```
/home/alba/julia/src/sys.c:16:24: fatal error: sys/sysctl.h: No such file or directory
compilation terminated.
Makefile:94: recipe for target 'sys.o' failed
make[1]: *** [sys.o] Error 1
```
If I remove it from julia/src/sys.c then it works.
Why is sys/sysctl.h needed in first place? I cannot find it in POSIX.
---
src/sys.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/src/sys.c b/src/sys.c
index 9a48871..89069a9 100644
--- a/src/sys.c
+++ b/src/sys.c
@@ -13,7 +13,6 @@
#ifdef _OS_WINDOWS_
#include <psapi.h>
#else
-#include <sys/sysctl.h>
#include <sys/wait.h>
#include <sys/ptrace.h>
#include <unistd.h>
...@@ -2,11 +2,11 @@ ...@@ -2,11 +2,11 @@
# Contributor: Shiz <hi@shiz.me> # Contributor: Shiz <hi@shiz.me>
# Maintainer: Shiz <hi@shiz.me> # Maintainer: Shiz <hi@shiz.me>
pkgname=julia pkgname=julia
pkgver=0.5.2 pkgver=0.6.0
# Keep in sync with deps/libuv.version. # Keep in sync with deps/libuv.version.
_libuv_ver=8d5131b6c1595920dd30644cd1435b4f344b46c8 _libuv_ver=52d72a52cc7ccd570929990f010ed16e2ec604c8
_llvm_ver=3.9 _llvm_ver=3.9
pkgrel=3 pkgrel=0
pkgdesc="A high-level, high-performance dynamic language for technical computing" pkgdesc="A high-level, high-performance dynamic language for technical computing"
url="http://julialang.org" url="http://julialang.org"
# x86: no libunwind package # x86: no libunwind package
...@@ -25,6 +25,7 @@ depends="arpack ...@@ -25,6 +25,7 @@ depends="arpack
suitesparse>=4.1 suitesparse>=4.1
" "
depends_dev="arpack-dev depends_dev="arpack-dev
curl-dev
dsfmt-dev dsfmt-dev
fftw-dev fftw-dev
gmp-dev gmp-dev
...@@ -55,10 +56,12 @@ source="https://github.com/JuliaLang/julia/releases/download/v$pkgver/$pkgname-$ ...@@ -55,10 +56,12 @@ source="https://github.com/JuliaLang/julia/releases/download/v$pkgver/$pkgname-$
0001-hardened.patch 0001-hardened.patch
0002-verbose-build.patch 0002-verbose-build.patch
0003-no-clean-docs.patch 0003-no-clean-docs.patch
0004-remove-sysctl.h.patch
0005-fix-rpath-issues.patch 0005-fix-rpath-issues.patch
0008-ldconfig-compat.patch 0008-ldconfig-compat.patch
fix-or-disable-broken-tests.patch fix-or-disable-broken-tests.patch
test-disable-tests-using-fake_pty.patch
test-libgit2-skip-SSL_CERT_FILE.patch
test-repl-disable-22176-20482.patch
" "
builddir="$srcdir/$pkgname-$pkgver" builddir="$srcdir/$pkgname-$pkgver"
ldpath="/usr/lib/julia" ldpath="/usr/lib/julia"
...@@ -106,6 +109,7 @@ prepare() { ...@@ -106,6 +109,7 @@ prepare() {
USE_SYSTEM_SUITESPARSE=1 USE_SYSTEM_SUITESPARSE=1
USE_SYSTEM_LIBUV=0 USE_SYSTEM_LIBUV=0
USE_SYSTEM_UTF8PROC=1 USE_SYSTEM_UTF8PROC=1
USE_SYSTEM_CURL=1
USE_SYSTEM_LIBGIT2=1 USE_SYSTEM_LIBGIT2=1
USE_SYSTEM_PATCHELF=1 USE_SYSTEM_PATCHELF=1
USE_LLVM_SHLIB=1 USE_LLVM_SHLIB=1
...@@ -163,13 +167,15 @@ dbg() { ...@@ -163,13 +167,15 @@ dbg() {
mv "$pkgdir"/usr/lib/julia/*-debug.* "$subpkgdir"/usr/lib/julia/ mv "$pkgdir"/usr/lib/julia/*-debug.* "$subpkgdir"/usr/lib/julia/
} }
sha512sums="70b3e23c7297d86268c2d32b0c19976dc6f9512bd41c5e9f621b1b9a082ed25ee85cf5f11f3e5acfc623b3a13fa88d245eb2609bad01935d86d90b502d068353 julia-0.5.2.tar.gz sha512sums="da21b35eb2c682c0fb8720974a76759c51fe993f10e6af5ca4864fc7f0bb6c90d880b706eb798476c7228bae2db19ff0825add6a2abde2961f16a93a3050cb69 julia-0.6.0.tar.gz
c53513a5aea84405bf302b084a23f24f54148aac90a2bd666219ce14879723baab959942934d0d801a4572fffd07e60a7d574ade8d7eb57b6da8216063c20a48 libuv-8d5131b6c1595920dd30644cd1435b4f344b46c8.tar.gz 4bf9c8b16617691b70ea43c667ecc575d2a06b3d0c347b949d10360c012138585a13ecea5e18de81b1585a96cf7734b7cc3d6072490898f1d5531c702cf5afab libuv-52d72a52cc7ccd570929990f010ed16e2ec604c8.tar.gz
0283c7b0ff7dd99ae79f6ddac63513ce7d58ba31de506a3fee07af9b8882ddc275d0f9cb002381ba1e304bcacf252612fa16b21b85667422477e6b945b725899 find-syslibs 0283c7b0ff7dd99ae79f6ddac63513ce7d58ba31de506a3fee07af9b8882ddc275d0f9cb002381ba1e304bcacf252612fa16b21b85667422477e6b945b725899 find-syslibs
15968d95b09ed0f2315e08a5fd14e798db7fd1faebd1327ceaf7886248b61d2e61f64e726d98cd70cbc2349c66fc3a707298a2481c6abf98c699826f3f2f4ccb 0001-hardened.patch f812b05b7712975eaef0bf071dd2c1cd0b21c68b18d6a513878bb8fe877bfcadf9f4b9dd8cd27b6809378de5b250a010301e7a90169677d155ad2ba377e8b428 0001-hardened.patch
6530709d5cd58970b5868a6a536727df6839b3aedfe81c67d4e5b37cf840803a33027eed338b47816810b9ae1119470acd097806e90a41cd59f8d1fcb0843663 0002-verbose-build.patch 52bbaff51c7d0299e875294b43e23773bcdbe1bc7d02b670814d051bb4f1224bba507182944dc739adb07acd10d3d7f5a0ac7c270c28d3a760d36d90520a2f16 0002-verbose-build.patch
66add07137c3baafba86aea1469ee2cf669f3fa4c01195c04c7a3f9e1b4a85dee020bef315919efa6261b675049bc251aa9fc1878ae7f7929baed5084eb697d7 0003-no-clean-docs.patch 04ab09428c299ca1cc7f162d2344763d9b9136c209a6718df62689f421b4925af20a7b739513965dcbdcbf191577b15d48ece08d63c6db21f8742c02d56a2ea0 0003-no-clean-docs.patch
6c111ccdd12af5b00fdf0b7cc8fba11980fceccf7c246b40e791cd1be8e39cd75b8c290c65ebd9b4add60fc242261e17e94807736fce6a96733e9bf18182b489 0004-remove-sysctl.h.patch
9875b3cdc49bcc2812ea52b2e25836ba22058dbad94287c9aa7c4e4ee48b7819655588a08d49cb9a3c73431ff6969b3b7eb140fc96dc5b0d64777c3027e06538 0005-fix-rpath-issues.patch 9875b3cdc49bcc2812ea52b2e25836ba22058dbad94287c9aa7c4e4ee48b7819655588a08d49cb9a3c73431ff6969b3b7eb140fc96dc5b0d64777c3027e06538 0005-fix-rpath-issues.patch
a66526aee8745875b254f0d27db78b10e76cd8489f4601c77b82674a31ee7a0cf417af8b24a520e069a464303ad7f0077b75543e197eaba48a75b960c9f81a05 0008-ldconfig-compat.patch a66526aee8745875b254f0d27db78b10e76cd8489f4601c77b82674a31ee7a0cf417af8b24a520e069a464303ad7f0077b75543e197eaba48a75b960c9f81a05 0008-ldconfig-compat.patch
1d128441bb3e15defa2b23c8d68255fe15320060ac7203ebf7d3573e9e8c0120ebf49b2256f022fdddcc816691c6271f35a27d36b03cbe203734b9f902417ca9 fix-or-disable-broken-tests.patch" 3f2a6cf439aaada90872b869972f17b506d2f39758f3e2407c3e5f6b28082e7797ed6f2d7e4bace56e02809fe94f879c2a34e22216aa19b08a452371b81e7462 fix-or-disable-broken-tests.patch
be3eea9d7506796a48171d244e61e8ee3f69ee659aa65ee738a7ec08499566a014bd6ee21ba39ec97e74d734a8b45b7ec1f5a630a96a31a6d4e17b274107b640 test-disable-tests-using-fake_pty.patch
a97a16e3b36c7c192c1133139c87b7b3a719cef645dd2435828b5b5468f4f9beb3bba0e02bb68935319dc150d0c4ccd4728c9eaedc9e2ddee2d823e881f36e2c test-libgit2-skip-SSL_CERT_FILE.patch
fc5eef406d84b60fdf1c837aa1f5bd0e7a205c311853d0ae8b2b237e2eb750d7da2152632d866d372174918a3953746620f2bf130596ab2b027ca389a6816edd test-repl-disable-22176-20482.patch"
...@@ -22,37 +22,37 @@ test/read.jl: ditto. ...@@ -22,37 +22,37 @@ test/read.jl: ditto.
close(p) close(p)
--- a/test/Makefile --- a/test/Makefile
+++ b/test/Makefile +++ b/test/Makefile
@@ -4,7 +4,7 @@ @@ -6,7 +6,7 @@
include $(JULIAHOME)/Make.inc
# TODO: this Makefile ignores BUILDDIR, except for computing JULIA_EXECUTABLE
-TESTS = all linalg $(filter-out TestHelpers runtests testdefs,$(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/*.jl $(SRCDIR)/linalg/*.jl)))
+TESTS = all linalg $(filter-out TestHelpers runtests testdefs libdl,$(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/*.jl $(SRCDIR)/linalg/*.jl)))
default: all
TESTGROUPS = linalg sparse unicode strings dates
TESTS = all $(TESTGROUPS) \
- $(filter-out TestHelpers runtests testdefs, \
+ $(filter-out TestHelpers runtests testdefs libdl, \
$(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/*.jl))) \
$(foreach group,$(TESTGROUPS), \
$(patsubst $(SRCDIR)/%.jl,%,$(wildcard $(SRCDIR)/$(group)/*.jl)))
--- a/test/cmdlineargs.jl --- a/test/cmdlineargs.jl
+++ b/test/cmdlineargs.jl +++ b/test/cmdlineargs.jl
@@ -301,7 +301,7 @@ @@ -404,7 +404,7 @@
bt = readstring(pipeline(ignorestatus(`$(Base.julia_cmd()) --startup-file=no --precompiled=$precomp bt = readstring(pipeline(ignorestatus(`$(Base.julia_cmd()) --startup-file=no --precompiled=$precomp
-E 'include("____nonexistent_file")'`), stderr=catcmd)) -E 'include("____nonexistent_file")'`), stderr=catcmd))
@test contains(bt, "in include_from_node1") @test contains(bt, "include_from_node1")
- if is_windows() && Sys.WORD_SIZE == 32 && precomp == "yes" - if is_windows() && Sys.WORD_SIZE == 32 && precomp == "yes"
+ if ((is_windows() && Sys.WORD_SIZE == 32) || is_linux()) && precomp == "yes" + if ((is_windows() && Sys.WORD_SIZE == 32) || is_linux()) && precomp == "yes"
# fixme, issue #17251 # fixme, issue #17251
@test_broken contains(bt, "in include_from_node1(::String) at $(joinpath(".","loading.jl"))") @test_broken contains(bt, "include_from_node1(::String) at $(joinpath(".","loading.jl"))")
else else
--- a/test/choosetests.jl --- a/test/choosetests.jl
+++ b/test/choosetests.jl +++ b/test/choosetests.jl
@@ -31,7 +31,7 @@ @@ -32,7 +32,7 @@
"replutil", "sets", "test", "goto", "llvmcall", "grisu", "replutil", "sets", "test", "goto", "llvmcall", "llvmcall2", "grisu",
"nullable", "meta", "stacktraces", "profile", "libgit2", "docs", "nullable", "meta", "stacktraces", "profile", "libgit2", "docs",
"markdown", "base64", "serialize", "misc", "threads", "markdown", "base64", "serialize", "misc", "threads",
- "enums", "cmdlineargs", "i18n", "workspace", "libdl", "int", - "enums", "cmdlineargs", "i18n", "workspace", "libdl", "int",
+ "enums", "cmdlineargs", "i18n", "workspace", "int", + "enums", "cmdlineargs", "i18n", "workspace", "int",
"checked", "intset", "floatfuncs", "compile", "parallel", "inline", "checked", "intset", "floatfuncs", "compile", "distributed", "inline",
"boundscheck", "error", "ambiguous", "cartesian" "boundscheck", "error", "ambiguous", "cartesian", "asmvariant", "osutils",
] "channels", "iostream", "specificity"
--- a/test/file.jl --- a/test/file.jl
+++ b/test/file.jl +++ b/test/file.jl
@@ -174,8 +174,8 @@ @@ -174,8 +174,8 @@
......
fake_pty does not work on Alpine or just inside LXC container...?
Error During Test
Got an exception of type ErrorException outside of a @test
Failed to open PTY master
Stacktrace:
[1] open_fake_pty() at test/TestHelpers.jl:31
[2] with_fake_pty(::TestHelpers.##5#8{Int64,Cmd,Array{Any,1},TestHelpers.#format_output#7{Bool}}) at test/TestHelpers.jl:47
[3] #challenge_prompt#4(::Int64, ::Bool, ::Function, ::Cmd, ::Array{Any,1}) at test/TestHelpers.jl:83
[4] (::TestHelpers.#kw##challenge_prompt)(::Array{Any,1}, ::TestHelpers.#challenge_prompt, ::Cmd, ::Array{Any,1}) at ./<missing>:0
[5] #challenge_prompt#1(::Int64, ::Bool, ::Function, ::String, ::Array{Any,1}) at test/TestHelpers.jl:68
[6] challenge_prompt(::String, ::Array{Any,1}) at test/TestHelpers.jl:57
[7] (::Test47Main_libgit2.##48#97)() at test/libgit2.jl:1301
--- a/test/repl.jl
+++ b/test/repl.jl
@@ -579,7 +579,7 @@
let exename = Base.julia_cmd()
# Test REPL in dumb mode
-if !is_windows()
+if false
TestHelpers.with_fake_pty() do slave, master
nENV = copy(ENV)
nENV["TERM"] = "dumb"
--- a/test/libgit2.jl
+++ b/test/libgit2.jl
@@ -1268,7 +1268,7 @@
# The following tests require that we can fake a TTY so that we can provide passwords
# which use the `getpass` function. At the moment we can only fake this on UNIX based
# systems.
- if is_unix()
+ if false
@testset "SSH credential prompt" begin
url = "git@github.com/test/package.jl"
This test fails and I have no clue why. It seems that SSL_CERT_FILE is ignored.
Hostname verification: Test Failed
Expression: err.code == LibGit2.Error.ERROR
Evaluated: ECERTIFICATE::Base.LibGit2.Error.Code = -17 == ERROR::Base.LibGit2.Error.Code = -1
Stacktrace:
[1] (::Test98Main_libgit2.##54#103{String,Cmd})() at test/libgit2.jl:1697
[2] withenv(::Test98Main_libgit2.##54#103{String,Cmd}, ::Pair{String,String}, ::Vararg{Pair{String,String},N} where N) at ./env.jl:157
[3] (::Test98Main_libgit2.##51#100)(::String) at test/libgit2.jl:1692
[4] mktempdir(::Test98Main_libgit2.##51#100, ::String) at ./file.jl:392
[5] macro expansion at test/libgit2.jl:1647 [inlined]
[6] macro expansion at ./test.jl:860 [inlined]
[7] (::Test98Main_libgit2.##7#56)(::String) at test/libgit2.jl:1606
--- a/test/libgit2.jl
+++ b/test/libgit2.jl
@@ -1694,8 +1694,8 @@
err = open(errfile, "r") do f
deserialize(f)
end
- @test err.code == LibGit2.Error.ERROR
- @test err.msg == "Invalid Content-Type: text/plain"
+ @test_skip err.code == LibGit2.Error.ERROR
+ @test_skip err.msg == "Invalid Content-Type: text/plain"
end
finally
kill(pobj)
There's some problem with temp file, don't know why...
Error During Test
Test threw an exception of type SystemError
Expression: readstring(tmp) == "123\n"
SystemError: opening file /tmp/julia_GolmjG: No such file or directory
Stacktrace:
[1] #systemerror#44 at ./error.jl:64 [inlined]
[2] systemerror at ./error.jl:64
[3] open at ./iostream.jl:104
[4] open at ./iostream.jl:150
[5] macro expansion at test/repl.jl:139 [inlined]
[6] anonymous at ./<missing>:?
[7] include_from_node1 at ./loading.jl:569
[8] include at ./sysimg.jl:14
[9] macro expansion at test/testdefs.jl:18 [inlined]
[10] macro expansion at ./test.jl:860 [inlined]
[11] macro expansion at ./util.jl:378 [inlined]
[12] macro expansion at test/testdefs.jl:17 [inlined]
[13] anonymous at ./<missing>:?
--- a/test/repl.jl
+++ b/test/repl.jl
@@ -126,7 +126,7 @@
# issues #22176 & #20482
# TODO: figure out how to test this on Windows
- is_windows() || let tmp = tempname()
+ true || let tmp = tempname()
try
write(stdin_write, ";")
readuntil(stdout_read, "shell> ")
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment