Skip to content
Snippets Groups Projects
Commit 2a1973f2 authored by alice's avatar alice
Browse files

main/opus: fix arm32 build

parent 35fa1890
No related branches found
No related tags found
No related merge requests found
......@@ -9,7 +9,9 @@ arch="all"
license="BSD-3-Clause"
makedepends="meson"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/xiph/opus/releases/download/v$pkgver/opus-$pkgver.tar.gz"
source="https://github.com/xiph/opus/releases/download/v$pkgver/opus-$pkgver.tar.gz
arm32.patch
"
# secfixes:
# 0:
......@@ -37,4 +39,5 @@ package() {
sha512sums="
1ecd39e0add24de12823bf7c936bb67441228721e2cdae0edbfcf3cee0894bcc6edf2a1d0ca5cdfdad1565803bf39cc4c985ad32710c2a9582f850adeb5ca631 opus-1.4.tar.gz
4218a3bc31efb91aa6b9cb2ac5928e63c34fd3b5aac61c68fa13b5a5fee00f902a1a03c61735d0610b0ded8f5b5e789494ea24165383bd4501d6a16e422e8eb6 arm32.patch
"
Patch-Source: https://github.com/xiph/opus/pull/267
--
From d94583359bcf8f1b52cc93b7ca6ced9664fb2a7e Mon Sep 17 00:00:00 2001
From: Vilius <orion1vi@protonmail.com>
Date: Sun, 27 Nov 2022 03:13:09 +0200
Subject: [PATCH] Meson: Fix unknown variable have_arm_intrinsics_or_asm
---
silk/meson.build | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/silk/meson.build b/silk/meson.build
index 917048b2d..a3e3f9eb3 100644
--- a/silk/meson.build
+++ b/silk/meson.build
@@ -25,6 +25,11 @@ if host_cpu_family in ['x86', 'x86_64'] and opus_conf.has('OPUS_HAVE_RTCD')
silk_sources += sources['SILK_SOURCES_X86_RTCD']
endif
+have_arm_intrinsics_or_asm = have_arm_ne10
+if (intrinsics_support.length() + asm_optimization.length() + inline_optimization.length()) > 0
+ have_arm_intrinsics_or_asm = true
+endif
+
if host_cpu_family in ['arm', 'aarch64'] and have_arm_intrinsics_or_asm
if opus_conf.has('OPUS_HAVE_RTCD')
silk_sources += sources['SILK_SOURCES_ARM_RTCD']
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment