Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
2774c7c8
Verified
Commit
2774c7c8
authored
2 years ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
community/dotnet6-build: use pigz for extraction
parent
578d173c
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!39304
[3.16] main/expat: security upgrade to 2.4.9
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
community/dotnet6-build/APKBUILD
+36
-11
36 additions, 11 deletions
community/dotnet6-build/APKBUILD
with
36 additions
and
11 deletions
community/dotnet6-build/APKBUILD
+
36
−
11
View file @
2774c7c8
...
...
@@ -104,7 +104,7 @@ checkdepends="
strace
util-linux-misc
which
"
"
makedepends
=
"
bash
clang
...
...
@@ -125,14 +125,14 @@ makedepends="
libxml2-dev
libxml2-utils
linux-headers
lldb
lldb-dev
lld
lld-dev
lldb-dev
llvm-dev
lttng-ust-dev
nodejs
openssl-dev
pigz
tar
zlib-dev
"
subpackages
=
"
...
...
@@ -358,7 +358,10 @@ check() {
export
DOTNET_ROOT
=
"
$_checkdir
/release"
if
[
!
-d
"
$DOTNET_ROOT
"
]
;
then
mkdir
-p
"
$DOTNET_ROOT
"
tar
-xzf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
-C
"
$DOTNET_ROOT
"
--no-same-owner
tar
--use-compress-program
=
"pigz"
\
-xf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
\
-C
"
$DOTNET_ROOT
"
\
--no-same-owner
fi
export
PATH
=
"
$DOTNET_ROOT
:
$PATH
"
# some files either should or should not have executable bits
...
...
@@ -399,7 +402,10 @@ package() {
"
$pkgdir
"
/usr/share/man/man1/dotnet
# unpack build artifacts to bootstrap
tar
-xzf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
-C
"
$pkgdir
"
/
$_libdir
/dotnet/bootstrap/
$pkgver
/
--no-same-owner
tar
--use-compress-program
=
"pigz"
\
-xf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
\
-C
"
$pkgdir
"
/
$_libdir
/dotnet/bootstrap/
$pkgver
/
\
--no-same-owner
# assemble docs
find
"
$builddir
"
-iname
'dotnet*.1'
-type
f
-exec
cp
'{}'
"
$pkgdir
"
/usr/share/man/man1/dotnet/.
\;
...
...
@@ -426,7 +432,11 @@ sdk() {
install
-dm
755
"
$subpkgdir
"
/
$_libdir
/dotnet
# sdk
tar
-xzf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
-C
"
$subpkgdir
"
/
$_libdir
/dotnet/
--no-same-owner
./sdk ./sdk-manifests
tar
--use-compress-program
=
"pigz"
\
-xf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
\
-C
"
$subpkgdir
"
/
$_libdir
/dotnet/
\
--no-same-owner
\
./sdk ./sdk-manifests
# some files either should or should not have executable bits
_fix_executable
"
$subpkgdir
"
...
...
@@ -442,7 +452,11 @@ netstandard_targeting_pack() {
provides
=
"netstandard-targeting-pack-2.1=
$pkgver
-r
$pkgrel
"
install
-dm
755
"
$subpkgdir
"
/
$_libdir
/dotnet/packs
tar
-xzf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
-C
"
$subpkgdir
"
/
$_libdir
/dotnet/
--no-same-owner
./packs/NETStandard.Library.Ref
tar
--use-compress-program
=
"pigz"
\
-xf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
\
-C
"
$subpkgdir
"
/
$_libdir
/dotnet/
\
--no-same-owner
\
./packs/NETStandard.Library.Ref
# some files either should or should not have executable bits
_fix_executable
"
$subpkgdir
"
...
...
@@ -454,7 +468,11 @@ templates() {
provides
=
"dotnet-templates-
$_pkgver_macro
=
$pkgver
-r
$pkgrel
"
install
-dm
755
"
$subpkgdir
"
/
$_libdir
/dotnet
tar
-xzf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
-C
"
$subpkgdir
"
/
$_libdir
/dotnet/
--no-same-owner
./templates
tar
--use-compress-program
=
"pigz"
\
-xf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
\
-C
"
$subpkgdir
"
/
$_libdir
/dotnet/
\
--no-same-owner
\
./templates
# some files either should or should not have executable bits
_fix_executable
"
$subpkgdir
"
...
...
@@ -476,7 +494,10 @@ artifacts() {
"
$subpkgdir
"
/usr/share/licenses
# extract artifacts to artifacts dir for use by future dotnet builds
tar
-xzf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/Private.SourceBuilt.Artifacts.
*
.tar.gz
-C
"
$subpkgdir
"
/
$_libdir
/dotnet/artifacts/
$pkgver
/
--no-same-owner
\
tar
--use-compress-program
=
"pigz"
\
-xf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/Private.SourceBuilt.Artifacts.
*
.tar.gz
\
-C
"
$subpkgdir
"
/
$_libdir
/dotnet/artifacts/
$pkgver
/
\
--no-same-owner
\
--exclude
'*Intermediate*'
}
...
...
@@ -510,7 +531,11 @@ doc() {
# licenses
install
-dm
755
"
$subpkgdir
"
/usr/share/licenses/dotnet
tar
-xzf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
-C
"
$subpkgdir
"
/usr/share/licenses/dotnet/
--no-same-owner
./LICENSE.txt ./ThirdPartyNotices.txt
tar
--use-compress-program
=
"pigz"
\
-xf
"
$builddir
"
/artifacts/
$_dotnet_arch
/Release/dotnet-sdk-
$_pkgver_macro
*
.tar.gz
\
-C
"
$subpkgdir
"
/usr/share/licenses/dotnet/
\
--no-same-owner
\
./LICENSE.txt ./ThirdPartyNotices.txt
}
sha512sums
=
"
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment