Skip to content
Snippets Groups Projects
Commit 26869740 authored by omni's avatar omni
Browse files

testing/rset: upgrade to 3.0

parent 93a764d7
No related branches found
No related tags found
1 merge request!63883testing/rset: upgrade to 3.0 & move to community
# Maintainer: omni <omni+alpine@hack.org> # Maintainer: omni <omni+alpine@hack.org>
pkgname=rset pkgname=rset
pkgver=2.9 pkgver=3.0
pkgrel=0 pkgrel=0
pkgdesc="Configure systems using any scripting language" pkgdesc="Configure systems using any scripting language"
url="https://scriptedconfiguration.org/" url="https://scriptedconfiguration.org/"
license="ISC" license="ISC"
arch="all" arch="all"
checkdepends="ruby-bundler" checkdepends="curl ruby-bundler"
subpackages="$pkgname-doc" subpackages="$pkgname-doc"
source="https://scriptedconfiguration.org/code/rset-$pkgver.tar.gz" source="https://scriptedconfiguration.org/code/rset-$pkgver.tar.gz
tests_Makefile.patch
"
build() { build() {
./configure ./configure
...@@ -26,5 +28,6 @@ package() { ...@@ -26,5 +28,6 @@ package() {
} }
sha512sums=" sha512sums="
f0e0958dc249bc755209e8c90bd5471b2b5e1f8c58723601d74961004eefc2c6734fa4b8678c8ec97e7c9e9ea06f500374e3cb8acfad120696b5d85efe57c4e3 rset-2.9.tar.gz 54b031c64ceddd7ee8992be6bbdb0d5299f668789978a1267a30b082629f74f0609cf37d58b8b13ed83df55c7fa117aae55e124b0684fbc3540784718ae753ce rset-3.0.tar.gz
7c2ea008aa3bb0a6259d4fd81ecdcf6fa21eeaee949fcff5d1e89f3a6e13884432d7274ca2e86a70673e07c439d57f6b4c085078a94421a0f039cdd672f7b6a8 tests_Makefile.patch
" "
make -C tests
make[1]: Entering directory '/home/user/tmp/rset-3.0/tests'
ld -r ../compat.o ../rutils.o ../input.o ../execute.o -o rset.o -Wl,--as-needed,-O1,--sort-common
ld: unrecognized option '-Wl,--as-needed,-O1,--sort-common'
ld: use the --help option for usage information
make[1]: *** [Makefile.bsd:18: rset.o] Error 1
make[1]: Leaving directory '/home/user/tmp/rset-3.0/tests'
make: *** [Makefile.bsd:78: test] Error 2
--- a/tests/Makefile.bsd
+++ b/tests/Makefile.bsd
@@ -15,7 +15,7 @@ RSET_LIBS = ../compat.o ../rutils.o ../i
all: rset.o test
rset.o: ${RSET_LIBS}
- ${LD} -r ${RSET_LIBS} -o $@ ${LDFLAGS}
+ ${LD} -r ${RSET_LIBS} -o $@
.c: rset.o ${RSET_LIBS}
${CC} -I.. ${CFLAGS} ${CPPFLAGS} $< rset.o -o $@ ${LDFLAGS}
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment