Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
25756a73
Commit
25756a73
authored
2 years ago
by
alice
Committed by
alice
2 years ago
Browse files
Options
Downloads
Patches
Plain Diff
main/curl: upgrade to 7.85.0
parent
b05f3ec8
No related branches found
No related tags found
2 merge requests
!39304
[3.16] main/expat: security upgrade to 2.4.9
,
!38437
main/curl: upgrade to 7.85.0
Pipeline
#134621
passed
2 years ago
Stage: verify
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/curl/APKBUILD
+5
-5
5 additions, 5 deletions
main/curl/APKBUILD
main/curl/easy_lock.patch
+0
-53
0 additions, 53 deletions
main/curl/easy_lock.patch
with
5 additions
and
58 deletions
main/curl/APKBUILD
+
5
−
5
View file @
25756a73
...
...
@@ -8,8 +8,8 @@
# this aport from arch=all WILL be reverted.
pkgname
=
curl
pkgver
=
7.8
4
.0
pkgrel
=
2
pkgver
=
7.8
5
.0
pkgrel
=
0
pkgdesc
=
"URL retrival utility and library"
url
=
"https://curl.se/"
arch
=
"all"
...
...
@@ -23,12 +23,13 @@ subpackages="$pkgname-dbg $pkgname-static $pkgname-doc $pkgname-dev libcurl"
[
-z
"
$BOOTSTRAP
"
]
&&
subpackages
=
"
$subpackages
$pkgname
-zsh-completion
$pkgname
-fish-completion"
source
=
"
https://curl.se/download/curl-
$pkgver
.tar.xz
easy_lock.patch
"
options
=
"net"
# Required for running tests
[
-n
"
$BOOTSTRAP
"
]
&&
options
=
"
$options
!check"
# remove python3 dependency
# secfixes:
# 7.85.0-r0:
# - CVE-2022-35252
# 7.84.0-r0:
# - CVE-2022-32205
# - CVE-2022-32206
...
...
@@ -196,6 +197,5 @@ static() {
}
sha512sums
=
"
86231866a35593a1637fbc0c6af3b6761bdfd99fb35580cc52970c36f19604f93dce59fea67a1d5bb4b455f719307599c7916c77d14f2b661f6bf7fb1ca716ce curl-7.84.0.tar.xz
f0c9e4744e62818f20634b7fa15b1ccd700b49259a99f151f6dc1067adac83ebb34a9bdd75adb1d8889d23a5d61c86dbfeb2ebad031cd4951a509c6bab9e0986 easy_lock.patch
b57cc31649a4f47cc4b482f56a85c86c8e8aaeaf01bc1b51b065fdb9145a9092bc52535e52a85a66432eb163605b2edbf5bc5c33ea6e40e50f26a69ad1365cbd curl-7.85.0.tar.xz
"
This diff is collapsed.
Click to expand it.
main/curl/easy_lock.patch
deleted
100644 → 0
+
0
−
53
View file @
b05f3ec8
From 3f6beb669e4edc170e167aa6cca3b4a6ec4501e9 Mon Sep 17 00:00:00 2001
From: Daniel Stenberg <daniel@haxx.se>
Date: Mon, 27 Jun 2022 08:46:21 +0200
Subject: [PATCH] easy_lock.h: include sched.h if available to fix build
Patched-by: Harry Sintonen
---
lib/easy_lock.h | 3 +++
1 file changed, 3 insertions(+)
diff --git a/lib/easy_lock.h b/lib/easy_lock.h
index 819f50ce815b8..1f54289ceb2d3 100644
--- a/lib/easy_lock.h
+++ b/lib/easy_lock.h
@@ -36,6 +36,9 @@
#elif defined (HAVE_ATOMIC)
#include <stdatomic.h>
+#if defined(HAVE_SCHED_YIELD)
+#include <sched.h>
+#endif
#define curl_simple_lock atomic_bool
#define CURL_SIMPLE_LOCK_INIT false
From 897d72b6c749545ee3d07052f9d1c69fd80b9dab Mon Sep 17 00:00:00 2001
From: Daniel Stenberg <daniel@haxx.se>
Date: Tue, 28 Jun 2022 09:00:25 +0200
Subject: [PATCH] easy_lock: switch to using atomic_int instead of bool
To work with more compilers without requiring separate libs to
link. Like with gcc-12 for RISC-V on Linux.
Reported-by: Adam Sampson
Fixes #9055
---
lib/easy_lock.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/easy_lock.h b/lib/easy_lock.h
index 07c85c5ffdd19..9c11bc50c5f20 100644
--- a/lib/easy_lock.h
+++ b/lib/easy_lock.h
@@ -40,8 +40,8 @@
#include <sched.h>
#endif
-#define curl_simple_lock atomic_bool
-#define CURL_SIMPLE_LOCK_INIT false
+#define curl_simple_lock atomic_int
+#define CURL_SIMPLE_LOCK_INIT 0
static inline void curl_simple_lock_lock(curl_simple_lock *lock)
{
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment