Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
2360e9d5
Commit
2360e9d5
authored
1 year ago
by
Patrycja Rosa
Committed by
alice
1 year ago
Browse files
Options
Downloads
Patches
Plain Diff
community/py3-trio: fix build
parent
a449b413
No related branches found
No related tags found
1 merge request
!46251
community/py3-t*: split -pyc
Pipeline
#161105
skipped
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/py3-trio/APKBUILD
+4
-1
4 additions, 1 deletion
community/py3-trio/APKBUILD
community/py3-trio/fix-musl-getaddrinfo.patch
+13
-0
13 additions, 0 deletions
community/py3-trio/fix-musl-getaddrinfo.patch
with
17 additions
and
1 deletion
community/py3-trio/APKBUILD
+
4
−
1
View file @
2360e9d5
...
@@ -25,7 +25,9 @@ checkdepends="
...
@@ -25,7 +25,9 @@ checkdepends="
py3-trustme
py3-trustme
"
"
subpackages
=
"
$pkgname
-pyc"
subpackages
=
"
$pkgname
-pyc"
source
=
"https://pypi.python.org/packages/source/t/trio/trio-
$pkgver
.tar.gz"
source
=
"https://pypi.python.org/packages/source/t/trio/trio-
$pkgver
.tar.gz
fix-musl-getaddrinfo.patch
"
builddir
=
"
$srcdir
/trio-
$pkgver
"
builddir
=
"
$srcdir
/trio-
$pkgver
"
case
"
$CARCH
"
in
case
"
$CARCH
"
in
...
@@ -46,4 +48,5 @@ package() {
...
@@ -46,4 +48,5 @@ package() {
sha512sums
=
"
sha512sums
=
"
146b18886c9a1483c35c2469017201c4ce5e74bcd1be670150ab9ec7c4ad51dd416ca201f911cf18a27391280a00580718a05b17b6470a646c477e4c626c8da4 trio-0.21.0.tar.gz
146b18886c9a1483c35c2469017201c4ce5e74bcd1be670150ab9ec7c4ad51dd416ca201f911cf18a27391280a00580718a05b17b6470a646c477e4c626c8da4 trio-0.21.0.tar.gz
a888e81ac513564e66e80143b615f608313d61ff7131b9afb0f698deb56761c91373059a1c87ecad0e758952912302af8937087a30dbda2c93f94860f3ff34e2 fix-musl-getaddrinfo.patch
"
"
This diff is collapsed.
Click to expand it.
community/py3-trio/fix-musl-getaddrinfo.patch
0 → 100644
+
13
−
0
View file @
2360e9d5
diff --git a/trio/tests/test_socket.py b/trio/tests/test_socket.py
index d891041..3f11189 100644
--- a/trio/tests/test_socket.py
+++ b/trio/tests/test_socket.py
@@ -548,6 +548,8 @@
async def test_SocketType_resolve(socket_type, addrs):
# Linux
if hasattr(tsocket, "EAI_ADDRFAMILY"):
expected_errnos.add(tsocket.EAI_ADDRFAMILY)
+ # Linux+musl
+ expected_errnos.add(tsocket.EAI_NODATA)
assert excinfo.value.errno in expected_errnos
# A family where we know nothing about the addresses, so should just
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment