Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
228aa049
Commit
228aa049
authored
3 years ago
by
Bart Ribbers
Browse files
Options
Downloads
Patches
Plain Diff
community/sddm: fix build failure
parent
2f7b6c88
No related branches found
No related tags found
1 merge request
!21658
community/sddm: fix build failure
Pipeline
#82529
canceled
3 years ago
Stage: lint
Stage: build
Changes
3
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
community/sddm/0001-pam-path-fix.patch
+0
-0
0 additions, 0 deletions
community/sddm/0001-pam-path-fix.patch
community/sddm/0002-sddm-fix-build.patch
+15
-0
15 additions, 0 deletions
community/sddm/0002-sddm-fix-build.patch
community/sddm/APKBUILD
+9
-5
9 additions, 5 deletions
community/sddm/APKBUILD
with
24 additions
and
5 deletions
community/sddm/pam-path-fix.patch
→
community/sddm/
0001-
pam-path-fix.patch
+
0
−
0
View file @
228aa049
File moved
This diff is collapsed.
Click to expand it.
community/sddm/0002-sddm-fix-build.patch
0 → 100644
+
15
−
0
View file @
228aa049
Fixes a build issue with the latest Qt 5.15 patches
diff --git a/src/daemon/XorgDisplayServer.cpp b/src/daemon/XorgDisplayServer.cpp
index 5f93a1b..d5f29a9 100644
--- a/src/daemon/XorgDisplayServer.cpp
+++ b/src/daemon/XorgDisplayServer.cpp
@@ -65,7 +65,7 @@
namespace SDDM {
// create a random hexadecimal number
const char *digits = "0123456789abcdef";
for (int i = 0; i < 32; ++i)
- m_cookie[i] = digits[dis(gen)];
+ m_cookie[i] = QLatin1Char(digits[dis(gen)]);
}
XorgDisplayServer::~XorgDisplayServer() {
This diff is collapsed.
Click to expand it.
community/sddm/APKBUILD
+
9
−
5
View file @
228aa049
...
...
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname
=
sddm
pkgver
=
0.19.0
pkgrel
=
1
pkgrel
=
2
pkgdesc
=
"Simple Desktop Display Manager"
url
=
"https://github.com/sddm/sddm/"
arch
=
"all !armhf !s390x !mips64"
# armhf blocked by qt5-qtdeclarative, rest: polkit
...
...
@@ -32,7 +32,8 @@ langdir="/usr/share/sddm/translations"
pkgusers
=
"sddm"
pkggroups
=
"sddm"
source
=
"https://github.com/sddm/sddm/archive/v
$pkgver
/sddm-v
$pkgver
.tar.gz
pam-path-fix.patch
0001-pam-path-fix.patch
0002-sddm-fix-build.patch
sddm.initd
"
...
...
@@ -65,6 +66,9 @@ package() {
install
-Dm755
"
$srcdir
"
/sddm.initd
"
$pkgdir
"
/etc/init.d/sddm
}
sha512sums
=
"f4de3d2da844caa8c5639ec39d4f41305d4fcad9ca29fe381c2c1d4b1bba0e54d47b8644e2c72d41fe9d11f3792959c3dd14f76d9ebc0de2b8ab7675c3e9acf7 sddm-v0.19.0.tar.gz
f0b4eb7ef0581701157f9decc637629156f36f6711b9a4bae517f94d7a1df614c81bbd891c918f07ac50e2a3d1519c43ccb9eefd80282c95dd79eca0e8d90904 pam-path-fix.patch
8762f9f1ce4922ef1e5df9e95c403a54363faad22b5703bbb0c64998887cfc1bd31178f489208648155f032bc12aa839d8c0ce9f5c57766ffa1df75531f0ac6f sddm.initd"
sha512sums
=
"
f4de3d2da844caa8c5639ec39d4f41305d4fcad9ca29fe381c2c1d4b1bba0e54d47b8644e2c72d41fe9d11f3792959c3dd14f76d9ebc0de2b8ab7675c3e9acf7 sddm-v0.19.0.tar.gz
f0b4eb7ef0581701157f9decc637629156f36f6711b9a4bae517f94d7a1df614c81bbd891c918f07ac50e2a3d1519c43ccb9eefd80282c95dd79eca0e8d90904 0001-pam-path-fix.patch
d2d4a6df0a329f37776e3efe3359e730c20ee5da3180b23f9b728afe924d9146f50f3377b9bfa2d7439e09640c33ecefda75707fda74e91812f97ec6358343ab 0002-sddm-fix-build.patch
8762f9f1ce4922ef1e5df9e95c403a54363faad22b5703bbb0c64998887cfc1bd31178f489208648155f032bc12aa839d8c0ce9f5c57766ffa1df75531f0ac6f sddm.initd
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment