Skip to content
Snippets Groups Projects
Commit 219f5b54 authored by Jakub Jirutka's avatar Jakub Jirutka :flag_ua:
Browse files

testing/ttfautohint: new aport

parent 1bb7c546
No related branches found
No related tags found
1 merge request!65487testing/ttfautohint: new aport
Pipeline #232250 skipped
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ttfautohint
pkgver=1.8.4
pkgrel=0
pkgdesc="Automated hinting utility for TrueType fonts"
url="https://freetype.org/ttfautohint/"
arch="all"
license="FTL OR GPL-2.0-only"
makedepends="
autoconf
automake
freetype-dev
harfbuzz-dev
libtool
qt5-qtbase-dev
"
subpackages="
$pkgname-dev
$pkgname-gui
$pkgname-libs
$pkgname-doc
"
source="https://download.savannah.gnu.org/releases/freetype/ttfautohint-$pkgver.tar.gz
musl-compat.patch
"
options="!check" # no tests provided
prepare() {
default_prepare
echo "$pkgver" > VERSION
sed -i \
-e '/dist_man_MANS/d' \
-e 's/manpages/dist_man_MANS/' \
frontend/local.mk
autoreconf -fiv
}
build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
--without-doc \
--disable-silent-rules
make
}
package() {
make DESTDIR="$pkgdir" install
}
gui() {
pkgdesc="$pkgdesc (Qt GUI)"
amove usr/bin/ttfautohintGUI
}
sha512sums="
983517c360f8e65ccbf17f28f045f1c0a45078707f2e30f465a7b6df4014f0ec212780ea2703bc16be1a3c6ede70f71ea3051c067fbfd06eff40ae3b20840eec ttfautohint-1.8.4.tar.gz
6d6443f45130681a1cfe506ddf78a050de5d787c91fff8830bea41c20037d23c51839b73b39fb3209a11852aad595937ea7783b95cca7e18829b15f89da2f460 musl-compat.patch
"
Patch-Source: https://github.com/void-linux/void-packages/blob/635e02124f328366b150e94e4335427189722226/srcpkgs/ttfautohint/patches/musl_bool.patch
--- a/lib/llrb.h 2018-01-13 08:59:09.826617752 -0800
+++ b/lib/llrb.h 2018-01-13 09:19:04.165564680 -0800
@@ -52,6 +52,11 @@
#ifndef LLRB_H
#define LLRB_H
+#ifndef _Bool
+#include <stdbool.h>
+#define _Bool bool
+#endif
+
#define LLRB_VENDOR "william@25thandClement.com"
#define LLRB_VERSION 0x20130925
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment