Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
219024e1
Commit
219024e1
authored
4 years ago
by
Bart Ribbers
Committed by
Leo
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/smooth: upgrade to 0.9.6
parent
0ef49dc9
No related branches found
No related tags found
1 merge request
!14000
community/freac: upgrade to 1.1.3
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/smooth/APKBUILD
+14
-4
14 additions, 4 deletions
community/smooth/APKBUILD
community/smooth/fix-drawing-issue-on-kde.patch
+38
-0
38 additions, 0 deletions
community/smooth/fix-drawing-issue-on-kde.patch
with
52 additions
and
4 deletions
community/smooth/APKBUILD
+
14
−
4
View file @
219024e1
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname
=
smooth
pkgver
=
0.9.
5
pkgver
=
0.9.
6
pkgrel
=
0
arch
=
"all"
url
=
"https://github.com/enzo1982/smooth"
pkgdesc
=
"The smooth Class Library"
license
=
"Artistic-2.0"
makedepends
=
"fribidi-dev gtk+3.0-dev libx11-dev libjpeg-turbo-dev curl-dev libxml2-dev"
source
=
"https://github.com/enzo1982/smooth/archive/v
$pkgver
/smooth-v
$pkgver
.tar.gz"
makedepends
=
"
curl-dev
fribidi-dev
gtk+3.0-dev
libjpeg-turbo-dev
libx11-dev
libxml2-dev
"
source
=
"https://github.com/enzo1982/smooth/archive/v
$pkgver
/smooth-v
$pkgver
.tar.gz
fix-drawing-issue-on-kde.patch
"
subpackages
=
"
$pkgname
-dev"
options
=
"!check"
# No tests
...
...
@@ -26,4 +35,5 @@ package() {
DESTDIR
=
"
$pkgdir
"
make
install
}
sha512sums
=
"7df1848fa6ea13455600ca8089962fb219732bd6ee12c5f8a10fc82c5ffaf5ca3f9ff00cb48c052d4e67921919fb871c472cc8a6bd04930df4695203246a2411 smooth-v0.9.5.tar.gz"
sha512sums
=
"ee4ab539c05ff68a01329aecb50aabdbc597eda954e310840ef5d50c1ea735fda4f027adb2ba047f9a7e699dce1ff868e2689261e941708eab3a0a4cf72945a6 smooth-v0.9.6.tar.gz
a5be6b2db828bde83dbb26462e5fb483ed336bfd31b965058d48e3dd864e76c33369e6df3b6a7f7020983a55e34b20a342907b6dff201cb0e7f654779f942a96 fix-drawing-issue-on-kde.patch"
This diff is collapsed.
Click to expand it.
community/smooth/fix-drawing-issue-on-kde.patch
0 → 100644
+
38
−
0
View file @
219024e1
From 0db8f929b935650698d3bcb09a52cc30e4abbb2e Mon Sep 17 00:00:00 2001
From: Robert Kausch <robert.kausch@freac.org>
Date: Tue, 13 Oct 2020 20:26:48 +0200
Subject: [PATCH] Fix drawing issues on KDE systems.
---
ChangeLog | 4 ++++
classes/gui/window/window.cpp | 3 ++-
2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/ChangeLog b/ChangeLog
index ec5724e3..1ce4786a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,9 @@
ChangeLog for smooth
+dd.mm.20 hh:mm - smooth alpha 0.9.7
+
+- window.cpp - fixed drawing issues on KDE systems
+
10.10.20 18:20 - smooth alpha 0.9.6
- surfacegdi.cpp - fixed too high DPI values being reported
diff --git a/classes/gui/window/window.cpp b/classes/gui/window/window.cpp
index b5523160..22a30836 100755
--- a/classes/gui/window/window.cpp
+++ b/classes/gui/window/window.cpp
@@ -578,7 +578,8 @@
S::Int S::GUI::Window::Process(Int message, Int wParam, Int lParam)
{
Bool resized = (updateRect == Rect(Point(-1, -1), Size(0, 0)));
- updateRect = backend->GetUpdateRect();
+ if (resized) updateRect = Rect(Point(0, 0), GetRealSize());
+ else updateRect = backend->GetUpdateRect();
Paint(resized ? SP_PAINT : SP_UPDATE);
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment