Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
21850cfc
Commit
21850cfc
authored
1 year ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
community/enigma: fix build
parent
d48a434e
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/enigma/APKBUILD
+5
-2
5 additions, 2 deletions
community/enigma/APKBUILD
community/enigma/format-security.patch
+70
-0
70 additions, 0 deletions
community/enigma/format-security.patch
with
75 additions
and
2 deletions
community/enigma/APKBUILD
+
5
−
2
View file @
21850cfc
# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
pkgname
=
enigma
pkgver
=
1.30
pkgrel
=
3
pkgrel
=
4
pkgdesc
=
"Puzzle game inspired by Oxyd on the Atari ST and Rock'n'Roll on the Amiga"
url
=
"http://www.nongnu.org/enigma/"
arch
=
"all"
...
...
@@ -19,7 +19,9 @@ makedepends="
xerces-c-dev
"
subpackages
=
"
$pkgname
-doc"
source
=
"https://github.com/Enigma-Game/Enigma/releases/download/
$pkgver
/Enigma-
$pkgver
-src.tar.gz"
source
=
"https://github.com/Enigma-Game/Enigma/releases/download/
$pkgver
/Enigma-
$pkgver
-src.tar.gz
format-security.patch
"
build
()
{
./configure
\
...
...
@@ -41,4 +43,5 @@ package() {
sha512sums
=
"
57c6d642538b7bce6a748e1e1bce641dcc1dcd627a4e2c4dfe5d1271bf9df624075914c04fc6cddc1b1118585e4f111d79c8c8a54a1a6b93a8bedfb1aa9f2ef6 Enigma-1.30-src.tar.gz
4631ba0a3057eaf3eaed334a5b7764c401f5b4505ce585270fd2b9a6e8eff23e69b8f224fbf2bf0f601c7f60e51b063dc4d3fc1abc9ed844ff9830cded1e4226 format-security.patch
"
This diff is collapsed.
Click to expand it.
community/enigma/format-security.patch
0 → 100644
+
70
−
0
View file @
21850cfc
diff --git a/src/lua.cc b/src/lua.cc
index fae9977..8f6c711 100644
--- a/src/lua.cc
+++ b/src/lua.cc
@@ -3894,14 +3894,14 @@
void CheckedDoFile (lua_State *L, GameFS * fs, std::string const& fname)
if (!fs->findFile(fname, completefn))
{
fprintf(stderr, _("Cannot find '%s'.\n"), fname.c_str());
- fprintf(stderr, _("Your installation may be incomplete or invalid.\n"));
+ fprintf(stderr, "%s", _("Your installation may be incomplete or invalid.\n"));
exit (1);
}
lua::Error status = lua::DoAbsoluteFile(L, completefn);
if (status != lua::NO_LUAERROR) {
fprintf(stderr, _("There was an error loading '%s'.\n"), completefn.c_str());
- fprintf(stderr, _("Your installation may be incomplete or invalid.\n"));
+ fprintf(stderr, "%s", _("Your installation may be incomplete or invalid.\n"));
fprintf(stderr, _("Error: '%s'\n"), lua::LastError(L).c_str());
exit (1);
}
diff --git a/src/main.cc b/src/main.cc
index 28a1a12..5e7c93c 100644
--- a/src/main.cc
+++ b/src/main.cc
@@ -352,7 +352,7 @@
void Application::init(int argc, char **argv)
// initialize preferences -- needs LUA, XML
if (!options::Load()) {
- fprintf(stderr, _("Error in configuration file.\n"));
+ fprintf(stderr, "%s", _("Error in configuration file.\n"));
fprintf(stderr, "%s\n", lua::LastError (lua::GlobalState()).c_str());
}
prefs = PreferenceManager::instance();
@@ -593,7 +593,7 @@
void Application::initSysDatapaths(const std::string &prefFilename)
if (!ecl::FolderExists(prefPath))
// may happen on Windows
if(!ecl::FolderCreate(prefPath)) {
- fprintf(stderr, _("Error: Home directory does not exist.\n"));
+ fprintf(stderr, "%s", _("Error: Home directory does not exist.\n"));
exit(1);
}
#ifdef MACOSX
@@ -616,7 +616,7 @@
void Application::initSysDatapaths(const std::string &prefFilename)
prefPath = winAppDataPath + ecl::PathSeparator + "." + prefFilename;
#endif
} else {
- fprintf(stderr, _("Error: Home directory does not exist.\n"));
+ fprintf(stderr, "%s", _("Error: Home directory does not exist.\n"));
exit(1);
}
}
@@ -635,7 +635,7 @@
void Application::initXerces() {
makeNewTranscoderFor(XMLRecognizer::UTF_8, initResult,
4096); // the block size is irrelevant for utf-8
if (initResult != XMLTransService::Ok) {
- fprintf(stderr, _("Error in XML initialization.\n"));
+ fprintf(stderr, "%s", _("Error in XML initialization.\n"));
exit(1);
}
@@ -684,7 +684,7 @@
void Application::initXerces() {
#endif
}
catch (...) {
- fprintf(stderr, _("Error in XML initialization.\n"));
+ fprintf(stderr, "%s", _("Error in XML initialization.\n"));
exit(1);
}
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment