Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
21572507
Commit
21572507
authored
1 month ago
by
Bart Ribbers
Browse files
Options
Downloads
Patches
Plain Diff
community/tellico: upgrade to 4.1.1
parent
3c280b08
No related branches found
No related tags found
1 merge request
!79787
community/tellico: upgrade to 4.1.1
Pipeline
#297993
canceled
1 month ago
Stage: verify
Pipeline: aports
#297994
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/tellico/0001-tellico-define-strdup.patch
+0
-95
0 additions, 95 deletions
community/tellico/0001-tellico-define-strdup.patch
community/tellico/APKBUILD
+3
-6
3 additions, 6 deletions
community/tellico/APKBUILD
with
3 additions
and
101 deletions
community/tellico/0001-tellico-define-strdup.patch
deleted
100644 → 0
+
0
−
95
View file @
3c280b08
diff --git a/src/3rdparty/btparse/btparse.h b/src/3rdparty/btparse/btparse.h
index 20680974..61865de8 100644
--- a/src/3rdparty/btparse/btparse.h
+++ b/src/3rdparty/btparse/btparse.h
@@ -21,6 +21,8 @@
#ifndef BTPARSE_H
#define BTPARSE_H
+#define _POSIX_C_SOURCE 200809L
+
#include <sys/types.h> /* probably supplies 'ushort' */
#include <stdio.h>
diff --git a/src/3rdparty/btparse/lex_auxiliary.c b/src/3rdparty/btparse/lex_auxiliary.c
index a433fc2b..6e277976 100644
--- a/src/3rdparty/btparse/lex_auxiliary.c
+++ b/src/3rdparty/btparse/lex_auxiliary.c
@@ -29,6 +29,9 @@
of the License, or (at your option) any later version.
-------------------------------------------------------------------------- */
+#define _POSIX_C_SOURCE 200809L
+#define _DEFAULT_SOURCE
+
#include "bt_debug.h"
#include <stdlib.h>
#include <string.h>
diff --git a/src/3rdparty/btparse/macros.c b/src/3rdparty/btparse/macros.c
index 066e14ce..0d2c1992 100644
--- a/src/3rdparty/btparse/macros.c
+++ b/src/3rdparty/btparse/macros.c
@@ -15,6 +15,9 @@
published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.
-------------------------------------------------------------------------- */
+
+#define _POSIX_C_SOURCE 200809L
+
/*#include "bt_config.h"*/
#include <stdlib.h>
#include <string.h>
diff --git a/src/3rdparty/btparse/modify.c b/src/3rdparty/btparse/modify.c
index 2d8d9c17..b28068e7 100644
--- a/src/3rdparty/btparse/modify.c
+++ b/src/3rdparty/btparse/modify.c
@@ -15,6 +15,9 @@
published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.
-------------------------------------------------------------------------- */
+
+#define _POSIX_C_SOURCE 200809L
+
/*#include "bt_config.h"*/
#include <stdlib.h>
#include <string.h>
diff --git a/src/3rdparty/btparse/names.c b/src/3rdparty/btparse/names.c
index e6227de8..b86956a2 100644
--- a/src/3rdparty/btparse/names.c
+++ b/src/3rdparty/btparse/names.c
@@ -18,6 +18,8 @@
of the License, or (at your option) any later version.
-------------------------------------------------------------------------- */
+#define _POSIX_C_SOURCE 200809L
+
/*#include "bt_config.h"*/
#include <assert.h>
#include <stdlib.h>
diff --git a/src/3rdparty/btparse/postprocess.c b/src/3rdparty/btparse/postprocess.c
index 7f7bfd4a..2c5349b6 100644
--- a/src/3rdparty/btparse/postprocess.c
+++ b/src/3rdparty/btparse/postprocess.c
@@ -15,6 +15,9 @@
published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.
-------------------------------------------------------------------------- */
+
+#define _POSIX_C_SOURCE 200809L
+
/*#include "bt_config.h"*/
#include <stdlib.h>
#include <string.h>
diff --git a/src/3rdparty/btparse/sym.c b/src/3rdparty/btparse/sym.c
index 85a79993..99ac577d 100644
--- a/src/3rdparty/btparse/sym.c
+++ b/src/3rdparty/btparse/sym.c
@@ -107,6 +107,8 @@
* during searching etc...
*/
+#define _DEFAULT_SOURCE
+
/*#include "bt_config.h"*/
#include <stdio.h>
#include <string.h>
This diff is collapsed.
Click to expand it.
community/tellico/APKBUILD
+
3
−
6
View file @
21572507
maintainer
=
"Bart Ribbers <bribbers@disroot.org>"
pkgname
=
tellico
pkgver
=
4.1
pkgver
=
4.1
.1
pkgrel
=
0
pkgdesc
=
"Collection management software, free and simple"
# armhf, ppc64le, s390x and riscv64 blocked by qt6-qtwebengine
...
...
@@ -43,9 +43,7 @@ makedepends="
taglib-dev
"
checkdepends
=
"xwayland-run"
source
=
"https://tellico-project.org/files/tellico-
$pkgver
.tar.xz
0001-tellico-define-strdup.patch
"
source
=
"https://tellico-project.org/files/tellico-
$pkgver
.tar.xz"
subpackages
=
"
$pkgname
-doc
$pkgname
-lang"
build
()
{
...
...
@@ -64,6 +62,5 @@ package() {
DESTDIR
=
"
$pkgdir
"
cmake
--install
build
}
sha512sums
=
"
fa72ddcfa9aaf5776bed47edcea4520d40275375abeafce5c936d5e5c18b1495efa7d041abc96cc3d02655c71403fd0889585aeb6c20bed3c9b28297ad467d66 tellico-4.1.tar.xz
0a8efadd382f75773d75c8800c8eb2ba6312291d62e8b9504d9e09188c6fdfec2d7b0e4674b62d406e7fdde43dd18aa5a63dc9dc919e4b61bba8c01776abfa9c 0001-tellico-define-strdup.patch
606428ee18a60b325f1b2e2896cb422ce2cf9f2838441ddb2a72983d3a454aae0d5129c5d3e26c4e487edf4025c56d180ed65ce52db23a152860f4e62fda5c28 tellico-4.1.1.tar.xz
"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment