Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
212b2955
Commit
212b2955
authored
4 years ago
by
whooo
Committed by
Andy Postnikov
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
testing/tpm2-tools: upgrade to 5.0
parent
1fa393f5
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!14975
testing/tpm2-tools: upgrade to 5.0
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
testing/tpm2-tools/APKBUILD
+7
-5
7 additions, 5 deletions
testing/tpm2-tools/APKBUILD
testing/tpm2-tools/argc-fix.patch
+35
-0
35 additions, 0 deletions
testing/tpm2-tools/argc-fix.patch
with
42 additions
and
5 deletions
testing/tpm2-tools/APKBUILD
+
7
−
5
View file @
212b2955
# Contributor: Alexander Sack <asac@pantacor.com>
# Maintainer: Alexander Sack <asac@pantacor.com>
pkgname
=
tpm2-tools
pkgver
=
4.3
.0
pkgrel
=
1
pkgver
=
5
.0
pkgrel
=
0
pkgdesc
=
"TPM2 Tools"
url
=
"https://github.com/tpm2-software/tpm2-tools/"
arch
=
"all"
...
...
@@ -11,7 +11,8 @@ makedepends="tpm2-tss-dev openssl-dev curl-dev util-linux-dev libtool
autoconf automake"
subpackages
=
"
$pkgname
-bash-completion"
source
=
"https://github.com/tpm2-software/tpm2-tools/releases/download/
$pkgver
/tpm2-tools-
$pkgver
.tar.gz
dont-generate-manpages-without-pandoc.patch"
dont-generate-manpages-without-pandoc.patch
argc-fix.patch"
options
=
"!check"
prepare
()
{
...
...
@@ -32,5 +33,6 @@ package() {
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"4e622bbc8642ba7fd93a7343900560fe3779cba03e363d16f391fc8929724a11913d238e3986de06982cbced27c3c2ca8c7e73d75796407b8646c101ccf393a8 tpm2-tools-4.3.0.tar.gz
2e0862c3c5d07cd40f655fa762a881a243fcf63c966f9867032057f7d7373fea94785929d8ef8bba8961bafa7d4549ebb3b90a09b15d6cfd8d3f08acfd488364 dont-generate-manpages-without-pandoc.patch"
sha512sums
=
"ea57a28a61e28b78cae7067ff58facd8754fafab7a2689fd93f8b3374073b6ac30301a75f8ff5c654800ab469ee6604d0b8a86c310631b9545b816ecaa05968e tpm2-tools-5.0.tar.gz
2e0862c3c5d07cd40f655fa762a881a243fcf63c966f9867032057f7d7373fea94785929d8ef8bba8961bafa7d4549ebb3b90a09b15d6cfd8d3f08acfd488364 dont-generate-manpages-without-pandoc.patch
068fadf650e76fd520135844368d68f883065d7eeeac3c2715f207d585cf9d71cd779c9fdd06c007f21e4ad81f2ffaf65ed953ed9c59151a539d5582ab742c1e argc-fix.patch"
This diff is collapsed.
Click to expand it.
testing/tpm2-tools/argc-fix.patch
0 → 100644
+
35
−
0
View file @
212b2955
just running tpm2 will segfault without this patch.
In upstream master branch, but not yet in a release, see https://github.com/tpm2-software/tpm2-tools/commit/fb1e0d98eca5279bf33304deedd9019b0130393a
Can probably be removed after 5.0.1 is released.
index e9aaa036..9fa583c6 100644
--- a/lib/tpm2_options.c
+++ b/lib/tpm2_options.c
@@ -300,7 +300,7 @@
tpm2_option_code tpm2_handle_options(int argc, char **argv,
if (argv[optind - 1]) {
if (!strcmp(argv[optind - 1], "--help=no-man") ||
!strcmp(argv[optind - 1], "-h=no-man") ||
- (argv[optind] && !strcmp(argv[optind], "no-man"))) {
+ (argc < optind && !strcmp(argv[optind], "no-man"))) {
manpager = false;
optind++;
/*
@@ -309,7 +309,7 @@
tpm2_option_code tpm2_handle_options(int argc, char **argv,
*/
} else if (!strcmp(argv[optind - 1], "--help=man") ||
!strcmp(argv[optind - 1], "-h=man") ||
- (argv[optind] && !strcmp(argv[optind], "man"))) {
+ (argc < optind && !strcmp(argv[optind], "man"))) {
manpager = true;
explicit_manpager = true;
optind++;
@@ -318,7 +318,7 @@
tpm2_option_code tpm2_handle_options(int argc, char **argv,
* argv[0] = "tool name"
* argv[1] = "--help" argv[2] = 0
*/
- if (!argv[optind] && argc == 2) {
+ if (optind >= argc && argc == 2) {
manpager = false;
} else {
/*
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment