Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
1dd28526
Commit
1dd28526
authored
5 years ago
by
Leo
Browse files
Options
Downloads
Patches
Plain Diff
main/yajl: switch to build type none
parent
2c075d0b
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
main/yajl/APKBUILD
+16
-27
16 additions, 27 deletions
main/yajl/APKBUILD
with
16 additions
and
27 deletions
main/yajl/APKBUILD
+
16
−
27
View file @
1dd28526
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname
=
yajl
pkgver
=
2.1.0
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Yet Another JSON Library (YAJL)"
url
=
"http://lloyd.github.com/yajl/"
arch
=
"all"
license
=
"BSD"
depends
=
""
license
=
"MIT"
makedepends
=
"cmake"
install
=
""
subpackages
=
"
$pkgname
-dev
$pkgname
-tools"
source
=
"https://dev.alpinelinux.org/archive/yajl/yajl-
$pkgver
.tar.gz"
_builddir
=
"
$srcdir
"
/yajl-
$pkgver
# How to create archive from git:
#
# abuild snapshot
...
...
@@ -29,37 +25,30 @@ snapshot() {
mkdir
-p
"
$srcdir
"
cd
"
${
SRCDEST
:-
$srcdir
}
"
if
!
[
-d
"
$_gitrepo
"
]
;
then
git clone
--bare
$_giturl
||
return
1
git clone
--bare
$_giturl
else
git
--git-dir
=
$_gitrepo
fetch
||
return
1
fi
git
--git-dir
=
$_gitrepo
fetch
fi
git
--git-dir
=
$_gitrepo
archive
--prefix
=
$pkgname
-
$pkgver
/
\
-o
"
$SRCDEST
"
/
$_tarball
$_gittag
||
return
1
git
--git-dir
=
$_gitrepo
archive
--prefix
=
$pkgname
-
$pkgver
/
\
-o
"
$SRCDEST
"
/
$_tarball
$_gittag
msg
"Uploading
$_tarball
"
scp
"
$SRCDEST
"
/
$_tarball
dev.alpinelinux.org:/archive/
$pkgname
/
}
prepare
()
{
local
i
cd
"
$_builddir
"
for
i
in
$source
;
do
case
$i
in
*
.patch
)
msg
$i
;
patch
-p1
-i
"
$srcdir
"
/
$i
||
return
1
;;
esac
done
scp
"
$SRCDEST
"
/
$_tarball
dev.alpinelinux.org:/archive/
$pkgname
/
}
build
()
{
cd
"
$_builddir
"
cmake
-DCMAKE_INSTALL_PREFIX
=
"/usr"
.
||
return
1
make
cmake
-B
build
.
\
-DCMAKE_BUILD_TYPE
=
None
\
-DCMAKE_INSTALL_LIBDIR
=
lib
\
-DCMAKE_INSTALL_PREFIX
=
/usr
make
-C
build
}
package
()
{
cd
"
$_builddir
"
make
install
DESTDIR
=
"
$pkgdir
"
||
return
1
make
install
-C
build
DESTDIR
=
"
$pkgdir
"
mkdir
-p
"
$pkgdir
"
/usr/lib
mv
"
$pkgdir
"
/usr/share/pkgconfig
"
$pkgdir
"
/usr/lib/
}
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment