Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
16e8ca6c
Commit
16e8ca6c
authored
4 years ago
by
Kevin Daudt
Browse files
Options
Downloads
Patches
Plain Diff
community/fzf: upgrade to 0.25.0
parent
2b135717
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!16410
community/fzf: upgrade to 0.25.0
Pipeline
#66734
passed
4 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
community/fzf/APKBUILD
+5
-3
5 additions, 3 deletions
community/fzf/APKBUILD
community/fzf/use-explicit-int-to-string-conversion.patch
+36
-0
36 additions, 0 deletions
community/fzf/use-explicit-int-to-string-conversion.patch
with
41 additions
and
3 deletions
community/fzf/APKBUILD
+
5
−
3
View file @
16e8ca6c
...
...
@@ -2,7 +2,7 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname
=
fzf
pkgver
=
0.2
4.4
pkgver
=
0.2
5.0
pkgrel
=
0
pkgdesc
=
"A command-line fuzzy finder"
url
=
"https://github.com/junegunn/fzf"
...
...
@@ -20,6 +20,7 @@ subpackages="
"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/junegunn/fzf/archive/
$pkgver
.tar.gz
find-buzybox-compat.patch
use-explicit-int-to-string-conversion.patch
"
export
GOPATH
=
"
$srcdir
"
...
...
@@ -99,5 +100,6 @@ cleanup_srcdir() {
default_cleanup_srcdir
}
sha512sums
=
"348cc000b4e28054bff56a37171ef4dd7ac22c7c292c19c3c0b95f3d30856b443887447604e1e38cfd71b421a22c1135a13cb40c78e5b34d477acaa3dcadb821 fzf-0.24.4.tar.gz
c59e7eb712f5072a2c66b79800f7674d1f9208b1ead4f654e57f8dcb673a45a751725a005c89759847f78c7ae7f246980b2c94e5fff5a3e8c2f6a364965e567e find-buzybox-compat.patch"
sha512sums
=
"73b65374334531ac81a64bb973cb976f4dab7c6458eb2705f323349223880294fa6238b0eeea3412ff121c5c1b70905b261ceb7994c2b00425b02c88286b36e3 fzf-0.25.0.tar.gz
c59e7eb712f5072a2c66b79800f7674d1f9208b1ead4f654e57f8dcb673a45a751725a005c89759847f78c7ae7f246980b2c94e5fff5a3e8c2f6a364965e567e find-buzybox-compat.patch
b0776a0e0f33328d68eb759719ea8cca9cb4c580c5f8ffe3f55763c8a2aa366563b1d7da11f5f817b7a73ca22aaf7167b68e4de55916461ac3383d822ab4aed5 use-explicit-int-to-string-conversion.patch"
This diff is collapsed.
Click to expand it.
community/fzf/use-explicit-int-to-string-conversion.patch
0 → 100644
+
36
−
0
View file @
16e8ca6c
From cab32ead2291fdbe5f5c284c71a693705533c700 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sat, 2 Jan 2021 23:25:43 -0500
Subject: [PATCH] Use more explicit int-to-string conversion.
This fixes the following errors with Go 1.15:
```
src/options.go:452:69: conversion from untyped int to string yields a string of one rune, not a string of digits (did you mean fmt.Sprint(x)?)
src/options.go:463:33: conversion from untyped int to string yields a string of one rune, not a string of digits (did you mean fmt.Sprint(x)?)
```
---
src/options.go | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/options.go b/src/options.go
index 12c09556..cee11ffc 100644
--- a/src/options.go
+++ b/src/options.go
@@ -449,7 +449,7 @@
func parseKeyChords(str string, message string) map[tui.Event]string {
errorExit(message)
}
- str = regexp.MustCompile("(?i)(alt-),").ReplaceAllString(str, "$1"+string(escapedComma))
+ str = regexp.MustCompile("(?i)(alt-),").ReplaceAllString(str, "$1"+string([]rune{escapedComma}))
tokens := strings.Split(str, ",")
if str == "," || strings.HasPrefix(str, ",,") || strings.HasSuffix(str, ",,") || strings.Contains(str, ",,,") {
tokens = append(tokens, ",")
@@ -460,7 +460,7 @@
func parseKeyChords(str string, message string) map[tui.Event]string {
if len(key) == 0 {
continue // ignore
}
- key = strings.ReplaceAll(key, string(escapedComma), ",")
+ key = strings.ReplaceAll(key, string([]rune{escapedComma}), ",")
lkey := strings.ToLower(key)
add := func(e tui.EventType) {
chords[e.AsEvent()] = key
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment