Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
1543b408
Commit
1543b408
authored
1 year ago
by
alice
Browse files
Options
Downloads
Patches
Plain Diff
main/llvm-runtimes: fix ppc64le patch for gcc13
parent
8fe6668d
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/llvm-runtimes/APKBUILD
+1
-1
1 addition, 1 deletion
main/llvm-runtimes/APKBUILD
main/llvm-runtimes/compiler-rt-ppc-fixes.patch
+2
-1
2 additions, 1 deletion
main/llvm-runtimes/compiler-rt-ppc-fixes.patch
with
3 additions
and
2 deletions
main/llvm-runtimes/APKBUILD
+
1
−
1
View file @
1543b408
...
@@ -202,7 +202,7 @@ sha512sums="
...
@@ -202,7 +202,7 @@ sha512sums="
860bcb999005f55bed25691304983d7bf707f8e3246000595b412b9e88f4a1614be0adb43bbff9c30f49b969373fa0becab02a56ac37915a5f83c52ca8ea3f95 llvm-project-16.0.4.src.tar.xz
860bcb999005f55bed25691304983d7bf707f8e3246000595b412b9e88f4a1614be0adb43bbff9c30f49b969373fa0becab02a56ac37915a5f83c52ca8ea3f95 llvm-project-16.0.4.src.tar.xz
5e7bbddbaea902e5ba5cd4db78bedbeef216f44fdd9b8f73efde6c09f40115c078649a109ffa61fefa0ee2f26655c038a48589ecac83068a47d60e9248c5dff1 armv6-arch.patch.noauto
5e7bbddbaea902e5ba5cd4db78bedbeef216f44fdd9b8f73efde6c09f40115c078649a109ffa61fefa0ee2f26655c038a48589ecac83068a47d60e9248c5dff1 armv6-arch.patch.noauto
7c2cbd095b863f735842aaa8f0daecbf0282200fc58f1394139cee30d53c4a738757e38cbf0ec734398ee827e8a47314592bd7dc9768ef5c3664db682680e5a1 compiler-rt-lsan-dtp-offset.patch
7c2cbd095b863f735842aaa8f0daecbf0282200fc58f1394139cee30d53c4a738757e38cbf0ec734398ee827e8a47314592bd7dc9768ef5c3664db682680e5a1 compiler-rt-lsan-dtp-offset.patch
c7b7deaedddc4b980b349c26751bdca102e19b3d2fb61fc47ede849d3994fd9b6bbcd631bc129f129f5b0a048e12ae04cce3a2d91bc5678aa9f782c37d170c93
compiler-rt-ppc-fixes.patch
aaef886f71c5499da18ff18937404ab641cbc3a540ee9e4eed7ae6895970863e6d01ed598f8b2f1512936f33d6dd122cd7a00545afaf710a8026c729a3af720c
compiler-rt-ppc-fixes.patch
448ad39865b1a86d69c80b6626500e16509834787944f0b402b3eb3b2d6d1c034073b4004b7e1eee6afdc21b553945e65943b79426105503012c4dfac1ee2e7b compiler-rt-sanitizer-supported-arch.patch
448ad39865b1a86d69c80b6626500e16509834787944f0b402b3eb3b2d6d1c034073b4004b7e1eee6afdc21b553945e65943b79426105503012c4dfac1ee2e7b compiler-rt-sanitizer-supported-arch.patch
b777d84f3dd397719805e3be656bd159b479ae8d7c0490c842eb7402b9badfcdf40c7fe80271117b0627866c4e56e9dc6818da8b29de112fa3aca694d484b94c compiler-rt-scudo-standalone.patch
b777d84f3dd397719805e3be656bd159b479ae8d7c0490c842eb7402b9badfcdf40c7fe80271117b0627866c4e56e9dc6818da8b29de112fa3aca694d484b94c compiler-rt-scudo-standalone.patch
e601d0657d61cf080c9a03fd0139f9cae85339ba7f997f61283c1ba3b9fb48479cca875db44b64ee8b48a7d61a18a70d7cd123500f72966770cf5312b1aca034 libunwind-link-libssp.patch
e601d0657d61cf080c9a03fd0139f9cae85339ba7f997f61283c1ba3b9fb48479cca875db44b64ee8b48a7d61a18a70d7cd123500f72966770cf5312b1aca034 libunwind-link-libssp.patch
...
...
This diff is collapsed.
Click to expand it.
main/llvm-runtimes/compiler-rt-ppc-fixes.patch
+
2
−
1
View file @
1543b408
...
@@ -65,12 +65,13 @@ index 7e872b5b4..9616a09d8 100644
...
@@ -65,12 +65,13 @@ index 7e872b5b4..9616a09d8 100644
#include <sys/platform/ppc.h>
#include <sys/platform/ppc.h>
#elif defined(__FreeBSD__)
#elif defined(__FreeBSD__)
#include <sys/types.h>
#include <sys/types.h>
@@ -27,6 +27,1
3
@@
uint64_t __ppc_get_timebase_freq (void)
@@ -27,6 +27,1
4
@@
uint64_t __ppc_get_timebase_freq (void)
sysctlbyname("kern.timecounter.tc.timebase.frequency", &tb_freq, &length, nullptr, 0);
sysctlbyname("kern.timecounter.tc.timebase.frequency", &tb_freq, &length, nullptr, 0);
return tb_freq;
return tb_freq;
}
}
+#else
+#else
+#include <cctype>
+#include <cctype>
+#include <cstdio>
+#include <cstring>
+#include <cstring>
+#include <cstdlib>
+#include <cstdlib>
+
+
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment