Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
051b9a82
Commit
051b9a82
authored
2 years ago
by
Hoang Nguyen
Committed by
alice
2 years ago
Browse files
Options
Downloads
Patches
Plain Diff
community/nptsec: upgrade to 1.2.2
parent
398aec61
No related branches found
No related tags found
1 merge request
!43087
[3.17] community/nptsec: upgrade to 1.2.2
Checking pipeline status
Changes
3
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
community/ntpsec/APKBUILD
+4
-6
4 additions, 6 deletions
community/ntpsec/APKBUILD
community/ntpsec/ntp.conf
+1
-1
1 addition, 1 deletion
community/ntpsec/ntp.conf
community/ntpsec/ntpsec-openssl.patch
+0
-102
0 additions, 102 deletions
community/ntpsec/ntpsec-openssl.patch
with
5 additions
and
109 deletions
community/ntpsec/APKBUILD
+
4
−
6
View file @
051b9a82
# Contributor: tcely <ntpsec+aports@tcely.33mail.com>
# Maintainer: Hoang Nguyen <folliekazetani@protonmail.com>
pkgname
=
ntpsec
pkgver
=
1.2.
1
pkgver
=
1.2.
2
_pkgver
=
${
pkgver
//./_
}
pkgrel
=
6
pkgrel
=
0
pkgdesc
=
"NTP reference implementation, refactored for security"
url
=
"https://www.ntpsec.org/"
arch
=
"all"
...
...
@@ -20,7 +20,6 @@ makedepends="
subpackages
=
"
$pkgname
-dev
$pkgname
-doc
$pkgname
-openrc"
source
=
"
https://github.com/ntpsec/ntpsec/archive/refs/tags/NTPsec_
$_pkgver
.tar.gz
ntpsec-openssl.patch
ntp.conf
ntpsec.confd
ntpsec.initd
...
...
@@ -71,9 +70,8 @@ package() {
}
sha512sums
=
"
6938504ee6153eb6fd7dab572f63ab133d8bff83580047396c1d783d2547660d5982e912e82c906abd406f4b539e9579e5177ae1c2e8c9ea813072b9af827c5d NTPsec_1_2_1.tar.gz
4bd5cf63313876030931f0d923f9a4899ff9bcd40f8137e4b2e3ea0c3d184074d413a7177320baba4d80b7ce6f87c9089d8169dcf9fb15c6aaee46a37cf5f948 ntpsec-openssl.patch
b929d540102dd5833d6a39d70d960270b17573b7a1ad7ae2bb64335d9272b73b9c6b1cc23d6232d13bcbfc6ec145986eaed46fdaa75a9493a6b907f5a3effeb1 ntp.conf
929f07e4183cf7f4c24c15f99391fb6d4d87eeb267ea767adbff0b58d44c419490c52174a01a5819f133e479602bb9343e4853c5a016ff41c04d3c6e76caa958 NTPsec_1_2_2.tar.gz
e8a72067151dac8cad29db40851343ee51c08dc9f35f71e137910bcf4b8269bafd72dfcb45b93e04d887dc426322fdc3bc250888f988879e006925855c644bd0 ntp.conf
615af8b9c713007ef0af5e6efc315a0ab1d3abbd8dc2b675d7eb631d6b98fcf3913fc89b1754361552de2bd0c0f782bca14588a4f35edda7fb44b27b59528f10 ntpsec.confd
b36bdba523e8696e38b170c931e731b3ffcd97129b297a5a55506073289f74f7f3458dd975d0ce0435c601fd7fd33ceecc3734e102cda954acc0d2ce235ad7ee ntpsec.initd
"
This diff is collapsed.
Click to expand it.
community/ntpsec/ntp.conf
+
1
−
1
View file @
051b9a82
...
...
@@ -8,7 +8,7 @@
# http://www.pool.ntp.org/en/
#
# iburst tells it to send the first few requests at 2 second intervals rather
# than wait for the poll interval, which defaults to 64 seconds.
That greatly
# than wait for the poll interval, which defaults to 64 seconds. That greatly
# speeds up the time for ntpd to set the system time and start responding to
# requests.
#
...
...
This diff is collapsed.
Click to expand it.
community/ntpsec/ntpsec-openssl.patch
deleted
100644 → 0
+
0
−
102
View file @
398aec61
commit ba368822d0a197cb84c46c911d40d0c52cf9c391
Author: Hal Murray <hmurray@megapathdsl.net>
Date: Sun May 2 22:24:26 2021 -0700
Update to OpenSSL 3.0.0-alpha15
diff --git a/attic/cmac-timing.c b/attic/cmac-timing.c
index c2088db63..464daa76b 100644
--- a/attic/cmac-timing.c
+++ b/attic/cmac-timing.c
@@ -225,28 +225,14 @@
static void DoPKEY(
#if OPENSSL_VERSION_NUMBER > 0x20000000L
static size_t One_EVP_MAC(
EVP_MAC_CTX *ctx, /* context */
- char *cipher,
uint8_t *key, /* key pointer */
int keylength, /* key length */
uint8_t *pkt, /* packet pointer */
int pktlength /* packet length */
) {
- OSSL_PARAM params[3];
size_t len = EVP_MAX_MD_SIZE;
- params[0] =
- OSSL_PARAM_construct_utf8_string("cipher", cipher, 0);
- params[1] =
- OSSL_PARAM_construct_octet_string("key", key, keylength);
- params[2] = OSSL_PARAM_construct_end();
- if (0 == EVP_MAC_CTX_set_params(ctx, params)) {
- unsigned long err = ERR_get_error();
- char * str = ERR_error_string(err, NULL);
- printf("## Oops, EVP_MAC_CTX_set_params() failed: %s.\n", str);
- return 0;
- }
-
- if (0 == EVP_MAC_init(ctx)) {
+ if (0 == EVP_MAC_init(ctx, key, keylength, NULL)) {
unsigned long err = ERR_get_error();
char * str = ERR_error_string(err, NULL);
printf("## Oops, EVP_MAC_init() failed: %s.\n", str);
@@ -255,13 +241,13 @@
static size_t One_EVP_MAC(
if (0 == EVP_MAC_update(ctx, pkt, pktlength)) {
unsigned long err = ERR_get_error();
char * str = ERR_error_string(err, NULL);
- printf("## Oops, EVP_MAC_init() failed: %s.\n", str);
+ printf("## Oops, EVP_MAC_update() failed: %s.\n", str);
return 0;
}
if (0 == EVP_MAC_final(ctx, answer, &len, sizeof(answer))) {
unsigned long err = ERR_get_error();
char * str = ERR_error_string(err, NULL);
- printf("## Oops, EVP_MAC_init() failed: %s.\n", str);
+ printf("## Oops, EVP_MAC_final() failed: %s.\n", str);
return 0;
}
return len;
@@ -290,7 +276,7 @@
static void Do_EVP_MAC(
clock_gettime(CLOCK_MONOTONIC, &start);
for (int i = 0; i < SAMPLESIZE; i++) {
- digestlength = One_EVP_MAC(evp, cbc, key, keylength, pkt, pktlength);
+ digestlength = One_EVP_MAC(evp, key, keylength, pkt, pktlength);
if (0 == digestlength) break;
}
clock_gettime(CLOCK_MONOTONIC, &stop);
@@ -305,26 +291,31 @@
static size_t One_EVP_MAC2(
uint8_t *pkt, /* packet pointer */
int pktlength /* packet length */
) {
+ EVP_MAC_CTX *dup;
size_t len = EVP_MAX_MD_SIZE;
- if (0 == EVP_MAC_init(ctx)) {
+ // dup = ctx;
+ dup = EVP_MAC_CTX_dup(ctx);
+
+ if (0 == EVP_MAC_init(dup, NULL, 0, NULL)) {
unsigned long err = ERR_get_error();
char * str = ERR_error_string(err, NULL);
printf("## Oops, EVP_MAC_init() failed: %s.\n", str);
return 0;
}
- if (0 == EVP_MAC_update(ctx, pkt, pktlength)) {
+ if (0 == EVP_MAC_update(dup, pkt, pktlength)) {
unsigned long err = ERR_get_error();
char * str = ERR_error_string(err, NULL);
- printf("## Oops, EVP_MAC_init() failed: %s.\n", str);
+ printf("## Oops, EVP_MAC_update() failed: %s.\n", str);
return 0;
}
- if (0 == EVP_MAC_final(ctx, answer, &len, sizeof(answer))) {
+ if (0 == EVP_MAC_final(dup, answer, &len, sizeof(answer))) {
unsigned long err = ERR_get_error();
char * str = ERR_error_string(err, NULL);
- printf("## Oops, EVP_MAC_init() failed: %s.\n", str);
+ printf("## Oops, EVP_MAC_final() failed: %s.\n", str);
return 0;
}
+ EVP_MAC_CTX_free(dup);
return len;
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment