Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Monitor
Service Desk
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
alpine
aports
Commits
03009d53
Commit
03009d53
authored
3 years ago
by
Leo
Browse files
Options
Downloads
Patches
Plain Diff
main/geoip: remove cron
See: #12950
parent
a0fb252c
No related branches found
No related tags found
1 merge request
!24623
main/geoip: remove cron
Pipeline
#93729
passed
3 years ago
Stage: lint
Stage: build
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/geoip/APKBUILD
+5
-6
5 additions, 6 deletions
main/geoip/APKBUILD
main/geoip/geoip.cron
+0
-7
0 additions, 7 deletions
main/geoip/geoip.cron
with
5 additions
and
13 deletions
main/geoip/APKBUILD
+
5
−
6
View file @
03009d53
...
@@ -2,15 +2,14 @@
...
@@ -2,15 +2,14 @@
pkgname
=
"geoip"
pkgname
=
"geoip"
_pkgname
=
"GeoIP"
_pkgname
=
"GeoIP"
pkgver
=
1.6.12
pkgver
=
1.6.12
pkgrel
=
1
pkgrel
=
2
pkgdesc
=
"Lookup countries by IP addresses"
pkgdesc
=
"Lookup countries by IP addresses"
url
=
"http://www.maxmind.com/app/ip-location"
url
=
"http://www.maxmind.com/app/ip-location"
arch
=
"all"
arch
=
"all"
license
=
"GPL"
license
=
"GPL"
makedepends
=
"zlib-dev"
makedepends
=
"zlib-dev"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc"
source
=
"https://github.com/maxmind/geoip-api-c/releases/download/v
$pkgver
/
$_pkgname
-
$pkgver
.tar.gz
source
=
"https://github.com/maxmind/geoip-api-c/releases/download/v
$pkgver
/
$_pkgname
-
$pkgver
.tar.gz"
geoip.cron"
builddir
=
"
$srcdir
"
/
$_pkgname
-
$pkgver
builddir
=
"
$srcdir
"
/
$_pkgname
-
$pkgver
build
()
{
build
()
{
...
@@ -29,7 +28,6 @@ package() {
...
@@ -29,7 +28,6 @@ package() {
cd
"
$builddir
"
cd
"
$builddir
"
make
DESTDIR
=
"
$pkgdir
"
install
make
DESTDIR
=
"
$pkgdir
"
install
mkdir
-p
"
$pkgdir
"
/usr/share/GeoIP
mkdir
-p
"
$pkgdir
"
/usr/share/GeoIP
install
-m755
-D
../../geoip.cron
"
$pkgdir
"
/etc/periodic/monthly/geoip
}
}
check
()
{
check
()
{
...
@@ -37,5 +35,6 @@ check() {
...
@@ -37,5 +35,6 @@ check() {
make check
make check
}
}
sha512sums
=
"a1c8120692a7ba6de5836550917f86f4797dd236a8b7d71b6f92b5389e4b071d89e57036654f5de1d4b762730a2a5c331c31414eab0c889c9befaa097941fee7 GeoIP-1.6.12.tar.gz
sha512sums
=
"
910b1efc93898416057aa7fc1a3f57d35f354973656ed40fbe266c737c4b4aa37f28b42e4163ed850a454c999bc880c27d863a04a14328b7b7e65348a85dd7d3 geoip.cron"
a1c8120692a7ba6de5836550917f86f4797dd236a8b7d71b6f92b5389e4b071d89e57036654f5de1d4b762730a2a5c331c31414eab0c889c9befaa097941fee7 GeoIP-1.6.12.tar.gz
"
This diff is collapsed.
Click to expand it.
main/geoip/geoip.cron
deleted
100755 → 0
+
0
−
7
View file @
a0fb252c
#!/bin/sh
wget
-q
http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz
-O
/tmp/GeoIP.dat.gz
&&
gunzip
/tmp/GeoIP.dat.gz
&&
mv
/tmp/GeoIP.dat /usr/share/GeoIP
wget
-q
http://geolite.maxmind.com/download/geoip/database/GeoIPv6.dat.gz
-O
/tmp/GeoIPv6.dat.gz
&&
gunzip
/tmp/GeoIPv6.dat.gz
&&
mv
/tmp/GeoIPv6.dat /usr/share/GeoIP
wget
-q
http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
-O
/tmp/GeoLiteCity.dat.gz
&&
gunzip
/tmp/GeoLiteCity.dat.gz
&&
mv
/tmp/GeoLiteCity.dat /usr/share/GeoIP
wget
-q
http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz
-O
/tmp/GeoLiteCityv6.dat.gz
&&
gunzip
/tmp/GeoLiteCityv6.dat.gz
&&
mv
/tmp/GeoLiteCityv6.dat /usr/share/GeoIP
wget
-q
http://geolite.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
-O
/tmp/GeoIPASNum.dat.gz
&&
gunzip
/tmp/GeoIPASNum.dat.gz
&&
mv
/tmp/GeoIPASNum.dat /usr/share/GeoIP
wget
-q
http://geolite.maxmind.com/download/geoip/database/asnum/GeoIPASNumv6.dat.gz
-O
/tmp/GeoIPASNumv6.dat.gz
&&
gunzip
/tmp/GeoIPASNumv6.dat.gz
&&
mv
/tmp/GeoIPASNumv6.dat /usr/share/GeoIP
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment