-
Michał Polański authored
Go binaries are statically linked, security updates require rebuilds
Michał Polański authoredGo binaries are statically linked, security updates require rebuilds
APKBUILD 780 B
# Contributor: Jordan Christiansen <xordspar0@gmail.com>
# Maintainer: Jordan Christiansen <xordspar0@gmail.com>
pkgname=cni-plugin-dnsname
pkgver=1.2.0
pkgrel=1
pkgdesc="Name resolution for containers"
url="https://github.com/containers/dnsname"
license="Apache-2.0"
arch="all"
depends="dnsmasq"
makedepends="go"
options="!check" # Requires root but 'checkroot' doesn't work with go programs
source="$pkgname-$pkgver.tar.gz::https://github.com/containers/dnsname/archive/v$pkgver.tar.gz"
builddir="$srcdir/dnsname-$pkgver"
build() {
make
}
package() {
make install PREFIX=/usr DESTDIR="$pkgdir"
}
sha512sums="
99fe827abcf7aca040c389122e02c39cd57f35de9bea8891907a5a69525bf1c52ba9a6478f2093d4eadd6a9fb31e9f29e42b03fc14d544ed2d15cc68e94ed0f7 cni-plugin-dnsname-1.2.0.tar.gz
"