-
Ariadne Conill authoredAriadne Conill authored
APKBUILD 1.53 KiB
# Contributor: Julian Weigt <juw@posteo.de>
# Maintainer: Julian Weigt <juw@posteo.de>
pkgname=asymptote
pkgver=2.70
pkgrel=0
pkgdesc="A vector graphics language for technical drawing"
url="http://asymptote.sourceforge.net/"
arch="all !mips64 !s390x !riscv64" #blocked by texlive
license="GPL-3.0-only"
depends="texlive texlive-dvi ghostscript"
### Optional dependencies
# gsl and gsl-dev for the support of certain special functions.
# fftw for fourier transform of data
# numpy pyqt5 cson and librsvg for GUI program xasy. I could not find cson for alpine though.
# freeglut for openGL support
makedepends="zlib-dev texinfo autoconf"
subpackages="$pkgname-doc"
source="https://downloads.sourceforge.net/sourceforge/asymptote/asymptote-$pkgver.src.tgz"
prepare() {
default_prepare
./autogen.sh
}
build() {
# Without specifying, the content of texmf goes to /texmf-dist in root dir
# Build hangs without --disable-gc
./configure \
--prefix=/usr \
--with-latex=/usr/share/texmf/tex/latex \
--with-context=/usr/share/texmf/tex/context \
--disable-gc
make asy
#-j1 is needed for building documentation with pdflatex due to probably race conditions
make -j1 all
}
check() {
### Other option:
#make check-all. Fails without gsl and gsl-dev.
make check
}
package() {
### Other options
#make install doesn't install html documentation
make -j1 DESTDIR="$pkgdir" install-all
}
sha512sums="24d60af361e3f0309a896ce8163da6fc0a9d6587efe726c5acf874dcb74f4d51b4bad8146a615ff54173ef06dac53117fd1cc09c77940271adc9f64cac6bcfe6 asymptote-2.70.src.tgz"