Skip to content
Snippets Groups Projects
APKBUILD 1.07 KiB
# Contributor: Fabricio Silva <hi@fabricio.dev>
# Maintainer: Fabricio Silva <hi@fabricio.dev>
pkgname=py3-plexapi
_pkgname=python-plexapi
pkgver=4.15.12
pkgrel=0
pkgdesc="Python bindings for the Plex API"
url="https://github.com/pkkid/python-plexapi"
arch="noarch"
license="BSD-3-Clause"
# tests requires an instance of plex running
# net for sphinx
options="net !check"
depends="
	python3
	py3-requests
	"
makedepends="
	py3-gpep517
	py3-recommonmark
	py3-setuptools
	py3-sphinx_rtd_theme
	py3-wheel
	"
subpackages="$pkgname-doc $pkgname-pyc"
source="https://github.com/pkkid/python-plexapi/archive/$pkgver/py3-plexapi-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"

build() {
	gpep517 build-wheel \
		--wheel-dir .dist \
		--output-fd 3 3>&1 >&2
	sphinx-build -W -b man docs man
}

package() {
	python3 -m installer -d "$pkgdir" \
		.dist/*.whl
	install -Dm644 man/pythonplexapi.1 -t "$pkgdir"/usr/share/man/man1
}

sha512sums="
8b5f36076b87e2941c4293aa94017c7cc00b680e207374c5ae5f8b8ab12ce83d1c9331bc174042095bd3461eb3926cb52635757e2099e63ffa660255fbbbaeb4  py3-plexapi-4.15.12.tar.gz
"