-
Natanael Copa authoredNatanael Copa authored
APKBUILD 760 B
# Maintainer: Michał Adamski <michal@ert.pl>
pkgname=py3-aiohttp-socks
pkgver=0.5.5
pkgrel=2
pkgdesc="Proxy connector for aiohttp"
url="https://github.com/romis2012/aiohttp-socks"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-aiohttp py3-attrs py3-python-socks"
makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/a/aiohttp_socks/aiohttp_socks-$pkgver.tar.gz"
builddir="$srcdir/aiohttp_socks-$pkgver"
build() {
python3 setup.py build
}
check() {
python3 setup.py check
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="18eb7cb6f8553596e5b973f0bffda71ce67f0b4298ad0006fff5353161ac656a0d87eb138c363683b411a42e2585f308625827bf896bbe53bb5cee2e8901b7a3 aiohttp_socks-0.5.5.tar.gz"