Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
TBK
aports
Commits
735829e7
Commit
735829e7
authored
7 years ago
by
Jakub Jirutka
Browse files
Options
Downloads
Patches
Plain Diff
testing/idris: fix and improve abuild
parent
92cf3505
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
testing/idris/APKBUILD
+32
-25
32 additions, 25 deletions
testing/idris/APKBUILD
with
32 additions
and
25 deletions
testing/idris/APKBUILD
100755 → 100644
+
32
−
25
View file @
735829e7
#-*-mode: Shell-script; coding: utf-8;-*-
# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
pkgname
=
idris
pkgver
=
1.0
...
...
@@ -6,22 +5,24 @@ pkgrel=0
pkgdesc
=
"A Language with Dependent Types"
url
=
"http://www.idris-lang.org"
arch
=
"x86_64 armhf"
license
=
"
bsd
3"
license
=
"
BSD
3"
depends
=
"gmp-dev gcc"
makedepends
=
"ghc cabal libffi-dev ncurses-dev zlib-dev"
install
=
""
subpackages
=
"
$pkgname
-doc"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://github.com/idris-lang/Idris-dev/archive/v
$pkgver
.tar.gz"
builddir
=
"
$srcdir
/Idris-dev-
$pkgver
"
_home
=
"
${
builddir
}
/deps"
_tmp
=
"
${
builddir
}
/tmp"
_home
=
"
$builddir
/deps"
_tmp
=
"
$builddir
/tmp"
prepare
()
{
default_prepare
cd
"
$builddir
"
install
-dm755
"
$
{
_tmp
}
"
"
$
{
_home
}
"
mkdir
-p
"
$_tmp
"
"
$_home
"
(
export
HOME
=
"
$
{
_home
}
"
export
TMPDIR
=
"
$
{
_tmp
}
"
export
HOME
=
"
$_home
"
export
TMPDIR
=
"
$_tmp
"
cabal update
cabal
install
libffi
-v
cabal
install
--dependencies-only
-v
...
...
@@ -31,9 +32,9 @@ prepare() {
build
()
{
cd
"
$builddir
"
(
export
HOME
=
"
$
{
_home
}
"
export
TMPDIR
=
"
$
{
_tmp
}
"
# Note, ordering of prefixes is important
export
HOME
=
"
$_home
"
export
TMPDIR
=
"
$_tmp
"
# Note, ordering of prefixes is important
!
cabal configure
--prefix
=
'/usr'
\
--docdir
=
'$prefix/share/doc'
\
--datadir
=
'$prefix/share'
\
...
...
@@ -42,28 +43,34 @@ build() {
--libsubdir
=
"
$pkgname
"
\
--datasubdir
=
"
$pkgname
"
\
--dynlibdir
=
"
$pkgname
"
\
--disable-shared
-fGMP
-fFFI
-fstandalone
--disable-shared
\
--flags
=
'GMP FFI standalone'
cabal build
)
}
doc
()
{
default_doc
# TODO: Run upstream tests and/or figure out how to set paths to be able
# to compile hello_world for check.
check
()
{
cd
"
$builddir
"
install
-D
-m644
LICENSE
"
$pkgdir
/usr/share/licenses/
$pkgname
/LICENSE"
./dist/build/idris/idris
--version
}
package
()
{
cd
"
$builddir
"
cabal copy
--destdir
=
"
$pkgdir
"
||
return
1
# We don't need the haskell shared libraries or interface files
find
"
$pkgdir
"
-name
"libHSidris*.so"
-type
f
-exec
rm
{}
\;
rm
-fr
"
$pkgdir
/usr/lib/idris"
# Move the docs from where cabal installs them so the doc pkg can
# find them
install
-dm755
"
$pkgdir
/usr/share/doc/idris"
mv
"
$pkgdir
/usr/share/idris/docs"
"
$pkgdir
/usr/share/doc/idris"
cabal copy
--destdir
=
"
$pkgdir
"
cd
"
$pkgdir
"
# We don't need the haskell shared libraries or interface files.
rm
-r
usr/lib/idris
mkdir
-p
usr/share/doc/idris/
\
usr/share/licenses/
$pkgname
/
mv
usr/share/idris/docs usr/share/doc/idris
mv
usr/share/doc/LICENSE usr/share/licenses/
$pkgname
/
}
md5sums
=
"bcc928484ce50389464be1e5c9893c9e idris-1.0.tar.gz"
sha256sums
=
"aaed0d01c0395cb7cac2562f689f8589072ad7568acaeb5e20451ffeebab963e idris-1.0.tar.gz"
sha512sums
=
"a350004a8510f01d1cc8f965a9a4e2dab219f003980b98354ebb5ae42f73b32c90c98dce193943e9709d994cb92ad35814a46b79412a1afc85d42e1018c6ba10 idris-1.0.tar.gz"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment