Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
aports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
TBK
aports
Commits
58231509
Commit
58231509
authored
7 years ago
by
Jakub Jirutka
Browse files
Options
Downloads
Patches
Plain Diff
main/ruby: patch Rubygems to avoid fetching platform-specific gems
For more information see description in the patch file.
parent
2a876880
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
main/ruby/APKBUILD
+5
-3
5 additions, 3 deletions
main/ruby/APKBUILD
main/ruby/rubygems-avoid-platform-specific-gems.patch
+31
-0
31 additions, 0 deletions
main/ruby/rubygems-avoid-platform-specific-gems.patch
with
36 additions
and
3 deletions
main/ruby/APKBUILD
+
5
−
3
View file @
58231509
...
...
@@ -4,7 +4,7 @@
pkgname
=
ruby
pkgver
=
2.4.1
_abiver
=
"
${
pkgver
%.*
}
.0"
pkgrel
=
2
pkgrel
=
3
pkgdesc
=
"An object-oriented language for quick and easy programming"
url
=
"http://www.ruby-lang.org/en/"
arch
=
"all"
...
...
@@ -28,7 +28,8 @@ subpackages="$pkgname-doc $pkgname-dev
$pkgname
-xmlrpc::noarch
$pkgname
-libs
"
source
=
"ftp://ftp.ruby-lang.org/pub/ruby/
${
pkgver
%.*
}
/
$pkgname
-
$pkgver
.tar.bz2"
source
=
"ftp://ftp.ruby-lang.org/pub/ruby/
${
pkgver
%.*
}
/
$pkgname
-
$pkgver
.tar.bz2
rubygems-avoid-platform-specific-gems.patch"
options
=
"!fhs"
replaces
=
"ruby-gems"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
...
...
@@ -225,4 +226,5 @@ _mvgem() {
done
}
sha512sums
=
"1c80d4c30ecb51758a193b26b76802a06d214de7f15570f1e85b5fae4cec81bda7237f086b81f6f2b5767f2e93d347ad1fa3f49d7b5c2e084d5f57c419503f74 ruby-2.4.1.tar.bz2"
sha512sums
=
"1c80d4c30ecb51758a193b26b76802a06d214de7f15570f1e85b5fae4cec81bda7237f086b81f6f2b5767f2e93d347ad1fa3f49d7b5c2e084d5f57c419503f74 ruby-2.4.1.tar.bz2
cfdc5ea3b2e2ea69c51f38e8e2180cb1dc27008ca55cc6301f142ebafdbab31c3379b3b6bba9ff543153876dd98ed2ad194df3255b7ea77a62e931c935f80538 rubygems-avoid-platform-specific-gems.patch"
This diff is collapsed.
Click to expand it.
main/ruby/rubygems-avoid-platform-specific-gems.patch
0 → 100644
+
31
−
0
View file @
58231509
From: Jakub Jirutka <jakub@jirutka.cz>
Date: Fri, 19 May 2017 19:56:00 +0200
Subject: [PATCH] Rubygems: don't install platform-specific gems
Gems with native extensions typically contain just source code that is
built during installation on user's system. However, Rubygems allows to
publish even platform-specific gems with prebuilt binaries for specific
platform. The problem is that Rubygems uses only short platform
identification like x86_64-linux; it does not identify used libc.
And sadly platform-specific gems for linux are built against glibc, so
they may not work on musl libc.
This patch is a workaround for the aforesaid problem. It removes local
platform from Rubygems' supported platforms to force it always pick
a platform-agnostic (source) gem. Users can override it using
`--platform` option.
--- a/lib/rubygems.rb
+++ b/lib/rubygems.rb
@@ -743,7 +743,10 @@
def self.platforms
@platforms ||= []
if @platforms.empty?
- @platforms = [Gem::Platform::RUBY, Gem::Platform.local]
+ # XXX: Patched to avoid installing platform-specific gems with binaries
+ # linked against glibc.
+ @platforms = [Gem::Platform::RUBY]
+ #@platforms = [Gem::Platform::RUBY, Gem::Platform.local]
end
@platforms
end
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment